Mocha keeps crashing

Mocha keeps crashing on my mac while I’m trying to do a project. This has only been the case the past couple of days.

Every time I save or try tracking the background on this boom mic remove it freezes and crashes. When I open the plugin back up it asks me if I want recently unsaved file. If I try anything other than open it crashes. Save as it freezes even more.

Tried deleting mocha and re downloading the plugin. Checked both my mac and mocha / AE for software updates. Tried reinstalling mocha and after effects. Also tried switching the cache directory and deleting all the files and creating a new folder for cache. Keep getting the same errors. Would love a workaround here.

If you need any info from me to get a better understanding as I know this is pretty broad just message.

Regards,
Michael

Okay, let’s start by getting the mocha.log from “View Log” in the Help menu. This will help us narrow down the specific crash. It will also help us not have to ask several questions. Many of our questions are answered by first getting this log file. :slight_smile:
It would also be helpful to get the crash log under the “Report…” button that appears that looks like this:
mocha crashed report button




mocha.log.zip (209.5 KB)

Can you check your write permissions in ~/Library/Application Support/BorisFX/ please? It appears it’s having trouble saving the autosave file.

You mean this?

Well that definitely looks like it’s saving. Hmmm… Are you able to share the project?

Possibly too extreme but ultimately used first aid on my hard disk and came back saying it failed/was corrupt. Thinking it was different placements of my old/new files when transferring over to a new mac.

Anyways, thru recovery mode I decided to erase everything I had and start anew but before backing up all my project files.

Reinstalled macos, got all my apps/settings back. But when I’m trying to open mocha and get back to the project now I now receive this message…

Had to create a new admin but I still have the activation key but still signed into mocha before I erased everything.

Have all my AE files and plugins on an external drive, how do I go about deactivating the old license so I use this version of mocha without it thinking I’m using more than one computer. Have a couple days left till the subscription ends so time is of the essence.

Hi, until Martin gets back to you, try the App Manager,
if it’s not already in your Start menu

Already just reset it from signing into my account but still having the same problem where my app keeps freezing on me in mocha and crashing when I either save it or try to track again. Very fustrating

mocha.log.zip (10.2 KB)

usage_data-mocha.txt.zip (3.6 KB)

Try setting your preferences to default:

  1. Load Mocha
  2. Go to Preferences
  3. Click the “Restore Defaults” button in the lower left corner
  4. Click OK
  5. Close Mocha and restart the host.

Hi Mike, did this help?

Sorry for the delay,
I ended up repairing my disk and redownloading my mocha again.

Everything works but now it crashes but only when crank the contrast up in the preprocessing window before I track forward or backwards. It freezes and mocha crashes.

I leave the preprocessing alone and it tracks without crashing. Problem is the footage is kinda grainy and would like to be able to see what I’m tracking better so it would be ideal if I could use both.

Don’t know if this is a bug or not. Know a fix?

Hmmm… that sounds like a bug. Can you post your Mocha log, please?
You’ll find it under the Help menu under “view log…”
Post the whole file so we can check the current system and what might be causing it.

mocha.log.zip (20.3 KB)

Here’s an attempt I tried doing just now, the crashing is still happening.

Okay that was not as illuminating as I had hoped. Are you getting a crash report dialog? If so, can you copy the information from this dialog please?
mocha crashed report button
Click the “Report…” button and copy the field to a text file: