Mocha OFX 2025.5 only loads first frame of a shot

I upgraded to MochaPro2022.5-OFX-9.5.0 from 2022-OFX-9.0.1-49. And in the same scripts suddenly my shots only loads in the first frame and I can’t find a way to reload the footage, even if I reload it and it says for examples 64 frames in the clip tab, it still only loads the first frame and puts the framerange to 1.

I tried to revert back and then it loads the shot correctly but then my wacom middle click stopped working.
I tried both prores and exr’s.

I’m on Windows 10 and Nuke 13.0v2.

Cheers

1 Like

I am going to flag @martinb on this, it sounds like a bug.

Hi @martin.sazesh

That’s odd, there haven’t been any frame offset changes between v9.0.1 and v9.5.0.
If you roll back to v9.0.3 (here) do you still get the same problem?

What was the original range, just 1-64, or with an offset like 1001-1065, etc?

I was starting at frame 1, tried to pop in an framerange node before the mocha node but no difference.
Strange thing is that it seem to work alright when I put the read node to start at 1001 and then open it in mocha, then the shot loads and the framerange works 1001-10…

v9.0.3 seems to have the same issues. However it worked on one of my shot that didn’t work on 9.5.0. But one shot that worked on 9.5.0 didn’t work on 9.0.3.

It’s all very confusing.

Is it possible you’ve set your preferences in v9.0.0 to adapt to the fixed frame offset and not in v9.5.0. Mocha preferences, are the options set in the lower-left corner here the same?

Can you attach an example nuke file? You don’t need to include the footage.

Yes the settings are the same.
The work around now is to convert to exrs and to set start at 1001 then it seems to work everytime.
I dont think it is the nukescripts that is the problem. I can open a clean one and load the footage and it still doesn’t work either. I tried nuke 11.3v6 aswell.

Cheers

This has happened to me recently several times too. I never fully light-bulbed it, it seems to be impacted what node is selected in the tree and where the viewer is connected to. Usually closing Mocha, reselecting the node in the tree on the second go-around I get the whole clip. Has been annoying but not a show stopper for me.

Does feel like a bug though.

1 Like

Seeing the same thing in 2022.5 via Resolve 17.4.6
I was able to get it to work by exiting out of the MochaUI and changing the length of the clip. When I entered the MochaUI again, it showed all the frames.

In Resolve, 17.4+ there’s a problem with both the edit pages and the color pages feeding in unedited footage.
It seems to have been fixed in the Resolve 18 beta, but not without some other stability issues.

Jan, this literally solved my problem. What a weird bug !

Since my last post earlier in this thread I’ve tracked it. And in Nuke you have to set the viewer to the Mocha Pro node before launching the UI otherwise you will be unhappy.

It’s not hard to do, just annoying to remember.

Would be nice if this can get fixed. Not sure if the problem is on the MochaPro side or on the Nuke side. I’ve seen in this on multiple system with different versions of Nuke 13.

1 Like

We have a defect flagged for it. We did implement a workaround for this way back in Mocha v5, but it has since resurfaced, so we’ll be taking a look at it again in future updates.

1 Like