Mocha Pro 2020 plugin not working with Vegas Pro 17

Hi!
I installed MP2020 a few days ago and have tried to get it going together with Vegas Pro 17, as a plugin, but have failed utterly so far. Not even basic functions work. I have read the Mocha manual and watched the few videos about the topic, and followed the instructions as close as I could. Do I do something wrong, or is there a bug in the MP software?

In short:

  1. Failed method #1.
    On the Vegas timeline I put a video on a track (track 2) and add another video on the track above (track 1). The video on tr2 is to be tracked, and the video on tr1 is to be inserted into the video.
    The tr1 video is shown in the preview window.
    I now make tr2 the child to the first track.
    Tr1 (the parent) compositing mode is switched to Custom, and Mocha Pro 2020 is selected as effect.
    Now the Preview window in Vegas suddenly turns black.!?!?!
    Anyway, I go on. The Mocha Plugin appears and I click Launch Mocha UI.
    The UI opens but the video window is black. So there is no video visible, just the Mocha UI. So it is impossible to do anything at all here.
    (this is how I understood the manual to be the correct method)

  2. Failed method #2
    Back where we started on the timeline. The two tracks are there with video on each. Tr1 is made the parent. Here’s a difference though: I select the combined menu at he left of the two tracks and enter compositing mode, and select Custom, and select Mocha Pro. Now the video on tr2 becomes visible, not the tr1. So far so good!
    Mocha UI is launched and the tr2 is visible in Mocha. Great.
    However, Mocha creates a timelive that is about 8 times longer than the video clip, so most of the timeline is black. Why???
    So I insert an out point where the video ends and zoom in.
    I make an Area brush, or X-spline, and manage to track an object without problem at all. The tracking is fine.
    In the Insert module I select Insert layer in the Insert clip box.
    Now I guess the tr1 video should be visible as inserted, right? But nothing. If I select Logo or Grid the are visible as inserted as tracked though. Anyway I select Insert layer again.
    I save and close the Mocha window and go back to the Mocha Pro effect plugin in Vegas.
    There I check the Render box and select the Insert: Composite module.
    But nothing appears inserted.
    So this failed too.

  3. Failed method #3
    Now I only have one track in Vegas, no Custom compositing mode, nor any parent/child tracks. I’ll try to do it all within Mocha.
    I add Mocha as an effect to a video event, open it and the UI and manage to track an objekt.
    Now I will try to insert someting.
    If I select Logo or Grid: these will show correctly in the tracked mask.
    If I select Import Clip: Selecting a reasonably small jpeg still image works and it follows the tracked mask. I close Mocha and go back to the effect window in Vegas and select Render and Inset: Composite. The video appears in the VEgas preview now with the inserted image correctly tracked. Great, however the timeline slows down to just 1 or 2 fps!!
    I make a region and render it out. The rendered file shows the inserted image totally off the tracking, like with a 2-3 sec delay after the object it should follow. So no good!

  4. Failed method #4
    The same mehid as #3 with the difference that I select an ordinary mp4 video clip instead of a still jpeg.
    Now Mocha doesn’t accept the file format. An error masseage appears saying:
    ‘Failed to open file… The file is corrupted or in an unsupported format.
    Please visit the media support page:’ and a link to Imagineer systems.
    and another error box says: Unable to load footage.
    I click the link suggested and it leads me to a webpage saying ‘404 not found’, a dead link.

I also tried other combinations of tracks, parents and child, etc etc. But nothing works. MOcha Pro seems totally useless. Or is it something wrong that I do? Or is it something with Vegas?
Please advise me, I need it to work.
Yours
Martin L, Sweden.

Great to see you here Martin :sunglasses:.

G

I am going to need to check in with @martinb on this one. I think we are experiencing some pain points with Vegas we need to work out.

1 Like

Hi Grazie!

Hi Maryp!
Thank you for recognizing this. I gave the whole day today to try to get Mocha going with Vegas. I followed all instructions I could find but nothing really worked. I also tried BCC witness protection with Mocha tracking and it worked, but that’s about it. Tried also the route Witness protection - Mocha tracking - and export of tracking data to another effect, like corner pinning, but there was no way of exporting the tracking data from Mocha. The export tracking data option used to be in the Track module, now it’s not there.

Strangely it seems to work for Grazie. He seems to be happy with it… We have almost identical machines and the same version of Vegas and Mocha as well as BCC.

Hoping for your help. Thanks in advance!
Martin

OH! The Mocha in BCC isn’t for copying and pasting data out of, it is just meant to drive the Continuum effect. Maybe that’s the difference.

Mocha Pro 2020 not reading properly in Vegas is something we will have to test on our end and see if we can repeat it.

Thank you for letting us know.

To amplify on Mary’s point about using Mocha in Continuum, as of the Continuum 2019 version (aka V12) the Mocha integration for parameter tracking was revamped so you no longer need to export and then re-import the data. Now it’s all contained directly in the single Continuum effect instance - much simpler! Here is a video that shows the workflow for using the integrated Mocha to drive parameter data in Continuum. This tutorial uses Media Composer to demonstrate, but the workflow would be the same for Vegas:
https://www.youtube.com/watch?v=n4yS56nDzok

Cheers,
Jason

I’d like to see that happen? Are you able to confirm this? I’m asking as the process Vega<>Mocha<>Vegas is presently coming under question. Maybe a MOCHA Developer could jump in here and give feedback. This is very necessary more than ever.

Ok, right? I watched some tutorials that outlined that way to do it but I guess they were a few years old, before 1919 version came.

Hi Martin,

A few things here:

  1. I’ll have to investigate this one. The standard insert method should work.
  2. Track-level input to Mocha reads the WHOLE track. That’s just the way Vegas handles track input to OFX plugins. Event FX only read in the clip.
  3. The timeline will definitely slow down. You’re rendering composited frames, not playing realtime effects. OFX roundtrip for Mocha is Input > Mocha > Render > Output so there’s a bit of a round trip to get frames to the timeline. As for rendered regions, we’d need to investigate, as I don’t know how Vegas handles these. If it literally crops the frame the input > output may be changing. We’ll check this.
  4. If you don’t have QuickTime installed you can’t import clips externally. MP4s can be anything but ordinary as they can be written many different ways by different hardware and software. In general, we don’t recommend importing MP4 as it’s slow for accessing frames.

Hi jclement and thanks for the tips.
That is good news. I watched the tutorial in your link. Let’s see if I will work in reality.

Hi and again thanks for bringing this to your attention.

  1. Still black today.
  2. Same results today. But now I understand from your answer that it is normal for Mocha to read in the entire track length. This is a minor problem since you can set the out point where you want and zoom in.
  3. Slowing down a bit is kind of normal, but not to 1 or 2 fps. That is outrageously slow, especially since I have a brand new monster machine. There must be somthing weird going on in the code here.
  4. So QT should be installed on my new machine then? Is that what Mocha needs? What version of QT? If Mocha has a hard time with mp4, the most common video file format, then what format is recommended?

My request to Boris/Mocha is to write a better manual. Perhaps part of the fault is on me, if I haven’t understood it correctly. The present manual is sparse and short. More explanations, step by step procedures and examples are needed. For example, is it the parent track that should be made Custom and opened in Mocha, or is it the combined track?
A few good and updated video tutorials would also be very helpful, if they are not too sparse. Better with a 15 min comprehensive one than a 5 min condensed that leaves me with a bunch of unanswered questions. Of course I understand this is time consuming for you, and probably you also would very much like to do this, but time is not enough for everything. But I think this should be a priority since this world class tracking software is now virtually useless with Vegas.

So thanks again for checking in on this. I am eager to get Mocha going.
Martin

Hi Martin

You can get QuickTime for Windows directly from Apple’s website at

[https://support.apple.com/downloads/quicktime]

The last version is 7.7.9 from 2016. I recall reading elsewhere that QT development for Windows ended some time ago.

When installing, I recommend using the Custom install selection (or similar name) to select only the QT software and not the extras like the QT Player. On Saturday, I had to rebuild my editing computer from the ground up - right from a clean install of Windows 10 - due to some strange behaviour of some programs that I couldn’t identify - and there were no restore points before a recent W10 upgrade. It was on installing QT that I became aware of the choice of what QT programs to install.

Besides taking over a day to do, the positive was a clean install without the ‘ghosts’ of older no-longer-needed programs hanging around in the registry given that I only installed currently needed programs.

I hope this helps.

Cheers

Conrad

Thanks, but is QT required to run Mocha Pro or not? If not I’d rather not install this old piece of unsupported software.