Mocha Pro 2020 - Unable to Track: Input frame from clip Input doesn't exist

Hi! I haven’t been able to get a single successful track from Mocha Pro since installing 2020. Every time I try, I get an Unable to “Track: Input frame from clip Input doesn’t exist” and if I try to manually track to the next frame the Interface shows “Memory Error”. It doesn’t seem to matter where the source clip has come from or how long it is and it is happening on clips that I have tracked successfully in previous versions. I’m using an i7 Surface Book 2 with a Nvidia GTX1060 DGPU and 16GB RAM and have only After Effects and Mocha Pro running. Most of the video I’m trying to track is MP4 4K from either a Sony A7RIV or a Mavic 2 Pro and I’m launching it from After Effects CC2020 though I’ve been having the same problems with CC2019. Can anyone help me to resolve the problem???

When you play back the clip (rather than track it), do all frames appear?
That error suggests AE is not giving Mocha some of the frames.
What happens if you try a format that is not an MP4, say ProRes or DNxHD?

Do you see the same problem if you install Mocha 2019.5?

Hi Martin, If I play it back after I have had the error, nothing appears after the frame the error happened on - I just get a black frame with “memory error” in the middle. If I play the clip back BEFORE I try to track it, I still get the error but it takes about twice as far into the clip to appear. I’ve tried this with other file formats today and get the same results. I’ve also tried uninstalling 2020 and reinstalling 2019.5 and it gives me the same error - albeit further into the clip than on 2020. I haven’t got any of the assets I know that I have tracked successfully before with me so I can’t check them. I’m at work though so I don’t have a lot of scope to experiment. I will try some different approach tonight - including reverting to 2019 (which might be the last version I had any success with)

Bruce, can you disable GPU tracking in the Mocha prefs, then resetart After Effects and retry?
Just curious if it is related to your GPU card.

OK, some further experimentation based on both of your suggestions has given me some success. First I transcoded to a series of different formats, leaving the footage in 4K. None of those tests worked and they all yielded the same results with the same error. Next I tried transcoding and reducing the resolution to 1080 and was able to get a proper track on footage in a range of different formats. Next I tried the suggestion to disable the GPU in Mocha Preferences and that worked too. I guess the GPU isn’t fully supported even though it has worked before. To be fair, I’ve also looked at the list of supported cards and the GTX1060 isn’t on it - though I thought I had checked this more than once before - albeit a while ago. I try to keep the drivers up to date so maybe it is something related to recent drivers and I might try rolling them back and doing some more tests when I get the chance. Thanks very much to both of you for your help!!

I’m sorry, that i’m asking too late, but where I can disable GPU tracking in the Mocha?

Hi Frank,



Hi Bruce,
Could you supply us with a copy of your imagineer.log file. It could be useful to see what was failing when tracking with the GPU.

After doing all things that discussed above I still get that same problem…" Unable to track and black screen showing memory error"

Update: I was tracking the clip forward it was showing that error in last 3sec…
This time what I did is, I tracked that same clip in reverse direction it’s went well in first then at last (as I told you i am tracking in reverse direction) it’s shows same error with same time that’s last 3sec…
So what’s my conclusion is my clip is proper but problem is there in mocha…

I need more information, as the above thread is nine months old.

Is your screen black in Mocha before you start tracking?
Are you using Mocha Pro or Mocha AE?
Are you using the Plugin or standalone?
What type of footage?
Is the footage being read properly?
What GPU are you using?
Is your GPU currently off or on?
Is there a larger shape above the shape you are trying to track that would hold out information from the shapes below it?

I won’t be able to help you without more information, but am happy to when I know more about your issue.


Mocha pro
MP4 shot on Samsung mobile
Yes, being read properly
Nvidia GE force 920MX
No but the subject that I am tracking that takes 90 % of the frame

If there is no more texture for Mocha to track, say because 90% of the frame is phone, you might need to manually hand track those troublesome frames using “Manual Track.”

1 Like