Mocha Pro 2021 8.0.2 OFX for Nuke - READING FRAME RAT BUG

@maryp

Hey Mary,

sorry to bother you but I found the following problem when using the Mocha Pro OFX Plugin for Nuke:

Mocha Pro does not take over my the frame rate I define in my Nuke Project Settings

I stumbled upon this when I tried the new alembic export for the first time.
I had a clip with 29,97 fps and my project settings in Nuke where the same, but the imported abc.-file from Mocha created a Camera-node with 24fps and ReadGeo-node with 24fps as well.

So I made several tests.

  1. In Mocha Pro, I could check (but not touch, because its not the standalone version) the Projects Settings.
    It showed me 24fps.

  2. Under the tab Clip I could compare the other clip attributes and everything was correct besides the framerate. 24fps.

  3. When I imported the clip directly in the same Mocha Project it would read the FPS correctly. But the exported abc-file would still show me 24fps in Nuke (I guess because it depends on Mocha’s Project Settings…which should be driven by Nukes Project Settings :thinking: )

  4. This got me thinking:
    “Maybe it’s a footage issue”
    My first footage was a Mov with 29.97fps. So I tried an EXR with 25fps. I created a NEW script, changed the project settings accordingly. Still 24fps in MochaPro.

  5. Next test:
    “Maybe its the mocha chache or nuke chache.” So I cleared both, just in case. Didn’t help.

  6. Questioning my own sanity I asked a freelance buddy to do the same test but with different footage. He had the same issue. Mocha Pro always defines the FrameRate as 24fps.

Now I’m out of ideas and need your help,please :slight_smile: :pleading_face:

As already written in the headline, I used Mocha Pro OFX 8.0.2
And I tested it in Nuke 12.2v5 and in Nuke 11.3v4 as well.

LG vom MG

PS.: It’s kinda weird but in Nuke the alembic file seemed to match, although it used the wrong frame rate.
But when I changed the frame rate in both Camera- and ReadGeo Node to the Clips and Project Settings frame rate it went completely astray.

So maybe it’s just a “cosmetic issue” in the end. But it’s still strange and alarming :worried:

1 Like

It’s never a bother, thanks for bringing this to our attention. Let me discuss with @martinb and see if we know about this and have a workaround.

1 Like

Hey there,

As long as you keep your frame rate the same in the geo/camera imports you should be fine, as they will adapt to the project playback.
I’ll confirm with the dev team about whether we can actually get the correct frame rate displaying, but as you discovered yourself, just leaving the values alone will work correctly as everything conforms to the Nuke project settings.

1 Like

Wow, that was a fast reply :open_mouth:
Thanks for reacting so fast :slight_smile:

PS.: I just watched one of your webinars (it’s probably my 100000th one) and you problably get this a lot but it’s really nice listening to your voice while your explaining :slight_smile:

Thanks Martin,

so it really is a “no touch no worry” situation… I can live with that :smiley:
I let my colleagues and my freelance buddy know.

I have the same Problem and its rly bad. And everything in my project is 25 frame but in mocha und 24!

I Imported the project from AE project and now nothing Match.

The same project in AE is 25 frame and in Nuke 24!



And the Mask dosent Match!

Hi there,

Did you change the AE project settings to match the Nuke settings? Because that is not something we can account for. You have to make sure your projects match for the Mocha files to cross-pollinate.

That sounds like project settings and not the same bug. But let me know if Mocha isn’t reading the same frame rate as the host project and we can double check if this is related to the same issue.

Cheers,
Mary

Thank you for your answer.
It look like a cosmetic Issue, like another guy mention that.
But here a Image from AE project.

In AE is everything on 25( project, comp, Video) but in Nuke on 24.

Right, but if the project settings are not the same between AE and Nuke, that’s not Mocha, that’s the project settings for those projects. The Plugin just reads from the host project. If your settings are not in alignment, the projects will not be in alignment.