Mocha Pro 2021 Not rendering correct in Blackmagic Fusion

I’m able to track (power mesh) and compose with some grafics with stabilize:warp.
I can preview and it works. As soon as I add a saver node and press render … the track is jumping around!
Testet with Blackmagic Fusion 16 and 17 Beta 3. I`m on Windows 10 Pro.

I think this is likely a bug, likely your clip has been trimmed and it is not the same size as the comp, so the data is pasting in off the timeline. We are working to correct this bug. In the meantime, trim the clips you want to use Mocha Powermesh with to the size you need and the same length as the comp/file.

I am also tagging @martinb here in case he has any insight.

Hi @nico.massimo Can you show me your node setup, please?
What format specs are you saving to?

I enclosed a screenshot of the node setup.
The Footage is passed to the first MochaPro node - where I made a power mesh track.
The second MochaPro node is a copy of the first one.
The First Node has Render:stabilize Unwarp, the second one Render: stabilize Warp.
I can playback in Fusion and it plays right.
As a format for the save node I tried : .jpg, .png and Quicktime. All with the same wrong result.

Curious. Okay.

One thing you might want to try is re-jigging the nodes so you only need the warp output of mocha pro 2_2:

  1. Turn OFF the unwarp in the first mocha pro
  2. Cut the merge from the between the two mocha pros and paste it between the mocha pro 2 and the write node so that the mocha pro 2_2 becaome the foreground input
  3. Wire the Image you want to warp into the mocha pro 2_2 source
  4. Wire the original source into background of the merge

This means that you are now only warping the image tree via mocha pro 2 and merging over the original.

Now, this of course depends on whether you’re using an alpha patch on the image nodes. If you’re using a full plate, this may not work as you ere originally merging on top of the full unwarped output.

Hi,
with the new Mocha Pro Update my setup works!
I tried your setup suggestion - but that seems not working.
When I try your setup … the Mocha node won’t update when I go foward in Time. It stays on the first Frame.
When I pipe the original footage in the mochapro everthing updates correctly!
Could it be that source footage is a movie clip and the grafik is a still image?