Mocha Pro 2021 not tracking properly when 'scale' selected

with Trans and Scale selected, i have tried tracking an object using both the OFX Plugin (in Resolve 17) and MP 2021 standalone, and i experience the same problem - on the second frame, the track shoots up and off the object and the tracking process is ruined. MP keeps trying to track the item, but it is way off.
if i track the same object with just Trans selected, then the problem does not occur and until the object starts scaling and rotating the track copes quite well.
any elucidation or suggestions will be gratefully received.
julian

Sounds like a tricky track. Have you tried increasing the search area for scale in the tracking options? The Search Area defines ranges for the tracker to search within. It has the following adjustable parameters:

  1. Horizontal/Vertical: The distance of pixels in the footage to search for the next object position. This is set to Auto by default.
  2. Angle: If you have a fast rotating object, like a wheel, you can set an angle of rotation to help the tracker to lock onto the detail correctly. The tracker will handle a small amount of rotation, less than 10º per frame, with Angle set to zero.
  3. Zoom: If you have a fast zoom, you can add a percentage value here to help the tracker. Again, the tracker will still handle a small amount of zoom with this set to zero.

You can adjust any of these values to get a better track, but it will take more time to track as Mocha is searching through more areas.

If that doesn’t work, I’d try translation only and then adjust track the scale in adjust track. Luckily we just updated the module to be easier to use: https://borisfx.com/videos/mocha-pro-2021-improved-adjusttrack-module/

You can also try tracking with the CPU instead of the GPU and seeing if that helps. The algorithm is slightly different and sometimes switching to CPU processing by going to file>preferences>gpu tab and unchecking the GPU processing box and restarting can help track very tricky shots.

Can you try those options and let me know?

Cheers,
Mary

hi mary,
thanks for this detailed response. in fact the track i am trying to do is the second one in ‘More Essentials Mocha AE’, lesson ‘02A Translation Scale and Rotation’. it seems to work very nicely for ben and i have tried to copy his screen exactly, but i must be doing something wrong. if you or he were able to access the footage and try with MP 2021 (ben was using 2019 i think), it may be that something has changed in the code recently?
julian

Can you send me the footage?

yes, sure. two files sent (video lesson and footage) via wetransfer to your email address.
julian

Sure, just email it.

so far, i simply increasted the size of the tracking selection (having misunderstood what you were suggesting re increasing search area!) and now the track works! in the coming days, i will try all the things you suggest properly just so that i understand the effects of these different parameters and adjustments.
thanks again,
julian