Mocha pro 2021: Unable to track: Input frame from clip Input doesn't exist

This is for version 8.0.1 of the Mocha Pro 2021 plugin for AE.

I am trying to track a .r3d file that is 6k in a 4k pre-comp (my final output resolution). After one or two frames it consistently fails and displays the error “Unable to track: Input frame from clip Input doesn’t exist.” I’ve tried on an output of a 4k ProRes version. I have tried brightening the shot with a curves effect. I have denoised the shot. I have tried turning off the GPU tracking for Mocha, and flushing the cache. Nothing works.

The same tracks have worked in the standard Mocha AE plugin.

The Power Mesh, the function for which I bought the plugin, doesn’t work at all. that just ends up with a black screen and says, “unknown error.” Is there any way to get this expensive plugin to function?

Screen Shot 2021-01-02 at 5.07.22 PM|492x300

It seems to be a cache issue. Now Mocha keeps pulling up frames from the cache in the wrong place. I’m just doing a basic track around a shape (an eye), and as I go frame-by-frame it keeps displaying the wrong frame.

I’ve checked the video file and it is fine.

This is an issue with Mocha.

Hi Paul,

Do you experience the same issue with a non-R3D file?
“Input frame doesn’t exist” errors, usually mean Mocha is unable to get the frame from After Effects for some reason. Usually this means we’ve requested a frame from After Effects and it hasn’t supplied it.

If you can also supply the log file from Mocha’s help menu (under “view log”) this will help us determine the exact nature of the frame problem.
The PowerMesh error will be directly related to your frame reading error, so if we can solve the first, the other problem should go away.

Yes, the same issue persists with a ProRes file.

The log file is 56mb so I can’t include as an attachment. I copied and pasted from the log file the last two days into a .txt file.

It also includes a time period this afternoon of using the Mocha AE version just fine on the same footage.

Thanks,

Paul

imagineer log file PMyers 01-03-21.txt (7.88 MB)

Paul, can you try purging both your After Effects cache and the Mocha cache?
Can you also tell me how much disk space you have remaining on your Mocha temp directory? You can see this in the output settings in MOcha Preferences.

I have purged both the mocha pro and the ae caches.

here is a screen grab of the preferences. It says there is 1TB available.

The problem is still happening.

Hi,

Any answer on this issue? I paid over $250 for this plugin and I haven’t been able to use it.

Hi Paul,

This still seems to be a problem of ingest, so we’re trying to figure out why the size of your footage is causing a problem.

  • What is the exact pixel dimensions (width and height) of the layer you’re bringing into Mocha?
  • What is the exact pixel dimensions (width and height) of the original file?
  • If you bring in the file as AE’s half or quarter resolution (as opposed to full) do you see any issues?
  • If you DON’T scale the file down into a 4k comp do you still get the same problem?

Hi,

The R3D files are 6144x3160. They are scaled down and nested in a precomp that is 4096x2160.

I have tried tracking at the full resolution in it’s own comp (6144x3160), and doing those same files at half, third and quarter resolution. They worked at a quarter res without having the same caching issues for a bit, but now it crashes when I try to do that. And still stops tracking if I have the footage precomped.

The mesh tracking is also malfunctioning. It works for a few frames then jumps to a completely different part of the image, or the tracking points get all tangled up. Then it crashes.

Thanks.

How much memory do you have allocated in After Effects?

How much memory is allocated in Mocha?
You can find the memory on the Mocha “System” page in preferences. I’d also like to look at the GPU page please.

Here are the screengrabs for each of those…

Here’s somethings I would change:

  1. Set your Max memory usage in Mocha to 50%. The 90% is too high and is probably taking away resources from After Effects. This means you could also up your AE load in RAM to about 16GB.
  2. Change your “Amount of Texture RAM to reserve” to about 512. This relates to what is displayed on screen, not processing, so this value doesn’t need to be high.
  3. Use GPU processing and change from “Automatic” to your preferred graphics card. In your case this would be the AMD Radeon R9 M295X. TBH, that card is very old (2014), so the performance boost would be minimal, but it may give you better memory handling compared to direct CPU.

After these changes, reboot After Effects and see if you get any improvement to the processing.

This is still persisting. As I have a ton of work to do I haven’t been using Mocha Pro as it just doesn’t work for me. Almost every time I use Mocha AE it works the way it is designed, but anytime I use Mocha Pro to do things that aren’t included in the AE version it breaks.

The latest was using a PNG sequence that is 3840x2160. I was trying to track a flat surface in the native resolution at full quality in order to do a camera solve… It looked good for about 180 frames out of the 218 and then said, “track terminated prematurely”. When going back through the sequence the tracking area is now all over the frame in random places.

So per your last email there hasn’t been any improvement in processing.

This is a forum post and isn’t an email, just to let you know so you don’t post any sensitive account information in response. You can use emails to reply on forum posts, which is convenient and yet confusing sometimes.

I can take a look into your machine later if you have the time. Send me an email at maryp at borisfx.com and let me know your timezone, availability, and the best number to reach you at and I will reach out.

Cheers,
Mary

I came across this prob and couldn’t work out what the f- was happening. It’s something to do with Mocha running out of memory when working with large resolutions. I find Mocha super unstable with 4K and above and I’m working with a pretty beefy system / GPUs.

If anyone finds it useful ----->
I solo’d the layer I was tracking and then also hid any effects on that layer while working in Mocha. For me the main problem was RealSmart Motion Blur that I was applying to the Mocha matte.

dd

I have found that the only way to get it to work on hi-res (bigger than 4K) is to do it at half resolution and just ignore the pop-up warning.

Soloing can especially help in the newest AE release, so I am glad that worked for you. Or turning off caching in the background. Martin recently made a video on performance in the newest version of AE: Mocha Quick Tip: Faster Playback in After Effects 2022 - YouTube