Mocha Pro AE Plugin Crash

Mocha crashed twice so far when rendering remove module. It crashes my AE. :frowning:
Whats is happening?

Here’s the report

Process: After Effects [25782]
Path: /Applications/Adobe After Effects CC 2018/Adobe After Effects CC 2018.app/Contents/MacOS/After Effects
Identifier: com.adobe.AfterEffects
Version: 15.1 (15.1)
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: After Effects [25782]
User ID: 501

Date/Time: 2018-04-13 19:46:48.454 +0100
OS Version: Mac OS X 10.12.6 (16G1314)
Report Version: 12
Anonymous UUID: AC0CEF7F-D46A-83FC-CFFE-610AF5D2B4C4

Time Awake Since Boot: 17000 seconds

System Integrity Protection: enabled

Crashed Thread: 48 QThread

Exception Type: EXC_BAD_ACCESS (SIGBUS)
Exception Codes: KERN_PROTECTION_FAILURE at 0x00000007017f3000
Exception Note: EXC_CORPSE_NOTIFY

Termination Signal: Bus error: 10
Termination Reason: Namespace SIGNAL, Code 0xa
Terminating Process: exc handler [0]

There’s more but can’t paste it due to character count.

Can you send the full log to support please?

Hi Unfortunately, I do not have the full log.
May be when it happens again I will send it to you.

  1. On a another note, I faced Mocha crashing when using join points between two tracks and accidentally connecting to the same point immediately crashes AE.
  2. I just worked on this complex mask and when I matte in AE it has a weird problem. Please check screenshot. Can you please help.

Thanks
Krishna

We’ll try to reproduce the join points issue.

In terms of the matte problem, check that the track your roto in linked to is not severely distorted (or missing). You can checkthis by turning on the surface and scrubbing through the shot. If the surface severely distorts or even disappears, you may need to retrack that section.

Are you pasting this data from the clipboard or viewing it via the matte option in the plugin?
Sometimes converting to shape data can distort points that are very close together.

I could not reproduce the crash with join layers. Can you please tell me the exact steps you did to get the crash?

Hi Martin,

I tried your suggestions to solve the Matte problem.

I figured out it was to do with Motion blur activation. I deactivated it and it worked. However, why is this happening with just one frame? Please let me know, Any help would be much appreciated.

As far as crash due to joining points is concerned. It was a simple join just like your website tutorial on youtube.

Please let me know

Thanks
Krishna

Hmmm… if it’s only happening on motion blur, that sounds like it’s potentially a bug. We’ll do some tests.

Just a follow up: Was the motion blur set on the background layers or just the foreground layers?