Mocha Pro crashes constantly

I am having a very frustrating time trying to remove dust spots from a 639 moving frame shot as Mocha Pro is constantly crashing. I have tried uninstalling and reinstalling the program onto a fast ssd. I noticed that it would crash if it hit an area that was not tracked so I checked my tracking. I have been using cleanplates exclusively as that seemed to be less crash proned and sometimes I would just manually render frame by frame as that was more stable. I also uninstalled quicktime and then reinstalled on the faster ssd as I noticed that it might be a bottleneck. These moves have reduced the instability options but not eliminated it and everytime it crashes I have to delete the frame that crashed (generally shows it at 4 kb).

Hi there,

How much memory is on your video cards?

What are your memory settings inside of mocha?

What lighting model are you using?

I ask because any of these issues could be causing your trouble. Please let me know and I will be happy to help you.

Cheers,
Mary

What do you mean by lighting model?

“Illumination modeling,” are you using none, linear, or interpolate?

NVidea K2000M with 2GB video Ram and 32 GB of system RAM

Illumination model is generally interpolate but it may have been at none during the last run

Under OpenGL settings I upped the amount of Texture RAM to 10109 which seemed to improve from the near constant crashing before then.

 

Also for some reason when ever I stop the remove render it seems to either take forever to stop or is locked up. After long waits I tend to just shut the program down and start again.

The render times are also horrifically long for something as simple as dust spots. I am trying to render 3 spots with a sky background tracked and it took a couple of hours just for 6 frames. This might have been under illumination of none but with cleanplates exclusively.

In open GL settings, take texture ram down to anywhere between 256 or 768 or so, it’s not your system RAM, it’s your video card ram that is affected by that setting.
Interpolate is very memory intensive, so that could be the issue.

That being said, your system sounds plenty beefy. Are you sure the “use cleanplates exclusively” box is checked? Is your footage 4K or something? How many layers are in your shot? It might be just easier to send the shot to me.

If not, you might want to select that. If it is checked, try increasing the “step” setting, but cleanplates will not work with step.

I converted the footage to dpx with each frame being about 12 meg from within Resolve but it was originally ProRes 422 HQ

OK, can you go to your preferences and find where your motemp folder is located on your machine?
Select all the files in there.
Delete them via the trash.

Now, restart your machine, make sure you don’t have chrome or firefox or facebook open on your machine, and that you don’t have any other program open to test this, and try to render again.

Please let me know how that goes.

Cheers,

Mary

I deleted over 80 GB from the MoTemp directory, rebooted and tried again without anything open. It seems like it takes a half hour for every frame for 3 dust spots. If for some reason I decide to stop the process it never seems to end the process, even if I leave for a few hours to see if it will complete. I didn’t have this problem before. Also, for some reason, the middle dust spot does not seem to be affected. I installed license manager this time. Would that affect it? I also installed Boris FX trial back when Mocha was installed on the slower drive. Would uninstalling Mocha from there and reinstalling on the new drive caused some kind of problem there. It seems like things have been worse since the move.

This is abysmally slow. Although it has not crashed yet, I decided to do just 1 dust mark and let it run overnight while I slept. 7 hours later and it has done less than 60 frames. I even went through regedit to make sure everything was pointed in the right direction since I changed drives from C: to D: and there were many pointers to the C:/Program/Files/… directory that I changed, but I see no difference in speed. Both the MoTemp and Mocha Pro are using the SSD which is a SanDisk_SDSSDXP480G_____________________R1311___

I am now forcing the Nvidia GPU on Mocha Pro (it had been running on a screen running the Nvidia GPU but I am going to see if it makes any difference. I also removed the one dust spot from the group and see if that makes a difference.

 

 

 

Yeah, that just seems out of character for mocha on that speedy of a machine, it has to be a weird setting or using too large of a source shape or something. It should not be that slow. Please email me at maryp@imagineersystems.com with the best number to reach you at and we can take a look at this shot together.

Cheers,
Mary

This is Albert, need to call me by 2pm CDT as I pick up my boy and let him play in the park from 2-5pm CDT.

Currently running with one dust spot with 37 frames completed in 2.5 hours

I might not be able to call before then, I have meetings today, so I will call tomorrow morning.

I am available now

This is getting weirder. I was able to stop a problem that chronically crashed and get several remove renders by doing it manually. I then saved and closed the program, reopened it and the rendered files do not show up (although other rendered files do.) I also periodically have problems adding a cleanplate from file. I was able to do it last time after deleting all files from MoTemp and rebooting but not this time. Very frustrated here.

I am going to call you in about an hour. I have a meeting right now.

For the curious, this was a very complex multi layered remove. This many layers in a remove file can significantly bog down a render. The remove tool is meant for 2-5 layers tops to operate at efficiency. It’s meant for simple motions over planar data. Removing over moving organic objects is best completed with rotopaint. In this case, it was dust removal from a lens and might be able to be solved with a much faster mask and color correct to fix the problem.

Cheers,
Mary

I have other problem with Mocha Pro 4 crash

After installing original system Windows 8.1 and set up machapro-4.1.3–10962.x64 everything works properly.
However after installing HitFilm 4 Pro with Mocha HitFilm Version 4.1.3 build 10342, Build Date Jul 7 2015 on the same computer, application mochapro.exe shows error:
Nazwa aplikacji powodującej błąd: mochapro.exe, wersja: 0.0.0.0, sygnatura czasowa: 0x564559df
Nazwa modułu powodującego błąd: MSVCR90.dll, wersja: 9.0.30729.8387, sygnatura czasowa: 0x51ea1bbd
Kod wyjątku: 0xc0000417
Przesunięcie błędu: 0x00000000000552d4
Identyfikator procesu powodującego błąd: 0x28c8
Godzina uruchomienia aplikacji powodującej błąd: 0x01d131249ca188df
Ścieżka aplikacji powodującej błąd: C:\Program Files\Imagineer Systems Ltd\mocha Pro V4\bin\mochapro.exe
Ścieżka modułu powodującego błąd: C:\Windows\WinSxS\amd64_microsoft.vc90.crt_1fc8b3b9a1e18e3b_9.0.30729.8387_none_08e793bfa83a89b5\MSVCR90.dll
Identyfikator raportu: 3bc46659-9d18-11e5-824e-d0509952c9fb
Pełna nazwa pakietu powodującego błąd:
Identyfikator aplikacji względem pakietu powodującego błąd:

and mochapro.exe cannot be run at any way.

Please advice what I should do, as I need both HitFilm and Mocha Pro for my work, installed at the same time on the computer.

Best Regards

Grzegorz Jakobik

Hi there,

We have responded to your case that you also submitted, please only submit cases for this kind of thing, lighting up forums and cases and emails all together won’t get your issue solved faster, it will just dilute our efforts.

Can you please try uninstalling mocha Pro completely? It may be that you have some Library problems on your machine.

Follow these steps:

Uninstall your mocha software.

Find any Preferences (or .plist) files:

On Windows, open the command prompt as an administrator, type regedit in the window, and hit enter.

Navigate to HKEY_CURRENT_USER/Software/Imagineer Systems Ltd/mocha

Delete your preferences files:
On Windows, Delete the contents of any folder in HKEY_CURRENT_USER/Software/Imagineer Systems Ltd/mocha

Re-install the mocha software from scratch by downloading a new mocha installer off of our downloads section.

Restart your machine.

Launch the app. Follow mocha’s instructions to reset preferences.

Please let me know if that works for you and I will be happy to continue to help you troubleshoot, responding to the email I sent you would be better than responding here.

Cheers,
Mary