Mocha pro framerange extension and colorspace

Hi! I tracked a shot over a certain framerange and exported everything to Nuke, everything worked well, go mocha. I then needed to extend my shot by about 80 frames at the head of it.
I went in mochapro and changed my project settings, re-linked my clip, zoomed out on the new timeline, manually moved my keys back in place, but I can’t work on my newly extended clip.
I can move on the timeline, but the colors appear strange (kind of as if it was in a different colorspace, except they’re EXR and same as the original footage.) I have a yellow dotted line around my viewer and can’t see my shapes, surface tool or grid. Which step did I miss when trying to change my frame range?

It sounds like you’re in the clip tab and adjusting colorspace, just change your color space and click on the track tab and you should be fine.

10 versions and a few hours later I figured out where all the kinks were coming from and how to fix it but I’m really not sure why it happened, whether it was a bug or my error so any input would be appreciated. I fumbled around trying to replicate the necessary steps to modify my source clip so might have not done things as they should.

The encountered issues were first and foremost that even moving back to the track tab I would keep the yellow dotted line that prevented me from doing anything, until I saved a version anyway and rebooted. Fixed issue. Then for some reason re-linking my clip with the extended frame range was changing the video gamma back to 1 (instead of 2.2) and offsetting the whites by 10. I compared with my original version and changed it back to where I needed it and the -linear- colorspace was fine.

The even if I could manually move my keys back to where they needed to be the dope sheet wouldn’t display the entire range (or the sliding bar to move one side or the other in the dopesheet.) Saving the project and rebooting mochapro fixed that as well.

One of the layer ended up still being locked but as it was just garbage matte I’ll deal without.

Are those bugs common when changing the range? I use mocha often enough but it’s the first time I have to change my clip in the head in (vs tail out) and I’m surprised by how complicated it proved to be…

Thank you for letting us know! I will have to see if we can repeat it on our end, if you can do it again a screen recording would help us get to the bottom of this.

I’m having the same issue now.


I can definitely replicate it on my side of things -using the same and a different clip/script I just tested with- but as I’m working for a company on a feature film that won’t be released for a little while, there is no way for me to do screen captures or recordings, sorry. My advice for other people who stumble upon the same kind of issues in the meantime would be to do incremental saves after each steps, exit mocha and reload. Though counter intuitive it ultimately fixed the issue on my end.

On a side note I watched a lot of your tutorials on using mocha and I’ll take the opportunity to mention they are really informative and lead me to become one of the most mocha-literate people at work, so thank you for your help all the same!

Ah, I know about the whole NDA thing. No worries. I am so pleased you get a lot out of the tutorials, and I agree that this is a kludgey workflow to fix the issue. If you can repeat it more than once, it’s likely we can too, which means we should be able to fix it. I have already passed this information to our product manager, so he’s on it. Thank you!

Thank you for letting us know. We are researching the problem now.

Hi guys,

If you’re using V5, you can adjust the color via the Colorspace subtab in the clip tab. Have you tried that?