Mocha Pro Plugin for Avid (Windows) Composite layers disappear when rendered

Hey I am struggling to work out whats going on, I seem to remember working past this awhile ago, but unable to now and running out of time on this project.

Inside mocha all is well, shape is showing the insert layer from below in the avid timeline. Its both tracked and rendered.

Back in avid, in the effects editor > Module Renders, Render is ticked with ‘Insert composite’ selected in drop down.

I can scrub frame by frame in avid can see every frame of the composite image, if I render the clip, video mixdown or export, the composite shape disappears.

Newly created composites are generally better, but opening old ones or opening/editing the effect on another edit suite that has access to same media always ends up with this fault. i.e the composite effect scrubs frame by frame fine, but disappears on rendering in avid.

I have this problem, both with the 2020.5 version of Mocha and I have upgraded to 2021 v8.0.3 today and still the same issue, older and new versions of avid seem to make no difference. Nor does the type of video resolution in the Media Creation settings in the Render tab make any difference. Disabling GPU rendering in Avid also doesn’t help.

Have I missed a setting somewhere in the Mocha interface??

Currently on Windows 10 (up to date) 2021 v8.0.3 Mocha Pro Plug in for Avid, Media Composer 2020.6
Nvidia 3090, Driver 471.68 Game ready,

but also possible to reproduce the problem on different system with 2021 v8.0.1 Mocha Pro Plug in for Avid, Media Composer 2018.12.11. Nvidia Quadro P2200 Studio Driver 441.66

Any help greatly appreciated, Gary

Hi Gary,

Go into your Mocha preferences and turn off GPU tracking, try saving and closing, and restarting Avid. Do you still have the error?

If you do not, it’s a GPU issue.

What GPU are you on?

Let me know and I will be happy to help you,
Mary

Hey Mary,

Thank you for helping :pray:

Current system has a Nvidia EVGA 3090 with the 471.68 Game ready driver.

I have disabled Use GPU Processing, in the GPU tab in preferences in Mocha. but can’t tell if helps as now getting
Exception: VideoEffectConsumer – Unexpected status returned from RenderEffect error
which stops the render before it completes.

but also possible to reproduce the problem on different system with a Nvidia Quadro P2200 Studio Driver 441.66,
2021 v8.0.1 Mocha Pro Plug in for Avid, Media Composer 2018.12.11.

This systems has allowed me to render without error, but disabling ‘Use GPU Processing’ hasn’t solved it and still the render disappears.

(New user settings in Avid have cured the error in the system with the 3090 but again the composite disappears on rendering with the GPU disabled in Mocha)

many thanks Gary

I am going to loop @Martinb in here, I think this may be a different known issue and we might have a workaround.

Thanks, also just tried stopping Avid from using the GPU to render in Avid users settings, restarted avid but alas still happening.

Until now its been working generally fine for the past months with offline resolution media (DNxHD LB(HD1080p). Now the source clips are conformed to DNxHR HQX(3840x2160)) even new simple shapes are not rendering.

OK, we might need to test some things, Martin will be on later (Australia time) and I will see if we can put our heads together.

Thanks Mary, I am UK time and going to try a few things myself for another hour or so (different project/sources clips with different codecs) but its getting late. I will keep an eye for updates on here. But try suggestions first thing tomorrow morning.

Happy to post pics or videos and allow remote in.

Many thanks again!

Update - Its seems like either a new project (although 2 different ones were tried before this) or a graphics driver update has done the trick with the system with the 3090 in it.

First I made sure I could render a comp with two AMA linked clips H264, then I tried a new comp with the same DNxHR HQX(3840x2160) material. When that worked I tried opening the bin with all the historic comps in it from the past year with the conformed DNxHR HQX(3840x2160) material , they all are rendering ok as well.

Finally turned GPU tracking back on in Mocha and its still rendering ok!!

If I get to the bottom of it, I will update again. I’m lucky, its this system with the Nvidia 3090 that I really needed it to be working with and I can now get on with the jobs tomorrow.

Thanks again

Probably the pesky gaming driver, then.

.

My VOG-L09. On O2.

To me, it sounds like potentially your OpenGL buffers were having a conflict.
If it happens again, try turning on “Disable offscreen buffers” in the GPU preferences. GPU rendering should be fine for everything else, so that can be re-enabled.

Hey Mary/Martin

Ok… tried all the above… Nothing is helping.

Yes, I still have one working system, but it’s very unsettling as it also happened once on that system too today…

I can recreate the problem at will on three different systems. One is an Avid approved HP workstation with an Nvidia Quadro P2200, Driver 441.66. I can’t change anything that requires admin as its the clients suite.

My suite is a custom-built i7 6700K with an Nvidia 3900 with the latest game-ready drivers. Its currently rendering ok on this or it is on the old windows installation…

I freshly installed Windows 10 on a different drive last night. Fresh and correct Nvidia Studio driver for the 3900 for Media Composer 21.5, but alas same problem the ‘Insert Layer’ doesn’t render in avid. It scrubs frame by frame but on the final render it is gone.

The same is happening also with Alienware i9 Dell with the Nvidia GTX2080.

I have the OFX and Adobe versions of Mocha from the yearly sub, so I’m trying to use either of them instead. Two layers on the timeline, mocha on the top layer. I make a shape, select ‘insert layer’ but in both premiere and Resolve I don’t even get the inserted clip to show in the mocha UI. Only 'Logo shows up with either.

I have been producing comps this way in Avid for the past three years and many many in the offline in recent months. Now its time to create them for real, ready for online and grade I just can’t be sure I am going to be able to recreate them all…

Am I missing something really simple?

Many thanks
Gary

Did you move the media around? It could be the media needs to be relinked in Mocha.

Maybe some background,

for instance

Job - Add a radio collar to a Meerkat ( yeah add one not remove :crazy_face:)

get lucky and do a half-decent attempt in the offline edit,

its a freeze-frame of another rushes clip on V1, meerkat clip to have the collar added on V2.
Draw a collar shape that tracks around the neck area, ‘insert clip’ in the drop-down for the layer. Now the collar from V1 is showing and tracked to the neck area.

Come out to Avid, render, mixdown whatever. No problem.

Now months later, get the two offline clips conformed to broadcast quality, same clips on the timeline and metadata.

The effect is now unrendered as the clip is batch imported at higher resolution, looking good on the timeline in Avid. Can be opened in the Mocha UI and playback in there is good. Mocha is Happy.

Make final adjustments, as now higher quality stuff needs adjusting.

Close Mocha, changes look good, scrubbing through. hit render and the ‘insert clip’ layer vanishes…

But not always, its been working all day on the one system of the three, until it didn’t for 20 mins…
And on the new Windows install with the studio drivers, even brand new comps disappears in the render. Scary enough that I feel I need to find another solution.

The standalone version is a solution but will slow me down as can’t grade the bottom shot quickly or using Baselight for Avid.

Should it work the same in Premiere and Resolve as it does in Avid? and I just need a little more knowledge of how to set up?? I would manually recreate them in either if I could get consistent renders out but I didn’t even get V1 showing with Insert Clip within the Mocha UI with either of them :man_shrugging:

Maybe you need to use mocha in Fusion instead of the VFX on the timeline?

It should work the same in other programs, and could be rebuilt. Also, if it is looking good in Mocha inside of Avid, render the whole clip in Mocha, and then go to File>export rendered clip>, and then save it as a clip you can drop into the edit.

render the whole clip in Mocha, and then go to File>export rendered clip>, and then save it as a clip you can drop into the edit.

Great thanks! I hoped that was possible and I did just look look at this, but stopped as it looked like it was just going to render out the Matte, (preview window) , but I will now (maybe I didnt render first).

Brand new, Windows and Avid/Mocha is defo not good, Sapphire renders fine but Mocha is having a hissy - Exception Error on rendering anything.

Thx you :pray: Yeah I will just render and export within Mocha in future!

OK, in the meantime, we will try to get to the bottom of whatever is happening in Avid with QA.