Mocha Pro V5 vs Mocha 2022.5 inconsistent

Hi. I’ve been using Mocha Pro V5.6 for years - has always been rock solid so didn’t update. I finally got round to updating to Mocha Pro 2022.5 yesterday and tried to track a shot in my current project.

The track from 2022.5 is awful - just unusable. I tracked the exact same footage using the exact same settings and track area in Mocha Pro V5 and it’s perfect.

I’ve tried using both GPU and non GPU tracking, but both gave the same bad results. In all instances, I’m copying tracking data to clipboard (AE corner pin supporting motion blur) and pasting it to the same layer in AE.

I’ve made a comparison video here: tracking test

It’s pretty clear the track from 2022.5 is bad, whereas the same footage tracked the exact same way in V5 is fine.

Does anyone have any suggestions why the 2022.5 track isn’t working, whereas V5 is fine?
many thanks for your help,
Terry

Hey
I’m sorry to hear that you’re not getting good result with the update jet. Let me try to help!
Link that you provided is unavailable for playing, could you check it please? Are you using Standalone or AE/OFX plugin? Did you try restarting the host after switching the GPU setting?

Oh, I’m sorry Elizabeth - try the link again now.
In both cases I’m using standalone. Yes absolutely - restarted application after making any changes on that preference box.

I see. Mind sharing the project for deeper look?

Well there isn’t really a project - it’s just a single piece of footage tracked. It’s difficult sharing the exact footage because it’s a live project and I’ve signed an NDA :frowning:

Could we do it privately somehow?

I was meaning the mocha project file and this piece of footage.
Yes, totally! You can send to me in DM or to elizabeth.postol@borisfx.com

I understand your worriness about NDA. This will be used for internal use only.

Thanks Elizabeth, I will do :slight_smile:
But you can see the difference between the two versions even though they’ve been tracked the same, right? There’s no reason for that, is there?

Yes, I see that odd drift. Having the project will help diagnose why this is happening. Probably @martinb may have thoughts on it

To me it looks like there’s either a frame rate or a frame offset drift.

@terryfishnorfowl-com Does the track inside Mocha look bad as well or only when you paste it?

Hi Martin! Thanks for taking a look :slightly_smiling_face:
Yes, I know what you mean but I can’t see an obvious way it’s happening. I’ve done it around five times now - each time with a brand new project pulling the framerate from the footage, and pasting it back into the same AE comp.

If I do the process in Mocha Pro Standalone v5 it works perfectly.
If I do the process in Mocha Pro Standalone 2022.5 it drifts.
If I do the process in Mocha Pro Plugin 2022.5 it actually works fine.

Elizabeth has a screencapture I did showing it not working for me. Perhaps there’s something obvious you can spot happening, but I’m at a loss. All the pasted keyframes in AE line up for the correct framerate and timebase, and like i say - it works in V5 and 2022.5 plugin, but not 2022.5 Standalone.

Terry, based on our email conversation I was able to recreate your issue! I’ll send you a short video showing how to deal with it in your case.

1 Like

Amazing! Thanks so much Elizabeth! Yes, you’re right - the timecode of the clips don’t start at 00:00:00:00.

But how comes it’s working in other versions though?

Hi Terry,

Based on @elizabeth.postol’s tests, this could be a frame reading issue with the file format.

Since v5.6 we had to depreciate the QuickTime reader in Standalone and moved to an input method called GStreamer. It’s far more diverse at reading many different file formats but occasionally it gets clips that may skip a frame due to the way they have been encoded.
Elizabeth has run some tests and found the ProRes file you’re using might indeed have this problem.

You have two options to confirm this:

  1. In After Effects, convert your clip to an image sequence like TIF or PNG at the same frame rate and import that into Mocha Standalone.
  2. Since you have the Standalone license, you should also have a license for the Adobe plugin version. I see you’ve already tried this, which is great!

We’ll file a bug for this particular file as it doesn’t seem to affect all clips in this codec.

Thanks Martin :slight_smile:
Ah, that does make a lot of sense and can explain the results I’ve been experiencing. Good to know I’m not going crazy!

Yes, I do have a plugin license but I’ve always preferred to use the standalone, as I can leave it open and jump back and forth, plus it feels more reassuring to have a separate saved project file. The plugin obviously works fine, but in terms of workflow I do find it a bit slower because of keep closing and launching it to get back to the host.

As soon as work allows, I’ll try doing some more tests in different formats to confirm the theory.
Thanks again for your help - both of you! :slight_smile: