Mocha Remove - nothing


I cannot get a simple remove to work. I’ve attached a screen grab, and you can see that the actor (I’m trying to create a clean plate). It’s a panning shot (moving right to left) and I’ve tracked

the background with no issue.

 

I’ve then gone ahead and selected an area (then tracked) the box. The layer order is correct.

 

Then, I turn the Uber Key on, head on over to the ‘remove’ tab and change the first frame to right before he enters and then the last frame after he exits. I hit the ‘render’ button (middle one) and wala! Nothing. Unlike all of the tutorials, nothing happens! It renders something, but the foreground elements are still there.

Image here – https://flic.kr/p/oWTJLX

Hi there,

From your image, it looks like your BG layer isn’t big enough to encompass all of the FG layer for the remove. You may need to track the sky as a second BG layer and link the tracking layers using the join layers tool. This will fix some of the problem.

The other problem is that is seems to be removing some of the object that guy is holding, but not all of it. Which means mocha can’t see behind the object completely because not enough of the background is being revealed. This is either from your settings in the remove (frame range too short) or because the guy and object are not moving enough in the scene. You will need to make a cleanplate (probably only a single one) in photoshop to fix anything mocha is unable to remove.

You don’t have to use the Uberkey for the remove to work, only when you want to ripple edit a shape.

That should fix your issue.

Cheers,

Mary

Thanks Mary,

I tried that, but still no dice. I’ll try the clean plate method, but this is nearly the exact example Ross had with the girl on the beach, where he removed her from the shot, first her legs on the sand, then second her torso up that were infront of the trees. This guy has a building ledge behind his legs and a city behind his torso. The camera pans with him, so every part of the background is in view at somepoint by Mocha…

Secondly, this is a bit of an oddity, but why is it, the time line can become greyed out? So, I’ve attached an animated shape to a track, and I’m nearly done, and then I can’t access the keyframes, and the arrow keys no longer work (I have to scrub via the mouse wheel). Link to screen grab

As an aside, Mary I love this program-but I run into some quirks. Thankfully, you guys are AMAZINGLY responsive.