Mocha Shapes not Aligning in AE

Hello - I have developed an inexplicable matte offset issue between what’s created and seen in Mocha playback vs what is cut-n-pasted into AE.

  1. Accessing Mocha through AE CS6 Mac.
  2. Tracking a portion of a moving car. Track is working in Mocha perfectly. Frame range, resolutions, FPS, etc are the same in both apps.
  3. RotoSplines in Mocha are also tracking perfectly, linked to my tracking data. They are keyframed every 20 frames or so.
  4. Upon cut-n-paste export back to AE, the mattes are not aligning. They appear to have an offset issue. I have “started from scratch” (including reboot) and have the same, re-occuring issue. I am pasting on frame 1.
  5. Previous shots have been successfully tracked with same process.
    Is there something I am forgetting?
    Huge thanks,
    Andrew

Hello - I have developed an inexplicable matte offset issue between what’s created and seen in Mocha playback vs what is cut-n-pasted into AE.

  1. Accessing Mocha through AE CS6 Mac.
  2. Tracking a portion of a moving car. Track is working in Mocha perfectly. Frame range, resolutions, FPS, etc are the same in both apps.
  3. RotoSplines in Mocha are also tracking perfectly, linked to my tracking data. They are keyframed every 20 frames or so.
  4. Upon cut-n-paste export back to AE, the mattes are not aligning. They appear to have an offset issue. I have “started from scratch” (including reboot) and have the same, re-occuring issue. I am pasting on frame 1.
  5. Previous shots have been successfully tracked with same process.

Is there something I am forgetting?

Huge thanks,

Andrew

I have had the same issue as Andrew. By pasting the shape data to a spreadsheet program, I was able to see that Mocha was exporting keyframes for the entire clip, starting at frame zero, rather than starting at the In-Point I had set for my clip within Mocha (or rather, the in-point that was automatically set when I selected a trimmed clip in After Effects and chose “Track in Mocha AE”). The simple workaround was to choose View > Go To Time in After Effects and set it to the negative of the in-point frame number before pasting. e.g., -0:00:00:1024

This behavior seems different than when exporting tracking data, which seems to export with the In-Point frame in Mocha labeled as Frame 0.

I am using Mocha for AE CS6.

I have had the same issue as Andrew. By pasting the shape data to a spreadsheet program, I was able to see that Mocha was exporting keyframes for the entire clip, starting at frame zero, rather than starting at the In-Point I had set for my clip within Mocha (or rather, the in-point that was automatically set when I selected a trimmed clip in After Effects and chose “Track in Mocha AE”). The simple workaround was to choose View > Go To Time in After Effects and set it to the negative of the in-point frame number before pasting. e.g., -0:00:00:1024
This behavior seems different than when exporting tracking data, which seems to export with the In-Point frame in Mocha labeled as Frame 0.
I am using Mocha for AE CS6.

I’m having the same problem. With me it’s interlaced footage.
When I import to Mocha without “upper field first” turned on and then export to AE the mask shapes seem to line up WRONG. They’re offset vertically and I believe the scale is incorrect.
When I import to Mocha WITHOUT “upper field first” turned on and export the shape to AE, it seems to export the shape properly.
Is this a bug or am I doing something wrong?
best,
Fred Raimondi

I’m having the same problem. With me it’s interlaced footage.

When I import to Mocha without “upper field first” turned on and then export to AE the mask shapes seem to line up WRONG. They’re offset vertically and I believe the scale is incorrect.

When I import to Mocha WITHOUT “upper field first” turned on and export the shape to AE, it seems to export the shape properly.

Is this a bug or am I doing something wrong?

best,

Fred Raimondi

Have you trimmed the clip in AE? Are you absolutely certain that the frame rate, aspect ratio, and clip length match? Can you attach some screenshots so we can diagnose this better (screen grabs of mocha AND After Effects)?
Cheers,
Mary

Have you trimmed the clip in AE? Are you absolutely certain that the frame rate, aspect ratio, and clip length match? Can you attach some screenshots so we can diagnose this better (screen grabs of mocha AND After Effects)?

Cheers,
Mary

Hi guys,
The shape data always exports to the full length of the clip, this is as intended, and why I asked if your frame rate, aspect ratio, and clip length matched in order to line up your shapes.
There are easy plugins in AE that help with that, if you do not want the workflow to work that way, including MaMoWorld’s mochaImport+ (http://www.mamoworld.com/index.php?option=com_content&view=article&id=52&Itemid=72).
And your manual workaround also works fine.
Cheers,
Mary

Hi guys,

The shape data always exports to the full length of the clip, this is as intended, and why I asked if your frame rate, aspect ratio, and clip length matched in order to line up your shapes.

There are easy plugins in AE that help with that, if you do not want the workflow to work that way, including MaMoWorld’s mochaImport+ (http://www.mamoworld.com/index.php?option=com_content&view=article&id=52&Itemid=72).

And your manual workaround also works fine.

Cheers,
Mary

It might be bug, and I will see if I can reproduce it, but I work with deinterlaced footage in mocha for best results and re-interlace later if I need to.

It might be bug, and I will see if I can reproduce it, but I work with deinterlaced footage in mocha for best results and re-interlace later if I need to.