Mocha Shapes offset when pasted into AE


#1

From AE, I exported a portion of a clip from an .mts video file into an APR442 movie file.
I opened a new project in Mocha and used that .mov file to create masks around a hand.
I then copied and pasted the Mocha Shapes data into AE and noticed the hand masks were offset by a bit.
image

I made sure my masks were ok in Mocha, which they were.

My settings match…frame rate, length (the masks are not offset by time, just in position), 1.0 pixel, etc…

BUT when I bring in the .mov file just to see, the masks line up a bit better, but still a bit off.

MTS:
image

MOV:
image

Any suggestions?

Mocha Pro Version 5.5.2 build 13566
After Effects CC 2017.2 version 14.2.1.34


#2

When this happens to me it is usually that the layer I have masked has been moved. Check the transform? I see that it lines up on the .MOV… in which case the problem is likely with the export. Maybe there’s some tweening happening. Overlay the two movie files in a comp and use a difference blending mode to see if the movies are different.


#3

Hi Mary,
Yes I tried that. I imported the mov into the sequence and l layered the mov over the mts and they were spot on.

It seems like the shapes aren’t liking the mts file for some reason.

I’ll try to reproduce a few things such as exporting a file again and seeing if it happens again.

But that’ll be tomorrow. Decided to call it a day and go home.

I’ll follow up when I have more.


#4

I will usually make the adjustment after transposing from Mocha to AE with some further refinements; exactitude is not a given with the program.


#5

What type of refinements?

I’ve never had this issue before where it was offset so much.


#6

In rotoscope mode, starting from the end of the clip, backtrack back through the frames hitting the 1 key. Adjust the matte.


#7

Yeah, I think I would just export the final file I needed to comp and roto in and use that in mocha instead of the problematic file format. In the meantime, we can look into this on the Dev side and see if we can support the difference.


#8

I have some sort of conclusion.

The pixel jump is only isolated to this one particular project.
It’s not a Mocha issue as far as I can tell but an After Effects issue.

I tried to replicate the issue with different file types and workflows but it only appears in my current project…and it’s due to Adobe Link. While using Premiere, I selected the file and chose Replace with AE Composition via Adobe Link.

In that comp I duplicated the .mts and stacked it.
This time I added an AE mask, and the image jumped up exactly one pixel.
I deleted the mask and the layer returned to normal. The transform values did not change, it was only a visual change that you can notice when you toggle the layer opacity on and off.

I’ll probably submit this to Adobe.

As far as my current projects goes, before I found the issued I ended up adding a ‘refine matte’ effect and then roto’d out some pixels to where it looked good.


#9

Thank you for letting us know!