Mocha Standalone & plugin, playback is slow?

Hi, in both the plugin & standalone the playback is less than full fps even after several looped playbacks it seems slower than it should be, ,
Is this expected or should it be playing at full fps, i honestly can’t remember if this has changed or if it was always like that?
Thanks.

Honestly, it depends on what you’re throwing at it.
What is the codec, dimensions and frame range?

Hi, just a simple MP4 AVC 29.97fps 1920 x 1080, no splines added, the timeline goes slowly through as it cache’s the media but when then playing through it doesn’t seem to reach full playback speed.
Specs are in my profile but …
Windows 10,
Ryzen Threadripper pro 32core
256GB RAM
RTX 3090 SUPRIM 24GB GPU. (latest Studio driver)


Video on YT 1.435mins long, watch how fast the man is walking

Thanks

PS. this is loop playing

You’re generally going to get the best playback with ProRes.
MP4 requires us to unpack it (or request the compressed frames from the host), all of which takes time. H264 and MPG in general is very slow to work with from a caching perspective.

Having said that, the playback should get cached, unless you’re running out of cache room. I assume you have plenty of swap space on your cache drive?

Ok i’ll experiment with ProRes & see :+1:
‘swap space on your cache drive’ i haven’t a clue about, i just read some on Google but it’s 3am here so i’ll have to get back to you on that, :exploding_head::grin::+1:

I have two 2TB M.2 drives, 7000MB/s Read, 5100MB/s Write., one has Windows & programs, one has temp media on it , both have 1.5TB free space
Thanks

Update, I tried all the ProRes options available to me, 444 422 HQ XQ…
& a rendered clip from Mocha using the render defaults

The file those settings produced

Playback is still slightly slow as in my video above,
Still working on the ‘swap space on your cache drive’ :face_with_monocle:

In the standalone at least, as long as you have enough RAM you should be fine. With the plugin you’re fighting for resources with the host, so there can be some overlap.
In After Effects, do you have “Cache frames when idle” turned on? If so, turn it off as it does slow down playback a lot.

Hi, sorry i use Vegas but it’s the same in the standalone as in the plugin version, this evening I’ve been clearing/cleaning the pc but that hasn’t changed anything,
I mainly use the standalone because Vegas is a bit crap, to discount Vegas’s poor performance all the images & video i posted above are all from the standalone, that’s why i didn’t mention Vegas but like i say the playback is almost identical in both plugin & standalone,
So pls ignore the Vegas bit, only focus only on the standalone & hopefully any fix/change i make i’ll be able to transfer over to the plugin,
All setting in Mocha are at their defaults, apart from i use the Linear controls & i tried increasing Texture RAM to try improve playback
Thanks.

I’d recommend not setting your Texture RAM any higher than 1024. That only controls how much VRAM to store for displaying images on the screen for any one frame (including zoom windows etc). It doesn’t have to be very large. Any RAM you assign there will not be available for other processing.

Does the cache here have a lot of data in it?
C:\Users[YOUR USER NAME]\AppData\Local\Temp\BorisFX\Mocha Pro\ImageCache

Thanks, it was on the default of 256, i increased it to about 2000, that didn’t improve it so i’ve since set everything back to defaults but i’ll keep what you said in mind :+1:
Nope very little in that folder, it was one that i cleared when i sad i’d cleaned the pc

I deleted everything in that Temp folder so now there’s only what i’ve been doing tonight (it’s 4am 3rd May now)

This is playback, the dips in the graph are as it loops backwards & forwards, it goes through once then just seems to reach a speed & sticks to it, nothing in the system seems to be stressed, there’s not much happening with the PC
Project settings seem to match whatever media i use, on this image the project says 29.97, when i put in the 30fps constant ProRes file it read 30, :man_shrugging:

I just had a play putting the Project settings Frame Rate at different speeds. if i set it at 31.5 i get almost the correct playback on screen compared to the orig ?:man_shrugging:

Hmmm, that IS odd. So perhaps a decimal frame rate doesn’t like playback at the correct rate?
I’ll check this now.

As a test, can you try a TIF sequence at the same framerate instead?
I still get real-time playback of non-integer frame rates, but I’m curious now about what happens if you take the clip reader out of the equation.

Hi, I added a TIF sequence from the orig video of 29,97fps, it played as does the other video versions,(ProRes & MP4),
but in this vid i also tried different frame rates, 31.5fps was closer to real time, maybe a little fast, 31fps was a bit slow,
Thankyou for your help & patience, I can work with it & enjoy working with Mocha but yes i’d like to know too :+1:

Mocha Pro Standalone & Silhouette Standalone, playing slow just like each other. (+ PI plugin.)

Hi, sorry to bring this back up,
I was using the Point Tracker we discussed in another post & i noticed Silhouette standalone played slow just like Mocha Pro does,
I’d deleted the video in the comments above so in this video i included both Mocha Pro Standalone & Silhouette Standalone both playing the same clip, & just out of curiousity I opened that clip with PI plugin, same there after several loop plays the best playback speed was similar to Mocha & Silhouette,
I’m still curious why?
Thanks for your time.

This is probably the closest you’re going to get. As VFX platforms we get as near to real-time as possible, but we’re not designed like editing tools that have to focus on the WYSIWYG framerate.

I’ll ping our dev team to see why you’d be getting closer to real-time using a slightly higher framerate though, as that is strange.