Mocha tracking holdout layers not working (9.5.4)?

I am working on a couple of 360 tracks (360 cam on a stick on a bike). the stick shadow has tracked well (for future removal). second layer tracking the bike and the person (for hold-out) was tracking ok-ish.
every time the stick shadow enters the floor track space during tracking, the track goes totally wrong, as if the hold-out condition is not applied. is this a current bug? the floor tracks great if i manually keep the splines on the floor ahead of the bike.

I’ve tested with the footage you sent and so far haven’t seen a problem with holdout mattes.

  • Is there edge width on the holdout matte when you’re tracking?
  • Are you tracking at full resolution or a lower resolution? For example, you can get a very decent lock with quarter resolution in AE.
  • Are you tracking from the beginning/end of the shot, or somewhere in the middle?
  • Have you tried tracking with an unlinked track (i.e setting the track layer to None to keep the spline stationary)?
  1. yes, the area to be replaced has an soft edge. you can see it in the file i have sent you
  2. tracking at full res is unfeasible in mocha. i usually track at half res
  3. I track from the beginning to the end. i track forward until i see mocha doing something wierd in tracking (track going off the geometry), go back 2-3 frames, adjust the spline doing the tracking, and continue tracking. over 450 frames or so, I need to do about 60-80 spline adjustments to prevent mocha from doing a bad track (lots of babysiitting) to continue the track.
  4. no i have not, i didn’t know about it and not sure how that is going to work. I’ll try

Okay. unlinked tracking is the best way to work for long shots, especially in 360 tracking.
Essentially you are treating the shape as a scanner and everything passing underneath it is tracked.

You do this as follows:

  1. Go to about the middle of the timeline
  2. Draw your shape near the center of the NADIR (avoiding the main FGD person and shadow), covering a squarish area (a rectangle will also work, but longer shapes need more supervising in case you don’t have a regular planar area)
  3. Go to “Link to track” in the layer properties and set the option to “None”
  4. Set up your surface as normal so you can check your track
  5. Track forwards. The shape will remain in place where you drew it, but the track will continue as normal.
  6. Go back to the original draw point and track backward

This won’t cover the matting problem you’re having as that appears to be a different issue, but it will make it easier to avoid needing to worry about it.

For foreground matte areas it’s best to start with a large hard-edged garbage matte and then refine the roto later once you’ve done the initial track.

1 Like