Mocha Tracking via Edit Mocha in 2020 Premiere effects isn't applying

It works is After Effects but is not working in Premiere. I am on the latest version of Premiere on Windows. When using s_lensflare for example, I “edit mocha”, track the points, save and quit, make sure the “use mocha” buttons are selected. The points move to what seems to be the beginning position of where I had the hotspot in Mocha but the track data isn’t applied. Works fine however in AE.

Please contact BorisFX support regarding this issue. They should be able to help sort through your issue with Premiere.

We were able to test out Sapphire 2020 in Premiere and it was able to track fine and the hotspot/pivot was able to follow the tracked hotspot/pivot.

Hi there,

we are having the same problem.

Tracking works fine when we open Mocha from Sapphire in Premiere. However, we do not understand how to put the tracking data from mocha into the keyframes of Premiere. Is there any solution?

Hi Jens,

There should be 2 params for S_Lensflare: “Hotspot Uses Mocha” and “Pivot Uses Mocha” which need to be enabled for it to use the mocha tracking data.

Hi linh,

thank you for your quick reply!

What exactly do you mean by need to be enabled? In Sapphire or in Mocha?

Hi Jens,
Please note that the Mocha masking/tracking embedded in Sapphire (or Continuum) is designed to support tasks inside those plug-ins, not export. For example, almost all Sapphire plug-ins can use the embedded Mocha masking to isolate effects. In 2020, Sapphire added Mocha parameter tracking that can drive positional data in filters like Zap, Lens Flare, etc.

If you are looking to export tracking data to Adobe native parameters in Premiere, please note this is not available in any product (Adobe does not support this process for 3rd party). The good news is we have many solutions:

  1. Mocha AE is free inside of After Effects and tracking data can be used to drive transform, skew and perspective. (Common usage to replace screens or track graphics to motion). Premiere users could send clips to AE to access Mocha AE. Mocha AE videos

  2. Mocha Pro - Mocha Pro for Adobe can run inside AE and Premiere. While Mocha Pro does export tracking to almost every available video host format (AE, Nuke, Flame, FBX, etc). Premiere does not support transform data from 3rd party Mocha Pro can render tracked screens or graphics via the insert module in Premiere. Mocha Pro has also has modules (stabilize, remove that add value in Premiere). Video link

  3. Continuum 2020 now includes Corner Pin Studio, which adds a similar workflow as Mocha Pro’s insert and you could run this in Premiere to use Mocha tracking and render tracked tracking, screen etc. Video link

Hope this helps,
Ross

Check out this video: https://borisfx.com/videos/sapphire-2020-intro-to-mocha-parameter-tracking/

Hello Rosss,

thank you for your reply.

It seems you understood me wrong. I do not want to export the tracking data. I want to use the tracking data at all.
Right now, tracking works fine. We put the sapphire lens flare in Premiere on a video, picked a lens and clicked “Edit Mocha”. In Mocha we picked tracking points. It tracked fine. But from there on it does not copy the path back into Premiere, so that the lens will move according to the tracking data.

We just tried the same thing with the BCC 3d lens flare and it worked without any problems.

So therefore we are wondering, how do we enable the hotspot XY and pivot XY, so that the flare will look properly?

Check the Hot Spot uses Mocha tick:

image

Sir, we do not have this option. What can we do?

It looks like you are not running Sapphire 2020. I would double-check the version you have installed. For more help please contact support:
https://borisfx.com/support/open-a-case/

Hello there,

so you were right about the version. We made an update and can now check “hotspot uses mocha” and “pivot uses mocha”. Using the tracking then worked, but only for two scenes. In the third scene it stopped working. Do you know why that can be?

Hello there again,

so we are still having problems with Sapphire/Mocha/Premiere. We made a quick screen recording, to show you the problem.

https://vimeo.com/frischmedia/review/386260619/f3cc147295

As you can see, Mocha tracked everything finde. However, in the next step you can see that the lensflare of Sapphire makes a strange downwards movement and does not hold the position of the lamp in the background.

Can you help us?

Hi Jens,

I’m curious if its because of the additional layers that has been added in Mocha in addition to the tracking hotspot. Is your project on full resolution?

Can you send us your project?

Thanks,
Linh