Mocha update timeline gone

Working on in hitfilm
Launched mocha pro, got update notification
Closed everything , did the update
Restarted pc
The timeline in Mocha is gone
Did a uninstall of Mocha
Reinstalled , restarted pc again
Same problem
Can’t use mocha anymore

So I went to the Boris website to download it again , maybe some went wrong in the download
Now I can’t login on the website anymore

Yep same here, it shows as it launches but then goes away immediatly, both Mocha Pro & Hitfilm are the latest versions i believe, changing the window from Classic doesn’t help.
I tried trimming off the first frame of the event as i’d read that somewhere about getting some FX’s to load but that didn’t help either,


In other programs i have you have to delete the plugins cache after something updates, to reload the plugins in the program
but i deleted plugins cache in Hitfilm

I went to C:\Users\gidjo\AppData\Local\FXHOME & deleted Hitfilm, neither helped,

It’s the same in Vegas Effects :unamused:

In Vegas Pro edit it works over here


Yep i checked Vegas Pro 19, it works in there but not in Vegas Effects or Hitfilm Pro,

Confirmed with me. Even though Mocha Pro is listed as a compatible host with HitFim Pro (latest version in my case), Mocha Pro OFX 2022 does not work in HitFilm Pro - there is no timeline display. Mocha HitFilm is fine though.

Definately a bug.
I hope the Boris Devs pick it up and solve it soon
It was working fine over here in Hitfim pro untill yesterday
Yesterday I got the update massage and installed the update
After that the problem started

The Boris team don’t work wk’ends so hopefully from Mon it will get sorted :+1:

Hi all,

This is a new bug that FXHome and the Mocha team are working to resolve. Essentially there is a problem with how timeline information is being sent to OFX plugins. We’ve seen a similar problem in Blackmagic Resolve.

We have a workaround coming in a new v9.0.3 update very soon. In the meantime, we recommend reverting back to v9.0.1 until the update is out.

For those working on Windows, we recommend uninstalling the v9.0.2 OFX plugin first before reinstalling v9.0.1, as Windows doesn’t like going backward.

You can grab the older plugin here: Boris FX | Legacy-downloads


Hi all,

We now have a fix for the HitFilm timeline issue in Mocha Pro v9.0.3: Boris FX | Downloads

1 Like

Thanks, yep the timeline is back,

I use Mocha in Vegas 19 normally not in VE but is when Edit in Vegas Effects the Mocha data supposed to transfer back to Vegas when Saved,?

here i added a sq spline as in the Mocha pic above, the simple black mask didn’t show back in Vegas, so i added a media clip that shows through the mask in VE but still doesn’t show back in Vegas 19,
Is it supposed to?

nothing showing in Vegas?

Ok got it to work with Edit in HitFilm by deleting the orig event on the HitFilm’s Editor timeline & replacing it with the composite shot,
but you can’t do that in Vegas Effects, there’s only the composite timeline not an additional Editor timeline like in HitFilm,
I guess this is a Vegas thing :unamused:

I don’t appear to have a problem editing the masks in Effects and having it refresh in Vegas Pro, but I’d be the first to admit that the Vegas Post suite is not my strongest skill set.

This is VE, black mocha sq on the back of the van

nothing in V19, is this how yours looks?

This could be an issue in Vegas 19 specifically. I see the effect fine in Vegas 18. you might need to clear the cache in V19.

Thanks, I’ve worked it out & now it works, someone on the Vegas forum suggested -

“After ‘first time’ going back from VE to VP, and seen the composited-clip not updated, try going to VE again from VP, and do nothing, go back to VP.”


1 Like