Mocha using Dual Screen

Hello All,
I’ve just downloaded and installed Mocha for AE v2. I have a dual monitor setup and the issue is that Mocha fills up the entire screen whereas I can’t access desk top icons. If I hit F1 I get the help doc but also now I have accesss to the bottom start bar but not the icons. So I how do I reduce the mocha window size? Will I be able to drag it to my other screen?
Also the window doesn’t allow me to view the other lay outs only the default.
What’s up with that?
By the way I’m glad to be here.
1luckydog

Not to beat a dead horse…
When I add the tutorial and go to View> all controls hidden (OK)
View> all controls visible I get a Run Time Error.
Here’s a portion of the error log:
Dec 11 09:57:12 (mocha for After Effects) Build Date Nov 2 2009
Dec 11 10:00:23 (mocha for After Effects) # ===> External exception thrown.
Dec 11 10:00:23 (mocha for After Effects) # File:.\Rendering\ISI_Render_OGL.cpp:1628:
Dec 11 10:00:23 (mocha for After Effects) # Context: glGetError() != GL_NO_ERROR in vSetCanvas() #2
Dec 11 10:00:23 (mocha for After Effects) # Message: OpenGL error 1281 has occured whilst rendering on line 1626 of file .\Rendering\ISI_Render_OGL.cpp
I’d like to know if it’s my system or the install that is causing this.
If this is not the place for issues like this then excuse me.
5fingers

Hello All,

I’ve just downloaded and installed Mocha for AE v2. I have a dual monitor setup and the issue is that Mocha fills up the entire screen whereas I can’t access desk top icons. If I hit F1 I get the help doc but also now I have accesss to the bottom start bar but not the icons. So I how do I reduce the mocha window size? Will I be able to drag it to my other screen?

Also the window doesn’t allow me to view the other lay outs only the default.

What’s up with that?

By the way I’m glad to be here.

1luckydog

I’ve got the Nvidia GeoForce 9600 GT. I updated the drivers from 175.16 to 195.62. The file version went from 6.14.11.825 to 6.14.11.9567.

Same issue when going from view all controls hidden to view all controls visible. Run time error.

Dec 11 16:48:33 (mocha for After Effects) Commenced logging at Fri Dec 11 16:48:33 2009
Dec 11 16:48:33 (mocha for After Effects) Build Date Nov 2 2009
Dec 11 16:54:19 (mocha for After Effects) # ===> External exception thrown.
Dec 11 16:54:19 (mocha for After Effects) # File:.\Rendering\ISI_Render_OGL.cpp:1628:
Dec 11 16:54:19 (mocha for After Effects) # Context: glGetError() != GL_NO_ERROR in vSetCanvas() #2
Dec 11 16:54:19 (mocha for After Effects) # Message: OpenGL error 1281 has occured whilst rendering on line 1626 of file .\Rendering\ISI_Render_OGL.cpp
Dec 11 16:54:19 (mocha for After Effects) #
file .\Rendering\ISI_Render_OGL.cpp
Dec 11 16:54:19 (mocha for After Effects) #
Dec 11 16:54:19 (mocha for After Effects) # ===> External exception thrown.
Dec 11 16:54:19 (mocha for After Effects) # File:.\Rendering\ISI_Render_OGL.cpp:1628:
Dec 11 16:54:19 (mocha for After Effects) # Context: glGetError() != GL_NO_ERROR in vSetCanvas() #2
Dec 11 16:54:19 (mocha for After Effects) # Message: OpenGL error 1281 has occured whilst rendering on line 1626 of file .\Rendering\ISI_Render_OGL.cpp
Dec 11 16:54:19 (mocha for After Effects) #

I got a question into Nvidia about this. Thought I could find a list of OpenGL error codes but I couldn’t. I did see a couple of threads dealing with 1281 but I couldn’t figure out what they were talking about.

5fingers5

Duh…
Thanks. That did it but…
With my main monitor I can expand the window OK. When I move it to my larger monitor and expand it I get a Runtime Error and it terminates.
Oh well, It’s not a show stopper. Other then that all is well. Now it’s time to hit the tutorials and manuals.
5fingers5

Duh…

Thanks. That did it but…

With my main monitor I can expand the window OK. When I move it to my larger monitor and expand it I get a Runtime Error and it terminates.

Oh well, It’s not a show stopper. Other then that all is well. Now it’s time to hit the tutorials and manuals.

5fingers5

Not to beat a dead horse…

When I add the tutorial and go to View> all controls hidden (OK)
View> all controls visible I get a Run Time Error.

Here’s a portion of the error log:

Dec 11 09:57:12 (mocha for After Effects) Build Date Nov 2 2009
Dec 11 10:00:23 (mocha for After Effects) # ===> External exception thrown.
Dec 11 10:00:23 (mocha for After Effects) # File:.\Rendering\ISI_Render_OGL.cpp:1628:
Dec 11 10:00:23 (mocha for After Effects) # Context: glGetError() != GL_NO_ERROR in vSetCanvas() #2
Dec 11 10:00:23 (mocha for After Effects) # Message: OpenGL error 1281 has occured whilst rendering on line 1626 of file .\Rendering\ISI_Render_OGL.cpp

I’d like to know if it’s my system or the install that is causing this.

If this is not the place for issues like this then excuse me.

5fingers

I’ve got the Nvidia GeoForce 9600 GT. I updated the drivers from 175.16 to 195.62. The file version went from 6.14.11.825 to 6.14.11.9567.
Same issue when going from view all controls hidden to view all controls visible. Run time error.
Dec 11 16:48:33 (mocha for After Effects) Commenced logging at Fri Dec 11 16:48:33 2009
Dec 11 16:48:33 (mocha for After Effects) Build Date Nov 2 2009
Dec 11 16:54:19 (mocha for After Effects) # ===> External exception thrown.
Dec 11 16:54:19 (mocha for After Effects) # File:.\Rendering\ISI_Render_OGL.cpp:1628:
Dec 11 16:54:19 (mocha for After Effects) # Context: glGetError() != GL_NO_ERROR in vSetCanvas() #2
Dec 11 16:54:19 (mocha for After Effects) # Message: OpenGL error 1281 has occured whilst rendering on line 1626 of file .\Rendering\ISI_Render_OGL.cpp
Dec 11 16:54:19 (mocha for After Effects) #
file .\Rendering\ISI_Render_OGL.cpp
Dec 11 16:54:19 (mocha for After Effects) #
Dec 11 16:54:19 (mocha for After Effects) # ===> External exception thrown.
Dec 11 16:54:19 (mocha for After Effects) # File:.\Rendering\ISI_Render_OGL.cpp:1628:
Dec 11 16:54:19 (mocha for After Effects) # Context: glGetError() != GL_NO_ERROR in vSetCanvas() #2
Dec 11 16:54:19 (mocha for After Effects) # Message: OpenGL error 1281 has occured whilst rendering on line 1626 of file .\Rendering\ISI_Render_OGL.cpp
Dec 11 16:54:19 (mocha for After Effects) #
I got a question into Nvidia about this. Thought I could find a list of OpenGL error codes but I couldn’t. I did see a couple of threads dealing with 1281 but I couldn’t figure out what they were talking about.
5fingers5

Well it looks like the Graphic Card gods have smiled on me as I can now choose hide/unhide the window controls, change default views without getting the runtime error at this time.
The only thing I can think of is that after upgrading the cards drivers and resetting the computer a couple of time over a few days may have cleared the issue.
At this time all is well.
5fingers5

Well it looks like the Graphic Card gods have smiled on me as I can now choose hide/unhide the window controls, change default views without getting the runtime error at this time.

The only thing I can think of is that after upgrading the cards drivers and resetting the computer a couple of time over a few days may have cleared the issue.

At this time all is well.

5fingers5

Thanks for letting us know! Please keep us updated if you run into further problems.

Hi 5fingers5,
If you need to change the window size, you can go to Preferences… under the File menu and click on the the System tab. Under the UI Look and Feel section there is a radio button option to be in full-screen or windowed mode.
Select Window.

Hi 5fingers5,

If you need to change the window size, you can go to Preferences… under the File menu and click on the the System tab. Under the UI Look and Feel section there is a radio button option to be in full-screen or windowed mode.

Select Window.

Okay, so it appears to be an openGL problem.

Can you try updating your graphics drivers to the most current compatible release? I have just tested the scenario on our machines here and we can run the software on either screen with no problems.

—Quote (Originally by 5fingers5)—
Duh…
Thanks. That did it but…
With my main monitor I can expand the window OK. When I move it to my larger monitor and expand it I get a Runtime Error and it terminates.
Oh well, It’s not a show stopper. Other then that all is well. Now it’s time to hit the tutorials and manuals.
5fingers5
—End Quote—
Thanks for the report, we’ll check that out! Obviously it should not do that. :slight_smile:

—Quote (Originally by 5fingers5)—
Duh…

Thanks. That did it but…

With my main monitor I can expand the window OK. When I move it to my larger monitor and expand it I get a Runtime Error and it terminates.

Oh well, It’s not a show stopper. Other then that all is well. Now it’s time to hit the tutorials and manuals.

5fingers5
—End Quote—
Thanks for the report, we’ll check that out! Obviously it should not do that. :slight_smile:

Okay, so it appears to be an openGL problem.
Can you try updating your graphics drivers to the most current compatible release? I have just tested the scenario on our machines here and we can run the software on either screen with no problems.

Thanks for letting us know! Please keep us updated if you run into further problems.