Mocha VR Horizon Line Problem

Hello! I recently started using Mocha VR and it’s done a fantastic job so far. I had a lot of great results from the reorient tool, but when I started working on another machine, the reorient tool would no longer function correctly. When trying to move the horizon line, it would just shift the entire line and wouldn’t bend to properly match the horizon.

Any ideas what could be causing this?

Can you try turning off GPU tracking, this sounds like a draw error to me and I am curious to see if that will fix this issue. It may be a bug, and we will need to find out why. Just to double check though, did you track a layer before you went into the reorient tab? And have you selected that tracking layer and turned the gear on for that layer?


I tried turning off GPU tracking, but sadly no luck. I double checked that the track layers have the gear on.

Weirdly, when I open a project that was tracked on a different computer, I can go into Mocha VR and edit the horizon line as normal, however if I start the project on my main rig, the horizon line will never curve, it will just shift around as a straight line. I’ve tried this with three different shots and they all track great, but the reorient tool won’t work for me (unless I create the project on a different system first).

The two systems I work from are almost identical, except one has a GTX 1080 for a GPU, while the main rig (the one having issues) uses a GTX 980ti. Both machines are running Windows 10.

Weird, I am going to loop Martin in on this one, this sounds bugish.

Can you check to make sure your default Lens calibration in mocha VR on the problem machine is set to Equirectangular? You may be working in a Linear camera format.

Yes, I double checked and can confirm the lens is set to equirectangular.

The only other notable difference with the problem machine, was it was previously working with the beta build of Mocha VR. I also had this same problem with the beta build but I didn’t report the problem because I assumed I was doing something wrong and not that there was a bug. After purchasing the full release of Mocha VR, I found it worked great on the machine I initially installed it on, but that the issue was still there when transferring the license to the original machine.

I did try reinstalling the plugin, but that didn’t help. Could this issue be related to the fact that the machine was previously working with the beta?

Being a previous beta user could definitely be a factor.

Try deleting your mocha VR preferences from the registry. There could be some miscellaneous changes affecting your release build.

I’m looking at the Imagineer Systems folder within the Windows Registry Editor, but I’m not sure what I should be deleting to reset my preferences. I see one called “_SettingsVersion”. Is that what I need to delete?

The one you need to delete is called:
HKEY_CURRENT_USER\SOFTWARE\Imagineer Systems Ltd\mocha VR Plugin 5

I deleted the key, but now even after reinstalling Mocha VR, I’m told it can’t find the key so I’m unable to activate it. The good news though is that when I booted Mocha VR up in LE mode, the horizon line now functions as it should!

Any idea how I can fix the key problem and activate the software? Reinstalling doesn’t seem to put the key back. When I run the installer it doesn’t seem to do anything and just goes straight to “install finished.”

Hi there,

It sounds like you need to reactivate or use a manual key, please contact support here and they will reset/issue you a manual activation key.



Awesome, thanks for all the help!