Mocha VR remove module not reflecting in AE


#1

I’m using Remove to take someone out of a scene, and the results are working perfectly when rendered in Mocha VR (AE plugin version 5.6), but when I save and close, the results are not reflected in my AE comp. ‘Remove’ is selected in the module renders section, and the ‘render’ checkbox is ticked.

Any tips?


#2

What are your settings in the remove module? What does the remove render look like in mocha when you do a test remove?


#3

Hi Mary,

As ever, thanks a lot for the reply.

I’ve attached a picture of the remove module settings, as well as the before and after render. To me it looks like it’s doing a good job, I’m just not sure why it’s not updating in AE.

Thanks again.

1723


#4

Sorry if this is something that you’ve already tried but I wonder if this might be a stale cached issue? You might try purging the frame cache in AE (Edit>Purge>All Memory and Disc Cache) to see if this will force the host to render correctly.


#5

Thanks a lot Peter, will try that now.


#6

Yeah, definitely clear the cache, but also try increasing your step and reducing the frames before and frames after, it may just be it’s taking a while to render. Also, obviously, check and make sure the plugin isn’t accidentally turned off. I know you probably already checked that, but I do it to myself all the time.


#7

Unrelated to your issue, but is that shot using a moving camera?


#8

It’s not no, a static camera with people walking in front of it messing up my nice Antarctic vistas :slight_smile:

Still can’t get this to work, but I think it’s something I’m doing wrong rather than a Mocha issue. Test render is fine on one frame, but changes not rendering back to AE timeline, nor is the remove visible if I export the rendered clip from Mocha itself.

The quest continues…


#9

Yeah, that does sound odd.

If you want to shoot the project over to me, I can take a look: martinb[at] borisfx.com


#10

Sent you a mail, many thanks for the help. Much appreciated.


#11

For everyone’s benefit:

As it turns out, if you have the BOTTOM LAYER process cog turned on in the Remove module, it will not render back to the host timeline!

I’ve filed a bug for this, but the easy workaround is just to turn of this process cog in the layer controls and only leave on the rendering cog for the layer you need to remove.


#12

Thanks again Martin!