MochaVR OFX - popOS Installation Errors - Davinci Resolv

Version: Mocha VR OFX Plugin 5.6.0

Platform: popOS 20.10 (kernel 5.11.0-7614-generic) Ryzen 3600XT, RTX2080, 64GB RAM

Unable to install MochaVR for DavinciResolve. After installing Davinci resolve crashes on first launch, and disables mochaVR on subsequent launches.

I know Davinci and Mocha are both certified for RHEL variants, not Ubuntu variants, but I’d prefer to use ubuntu for other reasons, which is why I’m posting here rather than opening a support ticket.

Based off other posts I’ve red. I tried running:
rpm -Ufvh mochaVROFX-5.6.0-1601.gcc41335b663b.rhel.rpm

which gives me:

rpm: RPM should not be used directly install RPM packages, use Alien instead!
rpm: However assuming you know what you are doing…
error: Failed dependencies:
xclip is needed by mochaVROFX-5-1601.gcc41335b663b.x86_64
/bin/sh is needed by mochaVROFX-5-1601.gcc41335b663b.x86_64

I manually installed xclip with sudo apt-get install xclip. But I’m still getting that error. Also strange that it thinks /bin/sh doesn’t exist.

I’ve also tried installing with alien, but no luck with that either, despite it not throwing any errors.

Curious if anyone’s had luck getting this going on a Ubuntu based distro. Or if there’s anything else I can try! I’ve tried other plugins to confirm resolve is able to load OFX plugins. I also tried installing MochaPro 2021, but it also had missing dependencies that weren’t available by default so I left it alone for now.

Convert it to deb pkg first by using alien.

It can be done using alien --to-deb (file_name).

After doing this now run the file it will be installed.

Hi Sean,

Mocha Pro is not supported on Resolve on Linux due to a hard crash. This is a Resolve-side issue. I’ll chase up to see if this bug has been addressed yet by Blackmagic.

Are you on the latest build of Resolve?