Modifying Particle Illusion to change characters of Digit Column

Hi. I would like to make use of the Digit Column emitter however, I also want to use a subset of alpha characters. How can I modify to produce the effect I’m looking for?

https://borisfx.com/products/particle-illusion/#learn

Video 14. At about 6:30 Ben talks about changing the particle shape (sprite, image). In that dialog there is an option to import your own images, BUT…

…that feature may not work reliably. It’s a known issue that we’re working on, but it may not work for you with the current release. (Give it a try though!)

@fotiadis1 Hi, a little while back i created some tool images to use in place of the shape on a particle illusion,
To create the shape sequence I had to import cut out png pics into the Vegas timeline, change the length of them so each pic was only 1 frame in length, so the first frame was one pic, the second frame was another pic, the third frame was a different pic etc…
Then export/render the whole thing as an image sequence, that put the pics in a folder as png’s, those then would load into PI as a shape sequence, ,
but that was quite a while ago & i just tried that on the Digit Column, it would let me change the shape image to one in the options but it wouldn’t let me import the tools image sequence i’d created,
so i loaded the Basic emitter onto the screen, on the particle shape it let me import the tools sequence into the Emitter library (the one below Current Emitter), i could then use those in the library to change the ones in Digit Column,
I didn’t try it this time but last time it imported both Greyscale or Full Colour, both/either worked fine,
If you want to use a subset of 1-9… you might have to create your own png no’s,
A bunch of png’s in a folder won’t work as a sequence, when you go to change the shape you can only pic one of the png’s, but if it’s exported as a sequence, when you go to the folder & pic 000000 it gives the option to import the whole sequence
I don’t know if this is what you’re after.

The images in this folder are 1920 x 1080, PI scales them down

Thanks, Gid. That sort-of worked. When @Alan_Lorence mentions “may not work”… should be “will not work” in stand-alone client. I wasn’t getting anywhere and was going to give up and then thought of trying the OFX plugin.

So what I learned is that you can’t do any of this stuff in the stand-alone app…you need to use the OFX host to get anywhere with it. The stand-alone Particle Illusion will leave you extremely frustrated. Not that OFX experience is a charm but at least it sort-of works in a limited way.

So…bug patrol for the standalone app, there’s one for the list.

That’s strange – the PI app portion of both products should be identical. Are both the same version? (Check the “About…” dialog in PI when it’s open)

Hi, i just tried it in both, as Alan says they’re the same on my machine,
I normally use the plugin but opened the standalone for this, I already had the tools shape image sequence in my Library (Gids) from before, so i opened a basic emitter which let me add a different sequence i had saved,
That worked just fine, i then tried that imported sequence on your Digit column, no prob :man_shrugging:



I tried it importing the full colour image sequence, that worked fine too in the standalone, i just had to change the colour to white so it didn’t tint the images

Just realised why it would only offer to import to Current emitter when trying to import the shape when on the Digits one,
I need to have my library selected on the left highlighted blue, ‘Gids’. it then shows Emitter Library below Current Emitter, so there’s no need to open the Basic emitter to import sequences :man_facepalming::+1: