More efficient Morph node workflow for my specific usage?

Greetings,

I’m using the Morph node to morph to sections of the same clip of a talent speaking, but skipping 20 frames ahead on the B clip. Is there a more efficient workflow to use versus what I did below? This flow works 100% correct, but just seems to be a very manual process for eliminating dead space on this type of clip. Thanks for any input on this :slight_smile:

Current Workflow:

  1. Sent my original clip to A input on the Morph Node
  2. Tracked and added splines for morphing
  3. Made a second copy of the clip and connected it to B input on the Morph node.
  4. Offset the B input clip by “-20”
  5. Copied all the splines from A input, switched to B input and pasted all the splines to the B input
  6. Adjusted the start my working range to -20
  7. Shifted selected all the B input spline key frames l, then manually dragged all the B input spline key frames to start at the -20 frame.

Using the Morph node, I can’t think of a way to make this any easier.

The other option may be to use S_RepairFrames. You could cut out the pause using the Sequence Editor and then feed that into S_RepairFrames. You would then manufacture the needed frame/s at the cut point so it doesn’t look like a cut.

Thanks Marco, I’ll give the S_repair a try on a future clip, Regarding the Morph, I’m having a problem where I put a Roto node on my A clip to isolate the talent being morphed and a then copied that roto to the B clip which was shift -20 frames back, but the Output of the Morph is not using inputted Rotos from the the A and B clips. When I view A clip and then view B clip on the Morph node , individually the inputted rotos look correct, but my Morph output shows up as empty. Any thoughts on the problem here? Thanks again.

I would need to see your project/media.

Hi Marco, I’ll see if I can simplify the project roto to send.

I also noticed that I had turned off some of my morph shapes to see if anything changed, and apparently, the morph shapes that were closed shapes actually does allow the morphed clip to show through. I haven’t tested it yet, but does this mean I actually need to have the roto talent cutout as A and B shape layers within the morph node? Or would I just need to do an AE precomp’d Silhouette talent cutout roto only version of my clip first, and then apply the Silhouette Morph work as a plug-in to the precompd AE layer? Thanks again!

I am having a hard time visualizing what you are doing. I would need to see your project/media and a description of what you are trying to achieve.

This screenshot shows my current setup.

The problem happens if I try to send the roto inputs into the Morph A and B inputs. The end result from the Morph node is that it does not recognize the rotos that come in. It seems like I might need to create a separate already cutout roto input of the talent first, and then just input that as my A and B.

Depending on what you are trying to accomplish, adding a Premultiply after each Roto node may work for you.

Hi Marco, Ideally my goal is to isolate the talent via Roto before passing it through the Morph node. Thanks for this, I’ll give it a try. Also, not sure if this is expected behavior, but I noticed simply moving my forehead A and B shapes below or above other shape layers in the layers tree causes the A to B connections to break and then I have to recreate the connection links. Can you please let me know if this happens to you? Thanks again.

I am not able to replicate this in my Morph project.

Hi Marco,

From what I’ve tested, even with using the premultiply nodes, unfortunately, it seems that there is no way to maintain the roto cutouts created on the A and B sources prior to going into the Morph node. I would have to create a roto cutout after the morph which is not ideal incase I end up tweaking the morph or shifting/extending the morph length, or I need to create a separate AE precomp of just a Silhouette roto cutout in a different a Silhouette project file, and then apply my Morph Silhouette project onto that already cutout precomp layer.

  • If I set my Silhouette AE to render: Output: Composite, Clear Alpha: the morph shows up correctly except the background is all black instead of alpha
  • If I set my Silhouette AE to render: Output: Cutout, Clear Alpha: all I see are the tiny areas I did some roto painting on
    *Skipped Silhouette AE to render: Paint
  • If I set my Silhouette AE to render: Output: Roto: I get a proper cutout, but apparently the morph gets completely ignored and it’s only showing me the roto cutout of the original A source clip

Can this feature be added to the Morph node in the future, so that it will maintain the roto node alpha created before coming into the Morph node? Thanks for you input on this.

Thanks for letting me know on the correspondence points.

Hi Marco,

Here is simplified Silhouette project showing how I cannot find a way to get the Morph node to display the transparency even when using to clips that have a transparent background already in the files. No matter what I’ve tested, it seems that a post-Morph roto cutout would be the only way to get a transparent background to show up for comping. For reference, this video explains in more detail what I tested in this sample project. Thanks for you help on this :slight_smile:

Silhouette Morph Test - using sources already rendered with background removed.zip (217.7 KB)

Video reference

Thanks for the video. It was helpful. The source of the compositing issues is that the Morph node is not working properly at 4:1. I have filed an issue for this. At 1:1, the Morph node outputs alpha for any shapes that are set to generate alpha as long as the Output Alpha is set to Cutout.

Hi Marco,

I showed in the video that the two shapes each have a transparent backgroun (alpha) in them, which is clearly seen when simply compositing the shapes directly with the cyan background layer. What I also showed in the video is that there is NO WAY to get a transparent background from the Morph node output (test 1 and test 2) without a post-morph Roto node ( test 3), no matter what settings I chose. Even when working at 1:1 res, this is still the problem.

Can you please look a the sample project and let me know why is the Morph node ignoring the alpha (transparency) of the star and circle images. Thanks.

In the Test 1 example, set X-Spline 1 and X-Spline 2 to Generate Alpha and in the Node parameters, set Output Alpha to Cutout.

I’m specifically asking about how to get the Morph node to use the ALPHA ALREADY EXISTING in the source Star and Circle without having to spend extra time drawing perfectly aligned cutout shapes inside of the Morph node, when the alpha is already there just like when I simply comp’d the star over the cyan background. It’s redundant and a poor use of time if I’m using source clips that already have transparency, but then have to actually redraw the cutouts within Morph (test 2) or do a post-morph Roto node (test 3)

Is my understanding correct, that presently there NO WAY to get the Morph node to display the alpha existing in the sources? If I misunderstood, please tell me how to get the source alphas to show up when passed through the Morph node.

If this is currently not possible, I would like to request that this be added to the Morph node. Thanks for clarifying this.

The Morph node is set up as a shape based morpher and requires shapes. It will not use the incoming alpha of the source clips to automatically generate the morph.

Why can’t the Morph node just show the alpha of the incoming source, just like the Composite node?

To clarify, I am specifically asking about why WHY DOESN’T the Morph node show the source alpha/transparency like a Composite node? I’m fully aware and completely understand that the Morph node requires user generated A and B splines/shapes for doing the actual morph. This is NOT I am asking about. My question is ONLY regarding why the Morph node does not show source alpha/transparency?