Multi-spline layer looks perfect in Mocha but can't export properly

Hi Mary P!

Tracking something that goes beneath your feet seems impossible. If it is, please let me know! Its POV footage of a street…

Project settings such as frame rate, dimensions and pixel aspect ratio all match between my mocha project and my AE comp. I tracked in increments & pieces using “add x-spline to layer.” I enabled and disabled translation, scale, rotation, shear, & perspective whenever appropriate. I even deactivated some points in a spline that go off screen and reactivate when back in full view (this seemed to help track the most). When I inserted a grid clip, the track looks perfect in mocha. I know the most important part of the track is to make sure my planar surface is in tact but the planar surface shifts so drastically off screen (as it should since the perspective of the footage does like so). Because of this drastic perspective shift, errors occur during the export and half of my corner pin keyframes are missing. Any help would be greatly appreciated.

Thank you,


mocha example 2

mocha example 1

What are you trying to do exactly? If you’re trying to replace the whole road you’re going to have an issue. For tracking planar data onto the road, you’re fine, just track from the end to the beginning of where you need to track and you won’t have your surface fold in on itself. Try that and let me know?

Thanks for the swift response.

I’m not sure what you mean? I am just adding an image onto the road, not replace it in its entirety, although I would like the image to be nearly as long as the bike lane. Do you mean to just track one spline from top to bottom of the screen or clip? Because I tried using one spline in the middle of the road but the clip is about 4 seconds and no object stays on screen the whole time.

I mean track the ground, but track from the end of the shot to the beginning because you’re moving forward. You want the track to move backwards in space, if it moves forwards it can go behind the viewer in mocha and ruin your track. You need to also try unlinking the track from the spline (link to track dropdown set to “none.”) This will help your track be more solid as your bike moves, since the ground plane is always the ground plane, it will read the data as the track moves.

If you’re having corner pin issues it’s probably a mismatched alignment. Try this:
Please let me know if you have any more questions and I will be happy to help you.

Tracking backwards while unlinking the track works wonderfully! But the planar surface still folds onto itself about a quarter of the way through. When that happens, I try to AdjusTrack but that doesn’t help much. I think the problem is the perspective extends so much outside the viewport, the corners basically vanish. I tried to make due with three separate tracks overlapping.

Thanks Mary!

Hmm, if you’re still having that problem, can you send me a screenshot to and I’ll look at it?