MXF Support?

I am trying to start a new project that will have heavy Mocha use. I have Mocha 5 both plugin and stand alone. I am trying to use the standalone version, and for whatever reason the MXF files that have worked in previous versions of Mocha do not work in Mocha5. Has MXF support been removed for some reason? The same files work in the plug-in version (Ae) but when moving to stand alone, the files will not work. I tried to open older projects in Mocha5, and the files are offline there as well and will not reconnect. Do I need to reinstall or try something else? It seems odd that the files don’t work.

 

Thanks!

 

Jeremy

Hi Jeremy,

The MXF files have never been supported in mocha as far as I know, but in the plugin, they work because mocha reads off your timeline and your host software can read MXFs. Please let me know if you have any other questions and I will be happy to help you.

If thats’s so, how did they work in Mocha4?

They should not have. They are not on our supported file list. If they did, I am not sure why. Our supported file list is:

Movie clip formats

  • AVI files (.avi)
  • DV Stream files (.dv)
  • MP4 files (.mp4)
  • MPG files (.mpg)
  • QuickTime Movie files (.mov and .qt)
  • RED files (.r3d)

Image formats

  • OpenEXR files (.exr)
  • OpenEXR 2.0 files (.exr)
  • Cineon files (.cin)
  • DPX files (.dpx)
  • JPEG files (.jpg and .jpeg)
  • PNG files (.png)
  • SGI files (.bw, .iris, .rgb, .rgba and .sgi)
  • TGA files (.tga)
  • TIFF files (.tif and .TIFF)
Are you sure they were not quicktimes and not MXF files? I can ask our dev team just to be sure though.

Thanks, Mary. I am positive that they are MXF, They are camera original footage from a Sony F55.

 

Here’s the clip info from Mocha Pro 4:

[caption id="" align=“alignnone” width=“1393”] Mocha Pro 4[/caption]

 

 

Here’s the same project opened in Mocha Pro 5:

 

[caption id="" align=“alignnone” width=“2039”] Mocha Pro 5[/caption]

 

Thanks!

Now, I can’t import .mov to the insert module:

[caption id="" align=“alignnone” width=“470”] mov[/caption]

Should I reinstall or something?

Well, you need to make sure you have quicktime installed, that might be the issue if it’s not reading .mov files, or you need to update your codecs. Not all .MOV files are created equal, codecs change their readability. If users have security concerns and do not want to use Quicktime on Windows, but still want access to .MOV and .MP4 codecs, we recommend that they uninstall QuickTime Player, and install only the QuickTime Essentials part of the package. This substantially reduces the attack surface and reduces QuickTime to the status of a faceless library on their system which will only be used inside of other software for codec decoding. For v5 users, the mocha Pro 5 Plug-in option is the ideal solution because it has no dependency on QuickTime and reads the image data right out of the host’s timeline. For users who are unable to upgrade to mocha Pro 5 the Plug-in, installing the codecs alone will help solve some of the problems users are encountering with Quicktime on Windows.

If you have trouble installing only the quicktime essentials, try this method:

  1. Fully uninstall Quicktime and delete any Apple folders left on your machine for a clean uninstall.
  2. Reinstall using the full installation option with the player installed as well.
  3. In your program management configuration panel, select the uninstall option and ask Quicktime to be “modified.”
  4. Uninstall Quicktime Player only but keep the full library of codecs you need to read .MP4 and .MOV files.
The media engine inside of mocha is based off Quicktime, we are working on becoming quicktime independent, but it's been that way for a long time and requires changing architecture. Try making sure all those components are installed correctly.

Then, if you’re still having issues, maybe installing mocha again is a good idea. Please let me know your progress.

Again, I am using the plugin as MXF files don’t work, and the .mov isn’t working in the insert module (within the plugin).

I’m on a Mac (OS X El Capitan), so there is no QuickTime to uninstall, and codecs are up to date.

It’s weird that the exact same media works in Mocha 4 Pro and not Mocha 5 Pro, and that .mov files don’t work in the insert module from within Ae CC 2015 plugin on a Mac.

Right, but you were also saying you couldn’t import the movie file, hence the info about codecs and quicktime, which usually fixes that issue.

I am going to have to do some research. Stand by.

 

OK, I just tried to open an MFX file in V4 and V5 and it isn’t supported in either, so if you got that to work in the past it was a happy accident.

Can you try loading the quicktime into your comp and using it as the insert layer instead of importing it right into the plugin? That workaround should fix it.

Wow. I did an entire project with ton of tracking with MXF and Mov. Happy accident indeed.

I guess I don’t understand how the insert par of the plugin works.

If I do the tracking and setup surface on the background layer, enable the render on insert module: cutout in the plugin back in Ae, choose the insert layer that I want to insert in to the surface (which is a QT movie in my Ae comp), the target layer does not get inserted, nothing happens actually. What steps am I doing wrong?

The only way I can get the insert to show up is using the insert module in the Mocha interface.

Yeah, I am glad you were able to complete that project! We have had some reports of users being able to use those types of files but inconsistently. Usually it is dependent on MXF support via a component plugin for QuickTime, and if you already have that installed properly, the behavior should be the same. Either way, we can log it as a regression even if it isn’t an “officially supported” format.

MOV files not loading properly into the plugin is definitely a bug and I have made our product manager aware.

OK, so to load your MOV file as an insert layer… in the mocha Pro plugin interface inside After Effects, before you launch mocha, there’s a section to apply the insert layer. The insert layer can be any layer inside of your AE comp.

From here you launch mocha.
In the insert layer in the mocha interface, you select “insert layer.”

Then it should populate. Have you been trying that? If not, I can give you a call. You can email me at maryp@imagineersystems.com with the best number to reach you at.

Cheers,
Mary

Mary, thank you.

I was trying to load the insert layer after doing all of the tracking back in Ae, but with your help, I now see that adding the insert layer before launching the plugin, and changing the source to “insert layer” works as expected. This helps me out tremendously and thanks, as always, for your patience.

Jeremy

iDealshare VideoGo also helps to convert MXF to MPG, AVI, WMV, MP4, MOV, VOB etc