Needing some guidance w/ GPU Settings for both Vegas Pro 16 & Boris FX


#1

Long story short, I have a NVIDIA GeForce GTX 1080 TI (as well as the Intel HD 530) on my Dell XPS 8900 w/ 16 Gigs of RAM. I’m using the new Continuum 2019 fx

Whenever I use the Particle Illusion, it begins to lag ridiculously in the preview window or just freezes/crashes all together. I’m admittedly new to Boris FX so I need whatever tweeks I can get.

GPU acceleration is on, on the preferences of Vegas 16. It doesn’t matter if I set it to the 1080 ti or the Intel HD, it’s the same result. Same goes for the quality of the preview window. Draft all the way to Best, does not help.

It even freezes on the timeline of the Particle Illusion launch after the FX is added.

If anybody has any advice or starting points, it would be much appreciated. Be it NViDIA Control Panel, or how to set preferences, anything will help.


#2

Hi Eric,

If you are experiencing any crash with the software please provide us with steps to reproduce and if possible a project or a preset - in the testing that we performed in our QA labs prior to releasing the software we did not see any freezing or crashing at all. There were times when there was a noticeable lag before the rendered frame appeared but definitely no freezing or crashing and below I will explain how to avoid any lag in rendering a frame while working with Particle Illusion.

One thing to keep in mind when working with Particle Illusion is that when you click on a frame in the timeline, the software has to render all frames up to the selected frame in sequence and therefore when working with a very emitter heavy composition, or on a long clip with a single emitter in the stage, and you click somewhere further down the timeline (which kicks off a render event) you will find that there can be a pause or slight lag while the software produces the result for the current frame. Notice that if you press the play button and let all frames render in sequence you’ll see that the actual rendering is quite speedy, especially considering all of the calculations that are being performed under the hood. So basically, it’s only when you go out of sequence that you can see any kind of a lag.

The Preview window is where you’ll be able to get real-time rendering from any emitter - just click on an emitter in the library and it will immediately play an animation of the selected emitter in the preview window. You can also drag the cursor in this window to understand what this emitter will do when the source point is animated. It’s a really good way to preview any emitter in the library before committing it to the scene.

That said, this is an area that we feel we may be able to improve upon and our engineering team are currently looking into ways to enhance the user experience with this software.

Thanks,

Peter.


#3

Thanks for the reply, peter. I’m attaching a video so you can see exactly what I’m working with. Do not hesitate to tell me that I’m doing something completely wrong as I am new to this.


#4

https://youtu.be/viqZ-4cVPDw If the video comes up in error.


#5

Hi Eric,

Thank you for sending the screencap video - it explains everything and I now fully understand the issue that you’ve encountered. I’ll share this with our engineering team so that they can see the problem for themselves.

Have you tried to render the result to see if this helps the playback issue that you’re seeing in the Premiere timeline? I find that doing so results in full speed playback with no dropped frames. Obviously this won’t help when you’re in the Particle Illusion custom UI though.

So what can we do in the short term to make working with Particle Illusion a smoother process for you? Well looking at how you need to use Particle Illusion, I can tell that you might want to try using a workflow whereby you either render the effect layer and then continue to work with it or render and then export the particle effects from Premiere as a clip, then import the rendered clip and layer this over your animated still image - following this method should give you real-time playback in the Premiere Pro timeline. The workflow I am suggesting here would be :

(1) in the premiere pro timeline, add a new track (V2) above the animated still image that you want to have as the source (V1), and add a transparent video element to the V2 track making it the same length as the animated image source

(2) apply Particle Illusion to the media element on the V2 track and select the burning embers preset

(3) turn off the visibility of the V1, the track containing the animated image source

(4) all you should be seeing now are the particles - render this and export the result to disc

(5) import the rendered / exported particles result, replacing the media element on V2 with the imported particles clip

(6) turn on the visibility of the V1 track

(7) in he effects control panel, under the Opacity group twirl down, set the apply / blending mode to generate the result / look that you had in mind for this shot, maybe try the Screen mode.

I know it’s kind of clunky but the problem is that you’re using Particle Illusion on a 30 second clip - that’s a really long clip in the world of Particle Illusion but we recognise this as something that you and others need to do - hopefully we will soon be able to offer an update to the software that will eliminate the long delay and staggered results that you’re seeing while using Particle Illusion as a live filter on long clips.

I hope this helps.

Thanks,

Peter.