New Kid on Blockhead : Image import IS STRETCHED

Greetings. Very happy to have Mocha. Learning.
When I start a new project, I import an mp4 off my Sony HD DSLR. 1080
Mocha is only showing part of the frame size and it stretches and flattens it in a peculiar way.
Thus, anything I do arrives at AE all messed up.
How do I get to see my whole video clip in Mocha?
Me try and try. Me tired.
Thanks.
Tim
.

Is it a standard 1920x1080? Are there any blank frames at the beginning?

Ok, in that case the pixel aspect ratio should definitely be 1.33 in mocha (see the setting in AE). As to the clipping, that is very bizarre.
Can you send me the clip?
martinb[at]imagineersystems{dot}com.

We don’t recommend using mp4 as it can sometimes compress in strange ways. I would convert it to an image sequence or an mov format.
However if the frame is just squashing down, you may just need to readjust your aspect ratio. When you import it, try setting the Pixel Aspect Ratio to Custom in the dropdown and set the value to 1.

Okay, if it’s 1440x1080 then it’s not a Square pixel aspect ratio. That’s HDV (1.33) aspect ratio.
Is the footage interlaced as well?

My recommendation is not to use mp4 OR h264. It’s a lossy unreliable format.
Obviously this shouldn’t be happening in the windows version of mocha, but I would recommend using image sequences until we can work out why the format is not playing nice.

If it’s 1920 subsampled to 1440 then it’s aspect ratio has to be stretched. What is the setting for the footage inside after effects?

Ok, looking at the clip it is interpreting exactly as HDV 1.333 format but not clipping. You’ll notice in my version the filmback size is different, so this is possibly a codec or hardware issue on Windows dealing with QuickTime.
Try updating your graphics drivers to the most recent stable release. Failing that, try converting the mp4 to another format. I would suggest an image sequence.

I can repeat the problem you have with the weird clipping and stretching on windows with the mp4 file. It must be something specific to that particular format coming off the camera.
I’m going to flag this as a possible defect and get the team to take a look at it. In the meantime if you have a conversion that works, please let me know.

That’s very clear, thanks. We will test the file.
Right now don’t use h264 or mp4. Use Animation codec or an image sequence such as JPG, png or TIF.

It is straight from a Sony Nex 5: number 2 for mp4
Sony NEX-5 Basic Video Specs

  1. 1080i (1,920 x 1,080), 60i (interlaced) fields/second HD recording (presumably 50i in European versions) in AVCHD format
  2. 1,920 x 1,080 (subsampled at 1,440 x 1,080), 30 fps HD recording in MPEG-4 format
  3. 640 x 480 30 fps standard-definition recording in MPEG-4 format

The NEX5 highest res videos are called MTS.
The Sony video MTS files cannot be read in Mocha.
Therefore…
I put the SonyNex5 MTS video file into AE.
I rendered the MTS video file to a 264 video file.
I opened the 264 rendered video file, into Mocha. Result is just like below. Black screen with lots of little lines in the timeline.
Thus:

  1. It will not open the complete sony nex5 mp4 video files in mocha.
  2. It will not open the rendered files from Adobe After Effects
  3. I opened AE. I put in NO video files. The new project had ONLY one block solid with text added. I rendered to a 264 and saved. I opened the new video clip in Mocha. Same as below. Black with lines on timeline.
    Hope all this helps.
    Look forward to the solution. I know you all can find it. Great program that will be very useful to me.
    Thank you again Martin,
    Tim
    .
    .

1440x1080 29.97

Thank you Martin. The ‘1’ returned it to normal.
I still cannot get the full width though. Maybe I’m sleepy and overlooking a setting. ??
I was able to do one mocha transfer to AE that worked.
Tim
.

Here is a conversion that worked. I need to test to see if dimensions equal AE clip…

  1. ae settings
  2. video in ae
  3. video as showing in mocha
  4. mocha clip information
    thank you again,
    Tim
    .

thank you Martin.
http://hplug.com/video/
Tim
.

Hello Martin,
Very odd indeed.
I upgraded quicktime, my soundcard driver, and the bios.
I also converted to MOV format.
… nothing changed.
I checked with a friend with a good powered desktop. He downloaded the trial version and it is doing the same thing on his.
I have Windows 7 64bit.
Does anyone there have a Windows they can try the clip on?
Thanks,
Tim
.

Hello Martin. That sounds good on flagging. Thank you.
Here is another clue? … I opened the file in AE. I added some color and then rendered it into a v264. See settings.
The video plays fine by itself on a player.
However, when opening the rendered AE mp4, Mocha just shows black and a whole lot of little lines on the time line.
.