New to Mocha AE - layer in and out points

Hi,

It’s been a while since I delved deep into new areas within AE and I have to admit I didn’t want to be rotoscoping for 2 days but someone pulled out on a job so I’m the only one with AE experience but never really rotoscoped anything of significance and a week later… a few days prep and now 2 days flat out… completely frazzled and doing my best but really hitting some stumbling blocks.

TLDR

Shot where someone takes their hand out of their pocket then puts their hand back in their pocket. How do I rotoscope just the part where they have their hands out of pockets? I have tried using ‘layer’ in and out points and it looks good in Mocha AE but when I export masks to AE in doesn’t seem to work and I can see the masks when they are not animated. I don’t seem to be able to delete them… but that may be my brain not thinking right at this stage… I scrolled through to the start of the track and tried deleting prior keyframes but it doesn’t seem to delete them…

Namely…

EXAMPLE…

Clip duration = eg 100 frames.

Shot starts with someone with their hand in their pocket (hand 1).
They take their hand out of their pocket (hand 2)
Put it back into their pocket (hand 3)
Then take it out again (hand 4)

I would have guessed I set in points and out points for each action (taking hand out of pocket) / layer so to speak…

Hand 1 (eg 01 frames to 20frames).
Hand 2 (eg 21 frames to 40 frames).
Hand 3 (ed 41 frames to 60 frames etc)…

So I do a track (hope I’ve got the terminology correct - IE I draw around their hand and hit the track arrows and it tracks it… I scale/tweak it accordingly etc for the bits that don’t track great…) of hand 2 as they pull their hand out of their pocket.

Then they put their hand back in their pocket…

So… I can’t seem to be able to set in and out points for that track/mask/layer…

So I export it to AE and I am left with bits of masks. I’ve been trough the layer masks in AE and tried deleting keyframes that way but it doesn’t seem to work.

I’ve tried setting layer (and not project) in and out points in MOCHA AE. Looks good in Mocha AE but doesn’t seem to work when I export it to AE. I seem to have the full layer.

I really hope this is making sense and I’m probably overcomplicating my question… ultimately I don’t seem to be able to set in and out points for layers that I can then export to AE and keep that data.

I’m going to get some long overdue sleep and hope that maybe there is some info here that will help when I awake… deadline day tomorrow and I’ve not even done the tracking right OH GOSH :wink:

Mocha Version 7.5.0 AE CC2020 V17.1.2 BUILD 37
MacBook Pro, 16GB RAM, SSD etc…

After Effects shapes don’t support the frame-based layer range deactivation that Mocha provides so you do end up with orphaned shapes when importing them from Mocha.

There are two workarounds to this:

  1. Set the opacity of the layer ranges in After Effects manually using hold keyframes:
  2. Use the “Apply matte” option in the Mocha AE plugin parameters to render the matte directly to your layer rather than creating splines. This will respect your layer ranges as it renders the matte:

Either way should turn off your different roto layers.

Thank you for your help Martin. That seems to have done the trick (and is a perfect example of how the brain doesn’t always compute the most simple of things at 4am). Most appreciated and really nice to see an active forum for a plugin so to speak.