New user w. Optics - 2 issues

Just started using the application. I 've come across two issues.

  1. The app doesn’t seem to keep the check mark for EFFECT in the View options menu. Why does it get disabled each time I exit the application?

  2. Sometimes the app appears to hang, i.e., the cursor changes to the wristwatch, and then all of the preview thumbnails disappear completely. I have to exit the app and restart – whether it was accessed as a plugin from Photoshop or directly. What causes the filter preview thumbnails to disappear?

Here’s my system info:

OS:

System Software Overview:

System Version: macOS 11.6 (20G165)
Kernel Version: Darwin 20.6.0
Boot Volume: Macintosh HD
Boot Mode: Normal
Secure Virtual Memory: Enabled
System Integrity Protection: Enabled

HARDWARE:

Model Name: iMac
Model Identifier: iMac19,2
Processor Name: 6-Core Intel Core i5
Processor Speed: 3 GHz
Number of Processors: 1
Total Number of Cores: 6
L2 Cache (per Core): 256 KB
L3 Cache: 9 MB
Memory: 16 GB
System Firmware Version: 1554.140.20.0.0
SMC Version (system): 2.47f3

What is the make and model of the graphics card you are using?

Hi and thanks for your reply. Here’s the graphics card info:

Radeon Pro 560X:

Chipset Model: Radeon Pro 560X
Type: GPU
Bus: PCIe
PCIe Lane Width: x8
VRAM (Total): 4 GB
Vendor: AMD (0x1002)
Device ID: 0x67ef
Revision ID: 0x00c2
ROM Revision: 113-C981AA-042
VBIOS Version: 113-C9819A1X-009
EFI Driver Version: 01.B1.042
Metal Family: Supported, Metal GPUFamily macOS 2

Please do the following:

  • Apply Optics.
  • Select the Optics > Preferences menu.
  • Change GPU Rendering from Enabled to Disabled.
  • Close Optics and then reapply it.

Does this solve the problem?

Thanks, Marco. I have made the change. So far seems ok. But will continue to test with some additional files.