No HUD in After Effects 2020

I am using the demo software version 13.0.2 to evaluate. In Primatte studio I do not get a HUD. Also get no HUD in any filter. With Primatte studio this keeps me from manually selecting a key color.

thanks…

Hi Tcliffe,
I’m not sure about in other apps, but if you’re in AE, at the top of the plugin is a HUD button that toggles it on and off.
Shane

As Shane mentioned, make sure the H.U.D. Preference button is enabled (blue) in the Continuum control panel at the top of the effect. Also make sure that the effect name itself is selected/highlighted in AE. See the attached screenshot.
HUDinAE

That applies to all Continuum filters. In the case of Primatte Studio specifically you might also want to hit the Reset Toolbar button at the very bottom of the effect controls in case the Primatte Studio toolbar is off the edge of the screen.

Thanks for the replys. The HUD button is blue. Have tried clicking it. Also the FX is highlighted.

Thanks

I have done additional testing. It appears that the HUD will appear in my other saved projects. It will not appear in the one I want to test BCC on. I have clicked the HUD button and highlighted the effect title. I have also clicked the toolbar reset.

Any idea where it could be hiding?

thanks

If you are using After Effects, is it possible that you are viewing a layer and not the comp?

It may be unrelated to OP’s issue, but I have found an issue with AE 2021/Big Sur/4KMXF’s and the HUD on my iMacPro - it disappears randomly and often and won’t come back - problem resolved by transcoding frontage to ProRes.

Coming in on this in Feb. 2022. Only been using Primatte Studio for a month & LOVE it! Started to get anxious when my H.U.D. started playing hide-and-go-seek. I toggled every switch on the UI but no joy. Restarted AE, tried new layers, comps - nothing. Then I noticed I had switched the button for “Toggle Mask and Shape Path Visibility” to off when I normally always have it on. I clicked it and the H.U.D. popped right up. I don’t know if this is a 100% solution or not. Boris, is this expected behavior? Anyway, I hope if anybody else has this problem in the future my input will be helpful.

Well that’s very odd and totally unexpected behavior. Thanks for letting us know - we’ll try to repro this in our labs. Can you tell me what platform you’re seeing this on please?

Windows 10 PC
After Effects v. 18.4
Latest release of Primatte Studio

Thanks for checking into it. My heart dropped bc I couldn’t select point or rectangle to clean the FG or BG. I tried but I’m figuring there isn’t any way to activate the selection tools when the HUD isn’t active, correct? If we could do that from the Effects Control panel then the missing HUD would just be an inconvenience instead of a show-stopper.

  • DK

I used to be a software and systems engineer, so I know how hard it can be to troubleshoot a problem that is not 100% reproducible. To help, I made a very short video of me demonstrating the problem. It seems to be tied in with both mask visibility and layer controls visibility. Toggling them on and off are the only actions I’m taking during the video and you can see the HUD disappear and re-appear on the right of my composition window. I hope this helps.

https://drive.google.com/file/d/1s4vN4MTCT0A9xBLU7SNXfDZPjVc3RB2L/view?usp=sharing

Thanks,

  • DK

Hi DK,

Thank you so much for the video - as they say, a picture is worth a thousand words and this little video explained the process of reproducing what you’re seeing. I’m seeing the same thing on my system so thanks again for that.

I’ll bring this up with engineering to get their take on it but it may be a fact of life given that AE disables all on-screen widgets (such as this toolbar widget) when that show layer controls switch is toggled.

That the view menu shows the problem while the button at the bottom of the comp window does not is most likely an Adobe side issue.

Cheers,
Peter.

Hey Peter,

Just checking in on this issue to see if engineering had any additional insight to offer on this. I’ve been running into this situation quite a bit when I want to clean my BGs but the mask outline is partially obscuring the area I’m working.

Thanks,

  • DK

Hey DK,

So this is indeed a bug that only Adobe can address - it has absolutely nothing at all to do with our software and can be seen when working with other 3rd party filter effects.

A workaround would be to disable the on-screen controls via the AE setting, then use the tools that are available in the filter control panel to switch between foreground, background etc.

Cheers,
Peter.

1 Like