Not Responding Importing file causes Moca AE CS5 to crash


#1

I have a similar problem when importing mp4 files from XDCAM EX cam.
Can’t fin if there’s a compatibility issue, but mocha crashes the “mediaioserver.exe”. This happens when importing HDV mpeg files created with a Z1 camera.
No error report, nothing. Just a crash of the server.
Any thoughts?
By the way, my system is a CS5, with Mocha AE 2.2.0, running on a
Windows 7 x64 Ultimate
AMD Phenom II x4 965 3.41 GHZ
8 MB RAM
Any info will be appreciated


#2

Hi wnowosad,

Can you upload one of the problem files and email me so we can take a look at the issue?

martinb[at]imagineersystems{dot}com.


#3

Hi wnowosad,
Can you upload one of the problem files and email me so we can take a look at the issue?
martinb[at]imagineersystems{dot}com.


#4

Hi Guys,
A lot of times this sort of problem can be handled by converting your .mp4s to a different file type, like an image sequence or an uncompressed quicktime. A lot of cameras have custom codecs that mocha might not interact favorably with.
A good test is run a JPEG compressed quicktime through mocha, if you don’t get the same issues, it’s a codec problem, try a different format. If you’re still getting problems, it’s likely a bug and you can submit that to our team here: http://www.imagineersystems.com/contact_form
It really helps if you supply the exact error code and the mocha log from mocha>help>view log and if you can supply info on your OS and software versions in the report. As well as steps you had to take to reach that error.
Cheers,
Mary


#5

Also, it never hurts to not only make sure your quicktime is up to date, but that your video card drivers are as well!
:slight_smile:
Cheers,
Mary


#6

Dear Mary, thanks for the advice. I’ll give it a try with the jpeg qt and see what happens.
The thing is, I don’t get an error, it just crashes the mediaioserver.exe and kills Mocha along with it. I’ll see what happens now.
Thanks for the quick response :slight_smile:


#7

Version 2.2.0 CS5 build 2626
Build Date: Mar 23 2010

This is my first attempt at using Mocha for AE.
Every attempt at importing MP4 files immediately results in Mocha “not responding”. I have tried importing several different MP4 files and each attempt has ended with the same results.

Please help.

About my system:
Windows 7 Ultimate - 64-bit
Quicktime Player version 7.6.6
Adobe SC5 Master Collection
Dual Intel Xeon 6-core 3.33 GHz microprocessors
98 GB RAM
10 TB of disk space (SATA3)
PNY NVIDIA 4800

About the clips:
Created using Sony PMW-EX3
1080p - failed to import
720p - also failed to import

Created from old single-chip camera:
AVI file captured from tape - imported successfully.

So, the software seems to work. Why is there an issue with MP4 files?
Must I convert my MP4 files to AVI before I can import?
That doesn’t seem to make sense, since the CHOOSE A FILE window allows for many different movie and file types, including the MP4 file format.

I tried moving MP4 files closer to the root; and got the same result…Mocho goes “not responding”.

I compared the file sizes of the MP4 to the AVI.
The AVI file was 2 GB in size and opened without error or delay.
The MP4 files ranged in size from 276 - 181 MB.

Must I transcode the files into another file format first?
I hope not. I’m hoping there’s an easier solution.

Thank you.


#8

Version 2.2.0 CS5 build 2626
Build Date: Mar 23 2010
This is my first attempt at using Mocha for AE.
Every attempt at importing MP4 files immediately results in Mocha “not responding”. I have tried importing several different MP4 files and each attempt has ended with the same results.
Please help.
About my system:
Windows 7 Ultimate - 64-bit
Quicktime Player version 7.6.6
Adobe SC5 Master Collection
Dual Intel Xeon 6-core 3.33 GHz microprocessors
98 GB RAM
10 TB of disk space (SATA3)
PNY NVIDIA 4800
About the clips:
Created using Sony PMW-EX3
1080p - failed to import
720p - also failed to import
Created from old single-chip camera:
AVI file captured from tape - imported successfully.
So, the software seems to work. Why is there an issue with MP4 files?
Must I convert my MP4 files to AVI before I can import?
That doesn’t seem to make sense, since the CHOOSE A FILE window allows for many different movie and file types, including the MP4 file format.
I tried moving MP4 files closer to the root; and got the same result…Mocho goes “not responding”.
I compared the file sizes of the MP4 to the AVI.
The AVI file was 2 GB in size and opened without error or delay.
The MP4 files ranged in size from 276 - 181 MB.
Must I transcode the files into another file format first?
I hope not. I’m hoping there’s an easier solution.
Thank you.


#9

MOCHA IMAGE STABILIZATION WORKFLOW FOR MP4 FILES

*** SUMMARY OF STEPS ***

  • CREATE AN IMAGE SEQUENCE FROM THE MP4 FILE
  • CREATE TRACKING DATA USING THE IMAGE SEQUENCE
  • EXPORT TRACKING DATA FROM IMAGE SEQUENCE ONTO THE MP4 FILE

*** DETAILED STEPS AND MY PERSONAL NOTES ***

CREATE IMAGE SEQUENCE:
In Premiere Pro CS5, select your footage
Under the FILE menu item, select EXPORT…
Under EXPORT SETTINGS section, select TARGA from the FORMAT box.
Click the Output tab to make sure your settings look the way you want. If you adjust the PRESET box, the output may change. In my case, I saw black bars appear. Since I didn’t want any black bars around my footage, I went back to the default settings by reselecting the TARGA format from the FORMAT box. After playing around with the various settings, I found that the default settings worked fine. In the case of my footage, the preset 'FULL HD TARGA 720p appears in the PRESET box.

OUTPUT NAME: Select a path\file name by clicking on the OUTPUT NAME file listed, or accept the default. I suggest creating a separate folder AND selecting a good descriptive name for the sequence for a couple of reasons: 1) This process will create an entire series of individual files for your footage; and 2) Since you may need to repeat this process more than one, you’ll want an easy way to locate the image sequence of files.
Ensure the EXPORT VIDEO check box is applied.
FILTERS TAB: no changes
VIDEO TAB
BASIC SETTINGS: Ensure the WIDTH and HEIGHT matches your source footage.
EXPORT AS SEQUENCE: Apply the check box to enable this setting; otherwise, you’ll only get one frame when you export.
FRAME RATE, FIELD TYPE, ASPECT:
I accepted the defaults for all the other settings. At first, thought I’d have to change the ASPECT to a value of 1.2121 for my 16:9 720P/24 footage; however, the default SQUARE PIXELS (1.0) worked just fine.
FRAME RATE: Ensure that this setting matches your footage settings. I had to change this from the default 25 to 23.976. Obviously, you’ll set this to match your footage.
FIELD TYPE: The Default PROGRESSIVE was appropriate for mine.
ASPECT: Square Pixels (1.0) worked for my 720P/24. Whatever you choose, ensure that OUTPUT tab display looks the same as the INPUT tab’s display. If your input footage doesn’t have black bars, and you choose a setting that adds the bars, let me know how that works for you; because, I’m operating on the assumption that since we’re matching tracking data from a sequence of images and applying it to video footage of an MP4 file, we need the input and output to look the same; otherwise, the tracking data won’t work.
RENDER AT MAXIMUM DEPTH: I didn’t care about this, since my primary need for this sequence of files was to create TRACKING DATA on a file of comparable size, format, and aspects which could be applied to my MP4 file.
USE MAXIMUM RENDER QUALITY: I did have this checked; but, I don’t think it would have made any difference.

Finally, I chose to Export immediately by clicking the EXPORT button, rather than to use the QUEUE.

CREATE TRACKING DATA:
Except for a modification of which file to select, this process was pretty much derived from the tutorial
"mocha - Image Stabilization"
which can be found at:
http://www.imagineersystems.com/support/mocha/tutorials/

Open Mocha
Click the CREATE A NEW PROJECT button, or from the FILE menu item, choose NEW PROJECT…
Navigate to the folder you created above and load the image sequence by selecting the first file of the TARGA sequence, which should be your file name followed by three zeros.

If your image sequence files are stored on a network drive share, this step will allow more responsive play back. If your file is stored on a local drive, skip to FRAME PROPERTIES, below:
Under the PROJECT section of the NEW PROJECT window, click the ADVANCED button and under the CACHING section, apply the CACHE CLIP option; and then return to the OPTIONS tab.

FRAME PROPERTIES
FRAME RATE: the frame rate of your Mocha project must match the frame rate of your source footage or image sequence. Since I shot in 720p/24fps on the Sony PMW-EX3, the frame rate is NOT 24 (which Mocha defaults to); it is 23.976. If you’re not sure of the frame rate, check in Premiere pro by selecting your footage and viewing the metafile tab; or, by selecting the source file in your project window. You may have to scroll to the right, or resize the panel (pallet, or whatever we’re calling it these days) to see the FRAME RATE column.
PIXEL ASPECT RATIO: I chose HD
Click OK
If you did everything right, your footage should appear.

Create a large shape using the x-spline tool (see video for more information)
After you’ve created your shape, look at the TRACK tab (selected by default), under the MOTION section (column) and remove x marks from SHEER, ROTATION, and SCALE; because, we only want to track x and y positions.
To track, simply hit the TRACK FORWARD (or BACKWARD) button.

On the right side of the MOCHA interface, you can activate SURFACE and GRID.
These tools can be used as a reference to make sure your spline is locked-on the plane. Scrub back and forth to inspect. (See Video for example)

EXPORT TRACKING DATA:
>From the TRACK tab (lower section of interface), click the EXPORT TRACKING DATA button
Select AFTER EFFECTS TRANSFORM DATA [anchor point, position, scale, and rotation] (.txt) - or whatever other product that’s appropriate for your software. Since I’m using After Effects, I chose AFTER EFFECTS TRANSFORM DATA [anchor point, position, scale, and rotation] (.txt)
Click SAVE to save the file

STABILIZE MP4 FILE FOOTAGE:
Open the AFTER EFFECTS TRANSFORM DATA.TXT file created above; select all (CTRL+A) and copy (CTRL+C)
Open After Effects and create a new comp for the original MP4 file footage - NOT the TARGA sequence you created to capture the Tracking data. I imported using File | Adobe Dynamic Link… | Import PremierePro Sequence…
Add the footage to your timeline
Select the source footage; and click the EDIT menu item and select PASTE
Twirl open the TRANSFORM properties of the composition and delete the POSITION, SCALE, and ROTATION key frames by clicking the stop-watch buttons of each. By default, ANCHOR POINT is selected with the other three; so, if you happen to click on the Stop-watch before deselecting ANCHOR point, you’ll wind up deleting all key frames. In this event, press CTRL+Z to undo and try again.

Ensure the duration of the comp matches the duration of
>From the COMPOSITION menu item, select MAKE MOVIE…
The Render queue tab appears
RENDER SETTINGS: Best
OUTPUT TO: choose a path and file name
Click the Render button
Import completed AVI file with your newly steadied footage into your Premiere Pro Project.

I had three layers in one long pan, which resulted in two errors:

  1. CRITICAL STOP message: Tracking Terminated prematurely
  2. WARNING message: One or more selections were not tracked properly. Try increasing the minimum percentage of pixels used.

On the TRACK tab which appears in the lower part of the MOCHA interface, I increased the MIN % PIXELS from it’s default value of 90 to 100 and tried again. Since I was working with a long panning shot through thick atmosphere, I noticed that the first mask, as it moved off the edge of the screen, started rocking erratically up and down before the error messages appeared. The Erratic rocking (rotation) motion increased as fewer and fewer tracking points of the spline/shape remained on the screen. I suspect that for MOCHA to successfully track a spline as it pans off screen, there may need to be more than just a few points on the extreme edge of the spline. I tested this by removing the last two splines and by increasing the number of points on the remaining spline. The same errors appeared. I retested by increasing the size of the one and only spline - same errors appeared. With the MIN % PIXELS set at 100, I tried creating multiple splines on the long pan. The same t!
wo error messages appeared. Since I really didn’t need the entire shot, I went back to PremierePro and cut it down to the size I needed. Since the spline didn’t leave the frame, the track completed successfully; but, I was not satisfied with the results, which I attribute to my sloppiness in spline creation. By this time, I’d spent 4 hours playing with the footage - was hungry, kinda burned out. While I’m certain I’m missing some key technique that will make this software work on this situation; and while I know I figure it out in a day or two, I have made a new resolution. If I ever need a long panning shot, I’ve resolved to do it on a clear day windless day from the stable platform of my Vinton fluid head and tripod.

Peace


#10

MOCHA IMAGE STABILIZATION WORKFLOW FOR MP4 FILES
*** SUMMARY OF STEPS ***

  • CREATE AN IMAGE SEQUENCE FROM THE MP4 FILE
  • CREATE TRACKING DATA USING THE IMAGE SEQUENCE
  • EXPORT TRACKING DATA FROM IMAGE SEQUENCE ONTO THE MP4 FILE
    *** DETAILED STEPS AND MY PERSONAL NOTES ***
    CREATE IMAGE SEQUENCE:
    In Premiere Pro CS5, select your footage
    Under the FILE menu item, select EXPORT…
    Under EXPORT SETTINGS section, select TARGA from the FORMAT box.
    Click the Output tab to make sure your settings look the way you want. If you adjust the PRESET box, the output may change. In my case, I saw black bars appear. Since I didn’t want any black bars around my footage, I went back to the default settings by reselecting the TARGA format from the FORMAT box. After playing around with the various settings, I found that the default settings worked fine. In the case of my footage, the preset 'FULL HD TARGA 720p appears in the PRESET box.

OUTPUT NAME: Select a path\file name by clicking on the OUTPUT NAME file listed, or accept the default. I suggest creating a separate folder AND selecting a good descriptive name for the sequence for a couple of reasons: 1) This process will create an entire series of individual files for your footage; and 2) Since you may need to repeat this process more than one, you’ll want an easy way to locate the image sequence of files.
Ensure the EXPORT VIDEO check box is applied.
FILTERS TAB: no changes
VIDEO TAB
BASIC SETTINGS: Ensure the WIDTH and HEIGHT matches your source footage.
EXPORT AS SEQUENCE: Apply the check box to enable this setting; otherwise, you’ll only get one frame when you export.
FRAME RATE, FIELD TYPE, ASPECT:
I accepted the defaults for all the other settings. At first, thought I’d have to change the ASPECT to a value of 1.2121 for my 16:9 720P/24 footage; however, the default SQUARE PIXELS (1.0) worked just fine.
FRAME RATE: Ensure that this setting matches your footage settings. I had to change this from the default 25 to 23.976. Obviously, you’ll set this to match your footage.
FIELD TYPE: The Default PROGRESSIVE was appropriate for mine.
ASPECT: Square Pixels (1.0) worked for my 720P/24. Whatever you choose, ensure that OUTPUT tab display looks the same as the INPUT tab?s display. If your input footage doesn’t have black bars, and you choose a setting that adds the bars, let me know how that works for you; because, I’m operating on the assumption that since we?re matching tracking data from a sequence of images and applying it to video footage of an MP4 file, we need the input and output to look the same; otherwise, the tracking data won?t work.
RENDER AT MAXIMUM DEPTH: I didn’t care about this, since my primary need for this sequence of files was to create TRACKING DATA on a file of comparable size, format, and aspects which could be applied to my MP4 file.
USE MAXIMUM RENDER QUALITY: I did have this checked; but, I don?t think it would have made any difference.
Finally, I chose to Export immediately by clicking the EXPORT button, rather than to use the QUEUE.
CREATE TRACKING DATA:
Except for a modification of which file to select, this process was pretty much derived from the tutorial
"mocha - Image Stabilization"
which can be found at:
http://www.imagineersystems.com/support/mocha/tutorials/
Open Mocha
Click the CREATE A NEW PROJECT button, or from the FILE menu item, choose NEW PROJECT…
Navigate to the folder you created above and load the image sequence by selecting the first file of the TARGA sequence, which should be your file name followed by three zeros.
If your image sequence files are stored on a network drive share, this step will allow more responsive play back. If your file is stored on a local drive, skip to FRAME PROPERTIES, below:
Under the PROJECT section of the NEW PROJECT window, click the ADVANCED button and under the CACHING section, apply the CACHE CLIP option; and then return to the OPTIONS tab.
FRAME PROPERTIES
FRAME RATE: the frame rate of your Mocha project must match the frame rate of your source footage or image sequence. Since I shot in 720p/24fps on the Sony PMW-EX3, the frame rate is NOT 24 (which Mocha defaults to); it is 23.976. If you’re not sure of the frame rate, check in Premiere pro by selecting your footage and viewing the metafile tab; or, by selecting the source file in your project window. You may have to scroll to the right, or resize the panel (pallet, or whatever we’re calling it these days) to see the FRAME RATE column.
PIXEL ASPECT RATIO: I chose HD
Click OK
If you did everything right, your footage should appear.
Create a large shape using the x-spline tool (see video for more information)
After you’ve created your shape, look at the TRACK tab (selected by default), under the MOTION section (column) and remove x marks from SHEER, ROTATION, and SCALE; because, we only want to track x and y positions.
To track, simply hit the TRACK FORWARD (or BACKWARD) button.
On the right side of the MOCHA interface, you can activate SURFACE and GRID.
These tools can be used as a reference to make sure your spline is locked-on the plane. Scrub back and forth to inspect. (See Video for example)
EXPORT TRACKING DATA:
>From the TRACK tab (lower section of interface), click the EXPORT TRACKING DATA button
Select AFTER EFFECTS TRANSFORM DATA [anchor point, position, scale, and rotation] (.txt) - or whatever other product that’s appropriate for your software. Since I’m using After Effects, I chose AFTER EFFECTS TRANSFORM DATA [anchor point, position, scale, and rotation] (.txt)
Click SAVE to save the file
STABILIZE MP4 FILE FOOTAGE:
Open the AFTER EFFECTS TRANSFORM DATA.TXT file created above; select all (CTRL+A) and copy (CTRL+C)
Open After Effects and create a new comp for the original MP4 file footage - NOT the TARGA sequence you created to capture the Tracking data. I imported using File | Adobe Dynamic Link… | Import PremierePro Sequence…
Add the footage to your timeline
Select the source footage; and click the EDIT menu item and select PASTE
Twirl open the TRANSFORM properties of the composition and delete the POSITION, SCALE, and ROTATION key frames by clicking the stop-watch buttons of each. By default, ANCHOR POINT is selected with the other three; so, if you happen to click on the Stop-watch before deselecting ANCHOR point, you’ll wind up deleting all key frames. In this event, press CTRL+Z to undo and try again.
Ensure the duration of the comp matches the duration of
>From the COMPOSITION menu item, select MAKE MOVIE…
The Render queue tab appears
RENDER SETTINGS: Best
OUTPUT TO: choose a path and file name
Click the Render button
Import completed AVI file with your newly steadied footage into your Premiere Pro Project.
I had three layers in one long pan, which resulted in two errors:

  1. CRITICAL STOP message: Tracking Terminated prematurely
  2. WARNING message: One or more selections were not tracked properly. Try increasing the minimum percentage of pixels used.
    On the TRACK tab which appears in the lower part of the MOCHA interface, I increased the MIN % PIXELS from it’s default value of 90 to 100 and tried again. Since I was working with a long panning shot through thick atmosphere, I noticed that the first mask, as it moved off the edge of the screen, started rocking erratically up and down before the error messages appeared. The Erratic rocking (rotation) motion increased as fewer and fewer tracking points of the spline/shape remained on the screen. I suspect that for MOCHA to successfully track a spline as it pans off screen, there may need to be more than just a few points on the extreme edge of the spline. I tested this by removing the last two splines and by increasing the number of points on the remaining spline. The same errors appeared. I retested by increasing the size of the one and only spline - same errors appeared. With the MIN % PIXELS set at 100, I tried creating multiple splines on the long pan. The same t!
    wo error messages appeared. Since I really didn’t need the entire shot, I went back to PremierePro and cut it down to the size I needed. Since the spline didn’t leave the frame, the track completed successfully; but, I was not satisfied with the results, which I attribute to my sloppiness in spline creation. By this time, I’d spent 4 hours playing with the footage - was hungry, kinda burned out. While I’m certain I’m missing some key technique that will make this software work on this situation; and while I know I figure it out in a day or two, I have made a new resolution. If I ever need a long panning shot, I’ve resolved to do it on a clear day windless day from the stable platform of my Vinton fluid head and tripod.
    Peace