Nothing happends when changing settings in mesh tracking

Mesh tracking seems like a wonderful feature, however, it’s currently unusable for me.
I can draw a spline and change the settings for mesh-tracking, however, once I enable it, the generated mesh, and the settings for it gets locked.
I’ve tried clicking clear mesh and generate mesh, but nothing happens. Even when I delete the spline and create a new one, the old mesh comes back.
The only thing that works is, create a new mocha pro node (in nuke).

Another issue that I have (although this is probably more of a feature request) is the only thing you get out is the area that you tracked. It’s quite rare that you only need to affect only the tracked area.
You really need to add a feature that expands the mesh outside the tracked area.
Hopefully, that feature already exist, and I just haven’t found it.
The first version of smartvectors had the same problem, thankfully, the foundry fixed that in later versions.

I use the latest version of mocha pro, ofx in nuke 12.1v2

  1. That is super weird and I need a screenshot because I can’t repeat the mesh not going away.

  2. Create a larger shape, generate your mesh, and then bring the shape in to a smaller area before you track. This way you have total control over both where the mesh generates and where it looks for tracking. Can you try that and let me know if it works for you?

Cheers,
Mary

Thanks for your reply!

I’m attatching a screen recording.
So, the problem is a bit different then I first thought. It seems like it’s actually generating a new mesh, but it’s always displaying the old one.

https://drive.google.com/file/d/1dp2ZM1Sj8P69vZuj4VSroFRJL0TaOltf/view

You have to turn on the Mesh track to get the Mesh to generate properly, so do that and it should regen, but that is definitely a caching bug we should fix. @martinb Check this out.

I think you didn’t watch through the entire video.
Yes, I forgot to click mesh when I did my second spline. But not on my third. Also, notice how nothing changes when I edit the settings and click “generate mesh”

Edit: Also, I’m not sure it’s a caching bug. Because I can clear the cache and restart mocha and it will still produce the same mesh as before.

Yeah, I think we definitely need to try to reproduce this. The dev team might already be aware, I will check in with them and see.

That is definitely weird.
It looks like your mesh cache isn’t updating.

What system are you using? Can you also please attach your Mocha log from the help menu?

System:
AMD Ryzen 7 3800X
RTX 2080 Ti
64gb ram
running Gnome in Linux release 7.7.1908 (Core).

Could I email the log to you? Not sure if there is sensitive info in it.

Sure, please email martinb at borisfx.com