Nuke & OFX Mocha Plugin - dumb question!

Maybe I’m just tired but …

I’m feeding a bg into OFX Mocha from Nuke adding a shuffle node to force it too RGBA where the alpha is black.

Coming back out of the plugin after doing some roto I was expecting Mocha just to render the Alpha over the black input and leave the RGB intact so I could just use it downstream …

I can’t seem to find a way to get the alpha out without premulting the RGB which would not be my preference - am I just missing something ?

Thx

Andrew Mumford

Hi Andrew,

Just use apply matte from the mocha plugin, you shouldn’t need to use a shuffle node at all.

Cheers,
Mary

 

Thank you - that works it seems that applying the shuffle node makes the matte from mocha go away when it really shouldn’t affect it at all !

There are plenty of time I might want to force a black or white alpha prior to processing in a plugin - I think Mocha should respect what is passed to it and combine over the top.

Still what you said works for now, thanks again.

I will pass that feedback on to the dev team, thank you! :slight_smile:

Hi Andrew,

You can see the correct alpha in the mocha GUI by pressing and holding the “A” icon (i.e. Alpha) in the view controls and choosing “Source Alpha”.
You can view the correct alpha out again by choosing the premultiply option in the plugin interface.

If this is not what you require, can you provide some screen shots of what it is you’re looking for?

It’s happening back in Nuke when you try to pass the Mocha matte back into the stream.

With Mocha OFX as the first node after an RGB only source it passes the alpha back as expected.

If I have something else going on in the Alpha channel prior to the plugin it seems to “block” the Mocha Alpha from being passed back.

In the example I was using I forced the Alpha to black using a shuffle node just prior to Mocha OFX and was unable to see / use the Mocha Alpha.

I would have expected Mocha to “comp” it’s own matte straight over the top of any pre-existing pixels as would be Nuke standard behaviour.

DOes that make sense ?

Thx

Andrew Mumford

Does the premultiply setting in the plugin not work as expected? This is what it is for. Perhaps we haven’t covered all scenarios. I’ll check with the development team.