NVIDIA Driver Problems - GPU Missing in Mocha Pro - Now Fixed in Mocha Pro 6.0.1

We have noticed a problem with recent NVIDIA driver versions, which causes the GPU to stop working in Mocha for tracking and remove.

The problem started with GeForce driver version 416.81 and Quadro driver version 416.78, on Windows 10. With these or newer drivers, the NVIDIA GPU will not appear in the list of available GPUs in Mocha preferences, so tracking and remove will use the CPU or a different, non-NVIDIA GPU if the system has one.

We are in contact with NVIDIA about the problem and will post an update when we have any news on a fix from either our or their side. In the meantime, please do not update your drivers beyond the following versions:

GeForce/TITAN: 416.34
Quadro: 411.95

If you have already upgraded, previous driver versions are available from the NVIDIA Advanced Driver Search page.


Yey. Thank you for the new update. GPU Processing is now working for GeForce ver. 417.22

Note for users experiencing this issue.

We have now released maintenance release Mocha Pro 2019 v6.0.1. You can download this here, or get it from the software update when prompted:

What about Mocha AE?
Even with the newest update from Adobe Cloud my Titan X is still not recognized with the most recent drivers installed.

Do you have unsupported cards also checked in preferences? Does it appear then?

Hi Martin,

I have the same problem with Titan X, and “unsupported cards” can’t be checked as you can see in this screen : GPU-Mocha — ImgBB

It would be unfair to have to pay a new version for a problem of incompatibility when it is supposed to be supported …

I upgrated to Mocha 2019.5. NVidea-driver is 416.34, host application Avid Mediacomposer 2018.12.3.
GForce 1060. The card is supported. Still no GPU support.

That’s quite an old driver, did you try updating to the most recent one?
Is this on Mac or Windows?

Its a Windows PC. Normally the driver update is part of the Media Composer Update. Yesterday I observed that sometimes GPU support is running sometimes not. I have no idea what is the reason.

Getting the same “GPU processing is not supported” message. Currently running a trial of 2020.5. Using a Quadro T2000 in an HP Zbook G6. Nvidia driver is 443.18.
I’m using the AVX plugin for Media Composer 2018.12.11 on Windows 10 Pro. Surely this card is supported? Is there still an issue with Nvidia drivers? Is there a recommended driver version to be running?

I do not see your card on the supported GPU list: Boris FX | Supported Graphics Cards

So that may be a valid error message. Let me confirm with @martinb in case there have been updates I am unaware of.

Hi Andi,

Although we haven’t tested and certified the T2000, I’d expect it to work. Can you please post your imagineer.log from Help | View Log… in Mocha?

Best regards,


imagineer_log.txt (71.1 KB)

Hi, here’s the log. The T2000 is just the updated version of the P2000 which is certified.



Sorry I was looking at the wrong list. P2000 is not supported for Mocha, just Continuum. But these are the cards that a lot of the newer HP workstation laptops ship with.

I have a suspicion this is caused by a bug in Mocha that we have already fixed internally. I’m going to DM you a link to a build which I think will work, can you please try it and let us know?

1 Like

Thanks J-P I will try this now and let you know.


Closing the loop on this, Andi tried the new build which fixed the problem. This fix will be released in the near future.


Oh, it must have been the same thing that got me a while back on GPU switching, thanks for making the connection, JP, and sending the build to them.