Obey alpha not working for OFX version

Hi,

So I was trying to use obey alpha options to reveal some input in my paint out in the OFX version of Silhouette and Unfortunately I am unable to do so.

The alpha is not showing up exactly like Roto mattes. I can see the shapes using the check box(show_shapes) but not the mattes.
Is there anything I should keep in mind before using this option?

In the Paint node, press the A key to view the alpha? Is it what you expect?

Make sure that the Source Alpha is set to Clear Alpha before opening Silhouette.
image

It is possible that if you have Preserve Alpha selected that the original alpha is interfering.

ok! I checked this option and its still the same as you told, I am facing this issue inside silhouette, I want to paint certain area using the alpha from the roto but it’s not happening whether I turn on the obey alpha or not

I am attaching the file here, Let me know if I am doing anything wrong or is it a bug?


In the nuke script, there is a silhouette paint node which is creating this issue

Can you send a screen shot of the Silhouette interface so I can see how the settings in your Paint tab is configured?

Here we go!

01.PNG|690x357

Set your Alpha Source to Foreground. This setting obeys the alpha from the Foreground input or the Roto node’s shapes.

Yeah it worked!
Then also if I checked alpha, its not showing the alpha from Roto, Weird!!

Thanks Marco for guiding me!

To see the roto alpha in the Paint node, you need to press the A keyboard shortcut.

Sorry, it’s not showing that way here.
though alpha visibility is wrong, when I paint and the alpha exits same as the roto alpha

I loaded your project and when I deleted the existing paint strokes, the alpha displayed as expected from the Roto node. At some point during your painting, you must have enabled the A (Alpha) channel in the Paint tab. This is the only explanation for the altered alpha channel in your screen shots.

1 Like

When I paint with obey alpha, Silhouette only paints one frame in auto paint. But if I paint with obey alpha off, auto paint works again. Any ideas?

Is the alpha you are obeying present on all frames?

I’m using obey alpha to mask out an area I don’t want to paint out. I have an inverse roto track layer of that area. Not sure why it would only have 1 frame of alpha if I’ve tracked the layer all the way through the clip? How can I tell if all frames have the alpha?

You can display alpha by pressing the A key.

It’s possible that you animated the opacity of the shape or layer by mistake. If you send me a download link to your project, I will take a look. That would be the only way to know for sure.

I’ll check my opacity on the animated layer. Thanks.