Object not sticking to subject

I am very new to Mocha and Im sure Im doing something wrong but for the life of me I can not figure it out. I take a video into AE and launch Mocha Pro. I draw a mesh in and track it. I then go back to 1st frame, click on stabilize, click mess warp and detail high, then I click show planner surface and click on expand surface frame button. Then I save a close Mocha. Back in AE I import my logo and place it where I want it. Then I precompose my logo. Then I copy the Mocha data from the video and paste it onto my logo. Then I click on Module Renders, click the Render box, Module to Stabilize Warp. Then I play the video and the logo does track at all nor does it warp to the scene. What am I doing wrong wrong? What step am I missing? Any and all help would be greatly appreciated.

1 Like

I’m having the exact same issue. I’ve completed the exact same steps mentioned by the original poster and am unable to get that pre-composed layer to track along with my original footage as well.
Somehow it worked the first time I tried it a few days ago, but since that first time I have been unable to get it to work again.

Are you following the videos? I am trying to picture where this is going wrong. Are you sure you don’t have the layer soloed or the timeline just hasn’t rendered it yet?

When you precompose, are you moving ALL of the attributes into the new composition?

Yes I am precomposing and moving all of the attributes into the new composition. When I play the video the person move in frame but the object I playing on her stays in the same place and never moves.

Hey @maryp, I’m not sure if the original poster is having the exact same issue as I was.
I followed along with your Power Mesh video tutorial step by step with a variety of video clips and PNGs and got it to work a total of three times seemingly at random. Since I was following the directions the same every time, I couldn’t pinpoint what the incorrect variable was.

Then I stumbled across your response to this post:


where you suggested that a trimmed clip might be causing the tracking data to paste off the timeline. So I rendered my trimmed clip and then tried again with that new shorter clip.
It worked perfectly and I have since tested it successfully on multiple clips.

It’s odd because you mentioned it being a possible bug in versions prior to 8.0.1, but I’m using 8.0.2 and seemed to still run into that issue.

I’m happy to have it working now and wonder if maybe OP is running into that same issue?

Maybe so! But if it’s precomposed with the all attributes in the new comp that should fix the issue. It does sound like something is off. I might have to remote in next week and see if I can figure out the problem. Can we schedule something for Monday? You can email me at maryp at borisfx.com.

Hi!

i am new with Mocha as well. I installed the TRAIL to see if Mocha Pro 8.0.2 is doing what i am hoping for but i´ve got the same issue as everyone else here in this topic. Has anybody find a solution for that? I´m using Windows 10 AE plug in and follow the videos. Same outcome as the other guys already mentioned.

Hi Marcel,

I believe these issues were fixed with pre-comping and moving all the attributes into the new comp, as well as making sure the timeline in the comp starts at the first frame. You have to make sure the checkbox in the precomp is checked for the timeline to line up when you set that up. Otherwise, there will be an offset at the beginning of the comp that causes problems.

If that doesn’t solve the issue, please let me know and be very specific about the workflow you are using so I can help you troubleshoot.

Cheers,
Mary

Hi Mary!

probably i am to stupid or something. I am following this video ( https://www.youtube.com/watch?v=L2KX-82ityA&t=288s&ab_channel=FilmRiot) step by step and i can´t get it work. Do you mind to give me a step by step tutorial. As mentioned i use windows 10, mocha pro 8.0.2 trial and AE 17.7.0. I´ve tried it now several times = several hours and i did not get it work.
HELLLLP!

Hi sorry i did not see that this fault was happening with others. My Powermesh was working great till the last point update.my Host is Hitfilm Pro and resolution is 1920 by 1080…layers have been trimmed…Frame Rate is 25 FPS. I have included this video for you to study.

Marcel, I have this step by step video which may help: https://borisfx.com/videos/mocha-pro-2021-intro-to-powermesh/

And I have a tips video that might help: https://borisfx.com/videos/mocha-pro-2021-top-powermesh-tips/

Hi Bidean,

I think the problem is your insert and clip aren’t lining up. Mocha is reading the clip length and you are trying to apply the data to the insert but the insert started on frame one and the clip doesn’t. I think @Martinb is investigating this, we it should be respecting the timeline and not the clip.

Cheers,
Mary

Hi, Mary, what is the best way to line them up, never had this problem before,and it all worked well as you see on the video. Will look and see what I can do
Best Regards
Rick

Try compartmentalizing them into a single precomp. That’s what I would do.

lost me Mary, tried with clip and insert both at 88 frames still getting no joy

Sorry Mary but i worked after this as well and it is not working. Tried even delete and reinstall both AE and Mocha trial - still same problem. Any other options to make it work?

Alright. I’ll have to schedule some meetings with you both on Wednesday and see if I can get to the root of the issue.

Please email me at maryp at borisfx.com and we will schedule a remote session.

That’s great Mary, just let me know when on Wednesday.And thanks in advance for all the trouble you are going through with this
Best Regards
Rick

Hi Mary!

Sent you an email. Please look in your spam as well.

Have a nice day!
Marcel

Alright, we have Marcel all set with a few adjustments to pre-comping and moving all attributes into the new comp AND trimming the timeline to the composition to account for some frame offsets when roundtripping from Premiere. And we made some tracking workflow adjustments by starting the track where the object is largest in frame, lease blurry, and most parallel to the camera. That seems to have made the process smooth once again.

I will update with the solutions for Rick later this morning if we find them.

Cheers,
Mary