Objects blocking tracking region

I have a moderate panning shot of a house and gutter to which I must track leaf elements on the gutter. My initial planer spline surrounds the gutter and lower roof shingles.

However, an actor walks into the area of the track region and obscures most of it for a good portion of the shot (but never obscures it completely). However, the track region is visible for most of the head and tail of the shot.
Making the shot worse is the camera person kept refocusing so the background element I must track tends to distort and goes slightly in and out of focus?
How do I tell Mocha to ignore the actor as much as possible, and compensate for the intrusive camera changes? The tutorial case of drawing a second roto on the layer is not obvious as the actor is moving about the scene.
I’ve used AE for some time, but am new to Mocha.

I have a moderate panning shot of a house and gutter to which I must track leaf elements on the gutter. My initial planer spline surrounds the gutter and lower roof shingles.

However, an actor walks into the area of the track region and obscures most of it for a good portion of the shot (but never obscures it completely). However, the track region is visible for most of the head and tail of the shot.

Making the shot worse is the camera person kept refocusing so the background element I must track tends to distort and goes slightly in and out of focus?

How do I tell Mocha to ignore the actor as much as possible, and compensate for the intrusive camera changes? The tutorial case of drawing a second roto on the layer is not obvious as the actor is moving about the scene.

I’ve used AE for some time, but am new to Mocha.

Unfortunately, I am presently stumped as to how to add a new tracking layer. I can find no menu command, or command within the layer window, that says add NEW LAYER.

How is this done?

The HELP menu simply mentions in one section about adding a new layer, but does not give any indication how this is done.

Thank you.

thank you J-P, I will try that.

thank you J-P, I will try that.

Unfortunately, I am presently stumped as to how to add a new tracking layer. I can find no menu command, or command within the layer window, that says add NEW LAYER.
How is this done?
The HELP menu simply mentions in one section about adding a new layer, but does not give any indication how this is done.
Thank you.

thanks for clarification on the tools…following your suggestion I did roto the actor, and to the lower layer added an extra region tracking roof and side of house.

Unfortunately all I got as a result was data that, when viewed in stabilize mode, resulted in a heaving, pulsing shot.

Unfortunately, the production was rushed and I had to abandon this for something else.

However, would it be worthwhile to send you folks a tiny QT version of this shot so you can see the difficulty and give me a brief guess as to whether Mocha, given a lot of time and an experienced user, could actually track the shot and provide useful data?

thanks.

thanks for clarification on the tools…following your suggestion I did roto the actor, and to the lower layer added an extra region tracking roof and side of house.
Unfortunately all I got as a result was data that, when viewed in stabilize mode, resulted in a heaving, pulsing shot.
Unfortunately, the production was rushed and I had to abandon this for something else.
However, would it be worthwhile to send you folks a tiny QT version of this shot so you can see the difficulty and give me a brief guess as to whether Mocha, given a lot of time and an experienced user, could actually track the shot and provide useful data?
thanks.

You can find this at Tools | Create X-Spline Layer Tool (Cmd/Ctrl-L), or using the tool button shown in the attached image.

There’s also a Bézier option, it has the same icon but with B instead of X.

Once you’ve selected the tool, drawing a new spline creates a new layer.

J-P

You should use another layer for the actor, rather than adding a second contour to the first layer. Make sure your layer for the actor is in the foreground (above the gutter in the layer list), make it slightly loose on the actor and track it. The tracking of the actor doesn’t need to be perfect, just make sure your shape contains all of the actor in every frame.
I’d recommend you finish tracking and keyframing the actor mask first before tracking the guttering. You can switch tracking on or off for each layer by clicking the gear icon in the layer list.
Having this layer in front will mask the actor off from the background, so when you track the guttering it will ignore the actor.
You can see the mask that will be used for tracking by selecting the gutter layer, then press “Track Mattes” in the view controls twice (it will switch to “Sel. Track M.”). You’ll see that the actor mask cuts a hole in the gutter layer, excluding it from the track.
To deal with the out-of-focus sections, you might want to increase Min % Pixels used. If you are drawing a large shape to cover the gutter, mocha will default to a low % pixels used, maybe 30%, because it is assuming there will be a good amount of texture in the large area. When the shot goes out of focus, it’s like removing a lot of the texture the tracker would normally rely on. You can help it out by increasing the % pixels used in these sections. Increasing this value slows down the track, but increases the likelihood of a solid result.
Hope this helps,
J-P

You should use another layer for the actor, rather than adding a second contour to the first layer. Make sure your layer for the actor is in the foreground (above the gutter in the layer list), make it slightly loose on the actor and track it. The tracking of the actor doesn’t need to be perfect, just make sure your shape contains all of the actor in every frame.

I’d recommend you finish tracking and keyframing the actor mask first before tracking the guttering. You can switch tracking on or off for each layer by clicking the gear icon in the layer list.

Having this layer in front will mask the actor off from the background, so when you track the guttering it will ignore the actor.

You can see the mask that will be used for tracking by selecting the gutter layer, then press “Track Mattes” in the view controls twice (it will switch to “Sel. Track M.”). You’ll see that the actor mask cuts a hole in the gutter layer, excluding it from the track.

To deal with the out-of-focus sections, you might want to increase Min % Pixels used. If you are drawing a large shape to cover the gutter, mocha will default to a low % pixels used, maybe 30%, because it is assuming there will be a good amount of texture in the large area. When the shot goes out of focus, it’s like removing a lot of the texture the tracker would normally rely on. You can help it out by increasing the % pixels used in these sections. Increasing this value slows down the track, but increases the likelihood of a solid result.

Hope this helps,

J-P

You can find this at Tools | Create X-Spline Layer Tool (Cmd/Ctrl-L), or using the tool button shown in the attached image.
There’s also a B?zier option, it has the same icon but with B instead of X.
Once you’ve selected the tool, drawing a new spline creates a new layer.
J-P

Sure thing, send it over to me at martinb(at) imagineersystems [dot] com and i’ll take a look. :slight_smile:

Sure thing, send it over to me at martinb(at) imagineersystems [dot] com and i’ll take a look. :slight_smile: