Objects not removed from the background

I used this tutorial from BorisFX: Mocha Pro: Solving Complex Object Removes - YouTube
But it seem the remove in my case doesn’t work, nothing is happening when I try to remove the cars from the road (Mocha Pro is calculating something but then nothing is removed after). See the image attached.


I tracked the cars and I put them in mattes (as per instructions from the video) to speed up the process, I tracked the background (in the video there more planes tracked including the background but I chose to track only one big background as a single track).
What am I doing wrong?

After Effects 2017 and Mocha Pro 6.1.1 on Windows

In the tutorial you will notice that while the fg remove can be a matte, the BG tracks must be rock solid and broken up by planar data. You can’t draw a shape around the background as a whole, since it’s many multiplanar objects at once, and expect the remove to remove properly. You have to track the road and any buildings the cars pass by on separate background layers. You have to avoid FG buildings in your shapes. Try that and see if it helps, I am certain the BG track you are using is not accurate based on how diverse the planar data is in your shape.

Can you rewatch that video and notice how the BG is separated out and try again? I bet you’ll get a lot more traction. Let me know and I will be happy to help you!

Cheers,
Mary

Mary, in your video you show what happens if you track a big single plane as a background. But even so when you remove you can see the remove, even if it’s not perfect. In mine I cannot see anything. Nothing is happening. The cars are staying in their place.
Now, I have tried to do the same remove in the video where I used the layers of each car (not the mattes). I chose a car and I removed and I could see it was removed. But when I selected more than one car layer I got an error “There should be at least one surface to fill”. How do I get that working?

Ok, now I tracked the road in two layers, left and right. Is this right? I tried like this and still remove doesn’t seem to do anything.
I don’t have any building which the cars passes by (only maybe the bridge over the highway?)

Yes, you must watch the video to completion. If you notice when I draw that large shape, I tell you it will not get you good results and then show you how to split up the Background. In your shapes, you have the bridge overlapping your shapes, that might throw the track and remove off. Try holding out the bridge.

Also, update your version of Mocha to the latest available to you, you might be seeing an bug we had with holdout mattes and had to fix.

Ok, I tried again. See the image below. Now I tracked the highway in two tracks (see the arrows for “highway”) and linked them together using Link. Then I tracked the highway behind the bridge (I left the bridge out), see the arrow for “back-highway”. Then I tracked the light poles.


And then I removed the cars. The remove is better this time than the first time I tried (I also upgraded Mocha and now I don’t have that problem of nothing happening in the Remove).
See the video of the results. What else should I track to make the remove better? Thank you again.

It still looks like the track is off to me because the texture is sliding where your cars should be removed. Turn the surface tool on and make sure the surface tool is locked to the ground. You may need to track the texture beside the road too where the cars are parked to get best results.

You can also make sure all the shadows from the cars are in the car shapes and you might try using illumination modeling. But all of that looking good is going to depend on that track being rock solid.

Try that and let me know?
Mary

I will have to look what this is…maybe I’ll find some tutorials on your Youtube channel about this.

It’s in our documentation here: Boris FX | Mocha® 2020 User Guide

Illumination Modeling specifies how to model changes in illumination in the remove module.

The None option will not model changes, giving you a result very quickly.

Linear will model global changes and should hence be used if the brightness change between frames are caused by e.g. changes in aperture. It affects all pixels inside the remove shape globally.

Interpolated will model global and local changes and is often useful when a cleanplate is used. So it takes into account the pixels along the edges of the shape and will change the pixels inside the shape based on the color of the pixels outside the shape and blend them together.

Smoothing Level controls the amount of smoothing applied in the Interpolated model. Increase the value if there are artifacts which might be resolved with more smoothing, either spatial variations or temporal variations. But this can severely increase render times so use with care.

This is killing me :slight_smile:
I tried again by tracking the cars on the left side only, then tracked the highway, the wall in the middle of the highway, the wall on the left of the highway, and the alley were cars are stationed. Then I linked the highway track, walls tracks and alley tracks together before doing the remove. See the image below, those white lines.


See also the video…it seems that the track of the highway is not good? The planar surface and grid keeps slipping…and I tried to adjust them…and I adjusted the track as well.
When I removed I tried Illumination Model None and Linear, with the same results (pretty much like in the video above were I did my first try).

(here is the link in case you cannot see it here Dropbox - File Deleted )
I am out of ideas what to do next…I wanted to try now the left cars on the highway to see if the remove works and it doesn’t.
Could I send you the raw video to have a try, Mary, if possible?

PS.
By watching this video of yours too I see the road is tracked unlinked (link to track: none). Should I do the same? mocha Pro 5 Plug-In: Remove Module Quick Tutorial - YouTube

Definitely send me the raw video and your mocha file and I will see what the issue is. :slight_smile:

MaryP@BorisFX.com

Mary, I sent you the files in the email. Thank you.

I have them downloading, I will check them out soon!

1 Like

Any news, Mary :)?

Hi Miki,

Check your email, I sent you a response April 7th, about three days ago, with a Mocha file attached. Basically the gist is it was mostly your track that wasn’t right. However, You might actually get better results from making a cleanplate for this as well, because the cars at the front of the shot aren’t removed, there isn’t enough data. Make sure your car shapes grab the shadows for all the cars too. You won’t get any artifacts from car shadows left on the road that way.

Take a look at the mocha file to see how I got the track. I tracked either side of the road, used that as the track, linked a new shape to that and split it where the bridge crosses the road. That seems to have locked the track down. Which seems to have been most of the problem. If you need to take cars off the bridge, you need a separate track for that and for the buildings they pass over. But the left and right side of the road can use the same track.

Load the attached mocha file from your email into your mocha pro plugin interface and it should work for you.

Cheers,
Mary

Oh, I thought you will respond here first :), didn’t think you will reply to the email first.
Thank you, I will take a look and let you know…making a clean plate means a lot of Photoshop but I will try that too.

Not as much as you think, only a little bit of photoshop at the beginning of the shot.

Oh, so I don’t have to remove ALL the cars from the road? Just those in the beginning?

I only saw problems at the beginning of the shot.