Occlusion top layer not working

Hey guys, i have a failry simple scene. There’s a wall that I want to put some text on…at a certain point, a girl walks by and block the wall (only partially)…

Based on this, i followed this tutorial

What I did was…

  • opened in Mocha

  • splined the girl and tracked her (call her layer ‘girl cutout’)

  • clicked the little cog next to the layer

  • splined the wall (call that layer ‘wall main’)

  • made sure the wall layer was below the girl layer

  • tracked it

But still, the girl is pushing and deforming the wall spline

Is there a setting that I am missing?

Some things to check:

  1. Turn on Track Mattes and make sure she is completely cutting out the area you need.
  2. Make sure what she is covering isn’t your main area of texture. If it is, it may just mean you need more detail to track somewhere else on the wall
  3. What version number of mocha are you using? Legacy versions did have a bug in tracking order that was fixed in V5
  4. Try turning on “disable offscreen buffers” in preferences and reboot mocha as a last resort. It could be your graphics card/drivers are causing the mattes to not be drawn correctly.

Hi!

Thank you for your reply…to answer your questions:

  1. Im not sure what you mean with make sure she cuts out the area you need… And how do you turn on track mattes?
  2. she’s just covering a small part of the wall, which has the same texture all over
  3. Im using 5.2.0
  4. tried that…didnt work :frowning:

here’s the scene, it might help

So i marked the part of the wall that I want to put a text on in red (so you can see)

and this is what the splines are doing when I track

So she just just pushes the wall spline to the side…

Hopefully you can help me out, thanks again for your help so far

You haven’t covered her completely there. Her arm and hair are still uncovered by her mask. Keep the foreground mask entirely covering her body and it will probably track better.

However you’re also trying to track a low texture area, as those lines are only horizontal.
Does the pole and tree have much parallax in front of the wall? If not, i’d recommend adding them into the tracking shape to help lock down the track.

1 Like