Opening particle illusion bpi files saved in optics 2022 in PI standalone

I have a question regarding how the particle illusion plugin saves PI projects and how they then are opened in the PI standalone. So for example, let’s say I have a 3500x5300 pixel image in Optics that I’ve decorated with PI emitters etc. I then send this to the PI plugin using the Launch Particle Illusion button in Optics. That all works great, image seems to open in PI at the image resolution (enunciated to the upper right as 3500x5300). But I find that now, while in Particle Illusion, the current Project Settings (under View->Project Settings) aren’t 3500x5300 but something different, for example the stage size may be listed as 720x480 and it can’t be modified in the plugin version of PI. The reason I’m asking is because if I now save the PI project as a .bpi file to open in PI standalone later, for example for rendering, it will open at 720x480. Does this sound correct?

Hi there,
I believe this is a bug or feature request that can possibly be addressed in the future. I can confirm that Particle Illusion when launched from Optics can not change the project dimensions. So as you say, when you open a PI project saved from Optics, it opens at the default saved size.

I just did a test and If I understand your workflow, you can simply open your saved PI project in the standalone, then go to View>Project Settings. Then manually change the size to match the source image you were using in Optics.

Does this help?

Thanks rosss. Yes, likely a bug. Your workaround didn’t work for me, however. Here is a quick example. I created a 2000x2000 pixel image in PS, went to Optics 2022 and added a particle emitter, positioned to the right of the frame and scaled to 250%:

From inside Optics I did a Launch Particle Illusion (and FYI in the standalone PI before doing this I purposely set the stage size to 2000x2000), and then saved this as a .bpi. This all looks right:

Then I open standalone PI (stage initializes at 2000x2000), but when I open the saved bpi it sets the stage to 1920x1080. If I scale manually to 2000x2000 that only scales the emitter size and not the stage size (and note the emitter stays centered, not positioned to the right). This isn’t a big deal, it just means I need to set everything up again manually if I want to render. But I figured it’s good for the programmers to be aware. Thanks for the help! Optics 2022 is awesome!



Thanks for adding your response. I have raised the issue with the team and we are having the Particle Illusion team address it. Not sure when this will happen, but probably the best advice is if you know you are designing for animation and video purposes to use either the free standalone application or the PI plugin.

Not sure if you use After Effects, but the purchasable plugin version adds some very nice features to use the AE camera controls and also has integrated Mocha for tracking. It is available inside of Continuum or as a premium filter.