Opening project in different plugin instances - Shape disappears

Update March 7, 2023
Gonna Repost this in a new thread as I’ve simplified the issue on my end.

Mocha 21.5 OFX plugin / Resolve 17 / Mac OS 10.15.7 / 32GB Ram / 2GB VRAM metal GPU.

Not sure if this should be in the BCC forum or posted here.

I need to add an inside matte in Primatte but the mocha widget inside Primatte does not play back the clip, so I wanted to use Mocha Pro on the edit page to crate the animated matte shape then transfer that to Primatte.

On the edit page, the matte view in Mocha Pro viewer looks good. I need to apply that mask to the BCC Primatte “inside mask” using the mocha widget. This instance of BCC Primatte is on the color page.

From the BCC Primatte interface, I open mocha from the “inside mask” dialogue. Then I load the project that I created on the edit page. The project opens fine but the shape is not there.

Is this the wrong workflow or Is there a workaround to get the shape into BCC?

Mocha Pro is not really supported on the edit page of resolve. It’s best used on the Fusion page.

But are you saying the project layer exists and you can’t see the frames, or there is literally nothing in the proiect?

Hi Martin,
If I recall correctly, I received a response on that in the effect that every plug-in instance was a new project such that it’s not possible to open a saved project from another instance.

So I’ve moved away from that workflow. I posted the latest thread on the Mocha forum regarding my efforts to export and import spline shapes, which is still an issue.

Here’s where I’m at.

My latest method that I thought would work to get the matte I need for the comp is to create the roto shate in Mocha Pro then export the project. I then merged the project into the Mocha Matte group in Continuum Pixel Chooser node.

That worked as you can see, except that the shape that came into the continuum plugin is not animated over time. It’s the same frame repeated all the way down the timeline.

New troubleshooting update. To test Mocha Pro’s export function in general, I did a fusion .comp export (copy to clipboard and paste) of shape data. To be safe, I did the export using a mocha pro node on the fusion page. The result was the same as the merge project method detailed in my last post. Again, the shape came into the new host software but it was stuck on a single frame of data, no animation over time.

Is it the same frame range? i.e when you did the work in Mocha Pro, what was the list frame range in the timeline vs the import? It’s hard to tell from the fusion timeline.

The mocha frame range was 12 frames long. The clip that the shape is being merged into on the color page is a compositing foreground plate that is 18 frames long.

You can ignore the previous dope sheet as that one was edited. Here’s the original unedited dope sheet.

Ahhhhh! I figured it out!

Based on your question, I went back and created a new BG plate that matches the length of the effect. Now the merge works to animate the shape based on data in the keyframes. I just had to move the keyframes on the dope sheet to the right spot.

I’m good now. Thanks for your help.

1 Like

Great! Glad to hear it worked!
This is the problem with editors with plugin workflows. Keeping track of the offset is a real pain!

1 Like

Arggggg. I went back to the project today to continue the compositing and found that the shape is no longer animating. It’s frozen again. :slightly_frowning_face:

Found Solution. It involves converting the Mocha shapes to fusion comp shapes and piping them into the color page for use there. Here’s the link to the Borisfx training video covering the process.