Optics insists on importing layers I deleted

I’ve got a picture of a girl holding a wand over a grey background that I want to work on in Optics then export to PI. She’s wearing a shirt similar in color to the background so I can’t key it out in my editor. I removed the grey background in Photoshop because the masks created in Optics don’t work in PI. I then applied the Optics filter. But when the image opens in Optics, the background is still there, even when the layer with the girl is the ONLY layer in Photoshop. I also tried adding another layer with an image below the girl. Same result.
How can I mask out a background when Optics keeps putting it back in?

I don’t know what ‘Smart objects’ are :man_shrugging:

If you send a layer with a Photoshop mask to Optics you have options in the viewer to see the image over black or straight.
image

If the mask came from PS and the viewer is set to Black, you should see your image over a black BG.

Often in my workflow, I send a mask from PS to Optics, but I want to see the full image and use the mask on an effect. A useful workflow is covered in this video.

Under the Color category, apply the S_ChannelSwitcher. The should be a “Remove Alpha” preset that will remove the mask for this Optics layer. Then you can drag this mask up to other layers. This allows you to send a mask from PS to Optics but selectively uses it on particular effects. Hope it helps.
image

As mentioned in other threads, the mask can be used to mask any Optics effect but can not be used within the Particle Illusion user interface for masking video animations.