Optics "not responding" nearly constantly

[UPDATE: a hypothesis is licensing related. See lower reply.]

Hope this isn’t duplicate (I did spend a few hours searching and trying my own (failed) troubleshooting before posting). Any pointers to get better logs, diagnostics, or other tips to resolve this would be appreciated.

Main symptoms:

  • (minor) launching Optics goes unresponsive for 5-10 seconds (if try to click/mouse, it adds “Not Responding” to the Windows title)
  • (killer) trying to apply filters - (I only use the S_LensFlare and S_LightLeak), it seems to go into cycles of being responsive for 5-8 seconds - e.g. dynamic, responsive light-effects with changing controls, then will freeze for about 10-15 seconds. Constantly. Repeatedly.
  • This applies if I try to adjust any controls on-image, OR if I use any settings-sliders.
  • Every “first” try to manipulate anything seems to go “Not Responding” and freeze for 10-15 seconds before anything is usable.
  • Changing an effect, same 10-15 second everything frozen.
  • Changing a layer, transparency, etc., same 10-15 seconds everything frozen.

Bottom line: what should take 1-2 minutes to decide an effect and apply to an image takes - quite literally - 20-60 minutes. For one image.

This didn’t seem to happen some months ago when I first purchased. Since then there have been many windows & drivers updates, an Optics version update, etc. I don’t use daily and primarily purchased only for ‘lens’ type effects to enhance some landscape/travel photography.

Unfortunately at this point, it’s effectively bricked for me. :frowning:

Things I’ve tried:

  • updated NVidia drivers
  • ensured all Windows updates applied
  • tried the GPU tips in Windows and NVidia control panel in this other thread
  • tried different Preview resolution, GPU rendering on/off, Downsampling settings within Optics
  • tried normal images in variety of cases (larger 40+ megapixels, smaller 10 megapixels, TIF/JPG, 8-bit depth, 16-bit depth, etc.)
  • ran stand-alone and invoked as PS plugin
  • ran Optics with nothing else running (like no background YouTube vid, etc.)
  • inspected with Process Monitor
    ** usually taking < 1 GB RAM - so plenty more available
    ** when ‘frozen’ seems only taking 0-1% CPU, so that doesn’t seem an issue
    ** watching threads/tasks, seems mostly Optics.exe, nvopencl64.dll, nvoglv64.dll in use. When it “is” responsive, I see a bunch of ucrtbase.dll threads in action, and they seem to fall out of use when it becomes non-responsive again. (But I am not expert enough to have any clue if this means anything.)

Any advice or tips to troubleshoot, or find more details would be appreciated. I’m happy to help diagnose, but right now am really frustrated as it’s completely unusable for me.

Welcome Eric. Sorry that you have been experiencing these issues. Something is definitely not right. Can you let me know the make model of all graphics cards on your system as well the the CPU make and model?

Glad to hear it’s not normal. Here’s some extra info, but let me know if this is detailed enough… This is a recent build/buy deliberately for upping my Photoshop/etc. performance.

System: CUK Stratos PC (Intel i9-9900K, 64 GB RAM, 500GB NVMe SSD)
GPU: NVIDIA GeForce RTX 2080 8GB, Bios 90.04.23.00.17, Driver 460.89, DirectX Runtime 12.0

Your i9 processor has a feature called SMT (Simultaneous multi-threading) and we have seen this cause similar issues on AMD processors. Can you try turning off SMT (Simultaneous multi-threading) in the bios and let me know if that makes solves the problem?

Seems that’s what Intel brands “hyperthreading,” correct? Let me know if that’s incorrect.

I disabled that, rebooted. No effect. Still seems identical with the pauses/freezes.

(Also note this was working fine some months ago when I first purchased. Same computer, same bios set-up.)

(Minor update: well, that was an adventure. Bios change seemed to hose a number of other things. Seems odd or coincidence. But Windows power-shutdown commands no longer worked and Bios didn’t respond to mouse or keyboard. Spent last 1.5-2 hours trying to get it back functional.)

I also updated the Bios, which had a ~1yr newer version. But after re-trying Optics, still has same behavior as before. Not-responding part of start-up, then the cycle of 8-10 seconds working then frozen, then working, then … etc.

Grateful in advance for any other suggestions. I’m a bit gun-shy trying too much at this point. Might just abandon the SW.

Yes, hyperthreading is Intel’s version of simultaneous multi-threading.

I’d be happy to jump on your machine and take a look if you are willing. If so, private message me and I can provide you details.

That might work. Let me try one more thing; bbiab.

Does this only happen with S_ effects? What about the non-Sapphire effects? Do they work as expected?

@paul.miller, yes, only seems to be an issue with the “S_*” effects. Though those are the only/primary use for which I wanted the package. Other effects seem to be okay, as far as I could tell with some quick tests.

@marco - my other experiment didn’t yield anything. I’ll message you if we can try remote desktop control…

UPDATE / recap (for posterity, in case stumble on this thread)…

Had a good call with Marco and Paul (thanks both!) to try a few things. This confirmed it was definitely unexpected behavior, and did seem different than they had seen before.

After a number of troubleshooting steps, the current hypothesis is it’s related to the Sapphire licensing enforcement when running inside the Optics overall application. Other Non-S- filters seem unaffected. When Sapphire ones are seen as non-licensed, the UI responds normally including filter controls. (Though they won’t render and are blacked-out due to lack of license.)

We don’t know why the license check is taking so long on this particular environment. Something for further investigation. We did try a different license config which makes it better, definitely noticeably less freezing, but still not up to ‘normal’ behavior.

The team will look further. I look forward to any updates.

Thanks for posting the update!

1 Like