Optimal tracking target?

Is there such a thing?

To be more explicit, I want to track an object (a ball) being tossed between two people and the camera will be perpendicular to the plane the object will be moving in. The recording frame rate will be high enough that blurring shouldn’t be an obstacle very often, if at all.

I would expect a shiny object wouldn’t be a good choice and could do anything from flat color to a pattern on the ball.

Are there any recommendations I could start from to make it easier on mocha to follow the object in the scene?

I suspect that solid color would be best, but other than that Mocha should be able to track it fine.

@Alan_Lorence this may be a dumb question but I don’t want to go farther down the rabbit hole only to find out I should have asked the dumb question.

I started out thinking that using the tracking built into the Particle Illusion fx would be the right thing to do, I want the emitter moving and don’t need world transforms as the camera isn’t moving.

Having used corner pin studio for another purpose, I’ve been put off by the lack of keyframes when I have to make changes to the tracking position over time when doing the emitter tracking.

In order to get the tracking I thought I needed I ended up creating a bezier layer, tracking that, adding keyframes as the tracking needed help and linking the emitter layer to that tracking layer.

Does that sound like the right way to go about this or did I miss something fundamental earlier on?


If you’re talking about using Mocha to track the emitter, you CAN create keyframes to help the tracker, but you do it inside Mocha. The keyframes don’t show up back in the host, but they’re there when you open Mocha again.

Take a look at this video tutorial:

@Alan_Lorence somehow I got mocha in a confused state. Likely because I wasn’t using the world center properly.

I found that adding a keyframe manually would move the emitter offset in strange ways. After watching those videos, I started fresh. If I properly put the world center on something static, that’s not happening.

Should keyframes be added automatically when moving the emitter or world offsets? Automatic insertion is enabled but I found I have to add them manually if I want them.

[time passes while I’m gleefully adding keyframes until…]

I discovered that they’re not doing what I think they’re doing.

I went back through my timeline and found that the keyframes save the search area location but not the emitter offset?

When tracking gets lost, I’ve tried both adding a keyframe and then moving the offset and search area back where I want it as well as moving then adding the keyframe. No matter what, once I move either the search area or the offset, it moves the offset location on previous keyframes as well.

I can post a video if none of this makes sense

A video would help I think. Thanks!

@Alan_Lorence Will do.

Another bit of oddness. Keyframes are being automatically created for me when I move the search area. They most definitely were not earlier today.

I’ll get the video out asap

@Alan_Lorence Here’s the video. - YouTube

I didn’t realize until after I’d recorded the video that my thumbnail inset covered up the view of the buttons in the lower right. Auto keyframe generation is turned on and just in case the state was displayed wrong, I tried moving the search area with it both enabled and disabled and couldn’t get a keyframe unless I added it myself.

Also note, it turns out this reflective ball works really well as a target because it’s got a transparent layer that creates a nice edge glow and the fact I’ve got 5 lights in the room means there are several specular reflections for mocha to lock onto.

@Alan_Lorence any thoughts on the keyframe issue?

Can you send me the source clip so I can try it out myself?

@Alan_Lorence sent through PM

@Alan_Lorence I can’t prove this but I have a hunch the keyframe failure could be related to deleting PI fx on an event in VP and re-creating it. Perhaps something in the mocha cache getting out of sync?

I was starting a new tracking project this morning and after going the wrong route with tracking decided to start over by deleting the PI fx from the video event on my timeline in VP and adding a new PI fx instance to the chain.

After that, keyframes weren’t being automatically generated when I moved the search area. They were before with the same vp project, vp session and event.

I haven’t had a chance to repro that from scratch but will do that soon.

@Alan_Lorence I’ve looked into this further and haven’t been able to cause any problems by deleting fx from an event and starting over from scratch. I have found a case I seem to have where subclips of a file seem to cause VP to crash half the time when I start mocha, but that’s a problem I’ll write up elsewhere.

One thing I’ve found that I could use your input on is… I’ve found that keyframes won’t automatically be added to the project when I move the search area until I manually add at least one keyframe. Once I do that, keyframes will be automatically added from then on. Does that sound right to you?

@Alan_Lorence To summarize, because this thread’s getting long, there are two issues/questions remaining.

  1. Is it correct that keyframes shouldn’t be auto-added unless at least one keyframe has been manually added?
  2. The emitter offset isn’t part of a keyframe. It’s saving the search area position but the emitter position moves around somewhat randomly at other keyframe positions whenever it’s moved on the timeline.

@Alan_Lorence any thoughts on the keyframe failures? I just started a new track with corner pin on a clip that was working fine a few weeks back. I wanted to tighten up the track and decided to start fresh. With this project no keyframes are being created automatically.

Anyone know why keyframes aren’t being generated automatically and if the emitter offset should be part of a manual or automatic keyframe?