Particle Illusion Motion tracker Adjust track not working

Hi, it might be working fine but i opened Particle illusion, added a flame to the exhaust on this trike, then tracked the motion with the Mocha tracker, it needed a little tweaking with the Adjust track, that was no problem


I added Particle illusion to the same clip & repeated the same steps, tracking etc, but i can’t now adjust either track, the options are greyed out even tho it shows the Adjust tracking i did earlier?

this is the second Particle illusion, i don’t have the Adjust track option?

Have i got to turn something on or have i turned something off? :joy:
Or maybe …

PS i just tried deleting the second Particle illusion, now in the first & only one, Adjust track is still not lit up?
I’ve cleaned & restarted my PC. I tried Resets To Defaults on the button at the top. no Adjust track,



Thanks,

PPS I checked Mocha Pro, that seems to be working fine, Adjust track is there & working :+1:
So i went into Vegas set-up/temp files deleted those so it would have to re-initialise/load the plugins, then restarted Vegas, all plugins reloaded as i expected but still no Adjust track in Particle Illusion tracking.
so i reinstalled The latest Continuum (Continuum_2021_5_OFX_Hosts_14_5_2_Windows) which i updated a short time ago, a wk or so, Still no Adjust track in Particle illusion,
I’m guessing i’m doing something wrong, but i did it without any problem in the first place, ?
Thanks again.

There seems to be some quirk with Adjust Track – sometimes it’s enabled with the default layers (“Emitter”, “World”) and sometimes it isn’t. Maybe it mostly isn’t.

I haven’t tried this myself, but if you create a new layer in Mocha and track with that, then use the “Link to track” dropdown to link it to “Emitter” or “World” or whatever you need… that seems to let Adjust Track work.

1 Like

Thanks, I think i did as you suggested
I tracked the tail pipe with a separate layer then linked it to the World Centre,
I also tried tracking with the World Centre layer & linking it to the new layer 3,
I’ve tried a couple of combinations Linking & tracking, I can Adjust track on the new Layer 3 but
when they’re linked the blue cross hairs of World Center follows the red track, not the blue sq
of the Planer surface of Layer 3 which is the bit Adjust track changes.
I hope that makes sense,
In these pics the red track changes shape, i’ve tried tracking to get the shape to stay fairly regular
but the blue + World emitter is following the red tack so Adjust track isn’t any help either way.





Hi

It looks like you’re really close to getting it, but you missed one checkbox. I’ll run through a quick how to track with AdjustTrack :

  1. Turn off visibility and the process cog on the World Center (and/or Emitter Offset) layer(s)
  2. Create a new layer shape and track it.
  3. Turn on the Surface and position the center point where you want the World Center to be. It won’t matter where this is, it’s just a visual reference point at this time.
  4. If absolutely necessary, use AdjustTrack to nudge your Surface center into the right spot.
  5. Turn Visibility back on, on your World Center layer.
  6. In the Link to Track dropdown, choose your tracked layer. Remember to turn on the checkbox next to Adjusted.

  1. Reposition your World Center point to the correct position in the image. Play your clip through and it should match perfectly. Do not look at the shape, only the blue cross is important, as this is the data that will be transferred to the plug-in.

  1. That’s it. You’re done. Save and Exit and you’ll see the data show up in the plugin.

Hope that helps,
Ben

1 Like

Thankyou, i need to play with it more later when i have time but yep that seems to work on a quick test i just did, & yep i’m aware it’s the blue cross that’s the important bit, that’s what i was trying to show in the pics, Yep that one checkbox :+1: the key was to tick just that one Adjusted box next to Link To Track to transfer that adjusted data from the new layer to the World centre layer, instead of just the tracking data :+1:
funny how close you can be & get so frustrated when just one little tick in a box resolves everything :rofl: :+1: