Particle illusion render dialog filename crash

It’s a small thing but easy to do at 3am…

If you enter a path without a filename in the “output to” field, PI simply crashes when you click “start render”.

I do a lot of work in Vegas Pro and was in a frame of mind where I expected that to field be an output directory like in VP. It wasn’t until I’d crashed PI a second time that I realized that PI probably wanted a path and filename.

Like I said, 3am…

[added later]

This crash had the side effect that I had to reboot my machine before I could start VP. It was stuck at the GPU init stage.

Hi Michael,

Interesting … I’ll take a look at that and if I can reproduce it then I can ask engineering to fix it.

Thanks for reporting this.

Cheers,
Peter.

@PeterMcAuley Thanks. I should have also included the following for that last detail…

Processor Intel® Core™ i7-8700 CPU @ 3.20GHz, 3192 Mhz, 6 Core(s), 12 Logical Processor(s)
BaseBoard Product ROG STRIX Z390-E GAMING
Installed Physical Memory (RAM) 32.0 GB
Adapter Description NVIDIA GeForce GTX 1660
Driver Version Studio 27.21.14.5177
Resolution 1920 x 1080 x 60 hertz
Video Memory 6G GDDR5

Thanks Michael. We’ve not had any luck in repro’ing this result using both the retail version and the beta version of PI - would you mind please generating a very specific set of steps that our QA techs can follow. It’s possible that they are missing a step, which is why it’s working as expected for them.

  1. Click “render”
  2. Into “OUtput To” field type the name of a destination folder. In my case it was “c:\temp”
  3. Leave everything else as the default
  4. Click “Start Render”

Ok, it looks like the problem is directly related to using c:\temp

I initially started checking the steps and decided to leave my settings as they were when PI came up which meant it was going to e:\temp, yes I have multiple temp folders, for reasons.

That worked ok. It actually created a file e:\temp.mov

I tried changing the type to mp4 and that still worked.

I changed the path to c:\temp and boom.

So, it’s probably a permissions issue under Windows when PI tries to create a file in the root of C:

Here’s the error info from event viewer in case that’s of help. If PI has any logging I can turn on, I’ll be happy to.

Faulting application name: Particle Illusion.exe, version: 0.0.0.0, time stamp: 0x5eebce5f
Faulting module name: ucrtbase.dll, version: 10.0.19041.1, time stamp: 0xbd1e2564
Exception code: 0xc0000409
Fault offset: 0x000000000007284e
Faulting process id: 0x1080
Faulting application start time: 0x01d669ad6ba18f27
Faulting application path: C:\Program Files\BorisFX\ContinuumOFX\13\lib\ParticleIllusion\Particle Illusion.exe
Faulting module path: C:\Windows\System32\ucrtbase.dll
Report Id: 527aefb7-fbe4-45d6-9fb1-7d5657da273a
Faulting package full name:
Faulting package-relative application ID:

Thank you! I think you’re right in that this feels like a permissions issue. I’ll pass that info along to see if it’s reproducible when attempting to write to c:\temp

Thanks Michael!

Issue reproduced and ticket filed. Thanks for reporting that and providing the steps to reproduce the issue Michael!

You’re welcome! Did I see you mention a new beta? Is that just for PI or for Continuum as well?

We have a few beta blocker tickets that we’re working on but we should have a new beta for testing fairly soon with some very cool new features. :slight_smile: And it will be a Continuum beta, which includes Particle Illusion.