Paste Mocha Camera Confusion

I’m doing a camera solve and after some time practicing, (forgetting to put layers in the proper order is a huge pain) I managed to get my solve to 100 percent. I copied my camera solve data to the clipboard for After Effects, and when I used “Paste Mocha Camera” my three layers had the proper 5 nulls attached and the camera layer at the bottom. The issue is that my values for position are huge. Like incredibly large and I can’t seem to see the nulls or anything for that matter.

for example the values for position on the “floor center” null is:

Position: -3.402820e+038, -3.402820e+038, -3.402820e+038

Those are x,y,and z values respectively and all of the layers are like that. Even the camera position data is crazy like that. The rest of the values are normal but it seems that my nulls and camera are somewhere lost in 3d space. Any Idea what this is? I can send screen shots or videos if need be, but its a little frustrating because I thought I finally understood how the camera solve in mocha works lol.


What I usually do nowadays when doing a 3D camera track in After Effects is “normalize” the nulls and camera from Mocha. Watch this tutorial on Video Copilot to learn specifics. You’ll see that 3D camera tracker is being used in the tutorial, but I think most or at least part of the information is relevant to doing a 3D camera solve using Mocha. In the tutorial, the nulls and camera come in with really great values (like you’re experiencing). By taking 5-15 minutes, you can normalize those nulls and camera to have an easier time adding elements into your scene.

Here is that tutorial:

That’s a great idea. I can’t seem to even see the nulls though. I can parent everything to the normalized null, but i can’t seem to go from there. Looks like I can’t find anything else besides the normalized null I created. Top view, Front view, zoomed out…nothing else shows up. Not even when I scale up or down the null they are all parented to. Any ideas?

Similarly, you could use Mamoworlds Orient World script Orient World | mamoworld which was inspired by Andrew Kramers examples.

This is odd. I saved the Mocha project and made sure my tracks were good, and made my surfaces a little bit smaller as per one of the mocha camera solve tutorials, and now I’m getting a solve quality of zero on auto. small parallax is around 30-40 percent and zero on large parallax. I actually didn’t change any parameters or re track anything (All gears were turned off once I made a good solid track). I’m wondering what could make it come up with a solve of zero when a couple hours ago the almost exact same track was 100.